mac mini starts up to blue screen with loading icon... cannot figure this one out

Discussion in 'Mac mini' started by montana111, Aug 15, 2010.

  1. montana111 macrumors newbie

    Joined:
    Aug 15, 2010
    #1
    I have a mac mini that I am supposed to fix for my uncle. It had a disc stuck inside and would not boot up properly is what i was told. I got the disk out, (it was a blank cdr i think) but the computer is still not booting up correctly.

    This is what happens when i push the power button and do nothing else:
    1) hear startup sound
    2) gray screen appears followed by an apple logo and a loading icon (spinning disc looking thing)
    3)after a while a blue screen comes up and has a pointer in the upper left corner. after about maybe 10 to 20 seconds a spinning disc loading icon shows up.
    4) the disc will come and go but nothing ever changes and my desktop does not load.

    Here is what I've been working with:

    I have two gray install disks, one for os 9 and one for os x. they are both labeled "Mac Mini". the os x one says it can be used for some type of hardware utility as well as an install disk. the os 9 one says its just an install disk. I've tried putting them in to boot from them but i cant get anything to work, it just spits out the disk before anything happens. I've tried holding down the "x" key or the "c" key on startup but that doesnt solve anything either, nothing actually changes when i do this.

    Another thing i've tried is to hold down the shift key on startup and its supposed to take me to some magical place that will fix my problem, but when i hold down the shift key on startup, after the grey screen the computer will just shut off.

    A third thing that i've tried is holding down the alt-command-p-r (or something similar... im using a windows keyboard) on startup and this takes me somewhere strange where i get to a blue screen with 3 icons. on the left there is a "refresh" type icon with a circular arrow, an icon of a hard disk, and another icon on the right is an arrow pointing right. I also see a mouse pointer that keeps switching between a watch/clock and a pointer. I cant control the pointer with my mouse (usb connected). I pushed the spacebar or enter key and something happened and then the computer booted into the gray screen --> blue screen with nothing again.

    can someone please help me? what am i doing wrong? a clean install or anything to get the computer working again would be fine. thanks in advance!
     
  2. MaxMike macrumors 6502

    Joined:
    Dec 6, 2009
    #2
    Did you try putting the OS X disc in and holding OPTION before and while it boots? Usually that is what is used for macs from like 10 years ago to boot from a disc in my experience
     
  3. montana111 thread starter macrumors newbie

    Joined:
    Aug 15, 2010
    #3
    thanks! so this boots me up into the select startup volume area that i described above, but only shows a hard disk option along with the two other arrow buttons. I can move my mouse now, but i cant click on anything. If i press enter the computer boots up to the blue screen...

    The install disk pops out of the mac before i can even get to the select startup volume screen. Any other ideas? it seems like it would be useful to be able to click on the refresh arrow in the startup volume screen, but like i said, i can't click on anything

    ??

    thanks again
     
  4. montana111 thread starter macrumors newbie

    Joined:
    Aug 15, 2010
    #4
    just took another crack at it. If i hold down option as suggested i get to the startup manager where i can pick which disk to start from. If i reinsert the install disk and push "s" on the keyboard i can see two new disks. One is for the install and one is for the hardware utility. I would select either of these, but i cant use the arrows to select them or the mouse. all i can do is press space bar or enter and it boots from the hard disk into blue screen.
     
  5. PraiseTheLard macrumors newbie

    Joined:
    Aug 23, 2010
    #5
    I just had the same issue and I solved it! Get ready to sacrifice all your settings though (Dock, finder settings, etc) You can import everything carefully later.

    Press COMMAND+S when you turn on your Mac so it goes into single-user mode.

    Type the following commands

    When you login all your settings are reset, but everything is normal and theres no longer a looping bluescreen or for people with login screens that get logged out immediately after. After you can go into Preferences_old and copy all the other plist files. I didnt copy any apple plists though. Might look into which one might've caused it.
     
  6. Giuly macrumors 68040

    Giuly

    #6
    Try deleting the settings like suggested.

    Else, if you want to boot from the DVD to reinstall the system, insert the disk, hold the "C"-key on the keyboard and power it on.
     

Share This Page