Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

super_kev

macrumors 6502
Original poster
Jan 12, 2005
356
2
USofA
Got a Mac Mini (mid 2010) and noticed that during file transfer my speeds were just around 11MB/s. All the other computers in the network are 1000, so I changed the cables a few times, changed ports on the Netgear switch (connected to a Tomato router), but no dice. Network utility reports 100Mbit, and changing/forcing it to manually connect at 1000Mbit/s (full-duplex, full-duplex w/traffic, etc., std. frames, jumbo frames, all combinations thereof) cause it to not connect. It'll only connect at 100Mbit speeds. Cable is 6-7ft long, one cat5, other cat5e, tips good, all looks fine from what I can see. Any thoughts?
 

Stephen.R

Suspended
Nov 2, 2018
4,356
4,734
Thailand
Are you sure the cables you're trying to use aren't damaged: i.e have you used a cable tester to ensure continuity of each pin/wire, or (probably simpler if you don't have a tester) tried to use them with another machine?
 

Banglazed

macrumors demi-god
Apr 17, 2017
4,145
5,951
Cupertino, CA
Are you using the cat 5 for Mac mini? That cable can only deliver up to 100mbps.

Use cat 5e and above for gigabit speed. Have you tried to reset the network adapter on the mini? Is the switch unmanaged?

If all devices connected at full link speed, it’s possible a fault port on the mini. Try to reset the network adapter. If still no dice, you may need to replace port or use a Ethernet dongle.
 
  • Like
Reactions: wardie

super_kev

macrumors 6502
Original poster
Jan 12, 2005
356
2
USofA
Shucks, reset the adapter and no dice, and cables are cat5e so I guess I'll buy a USB to ethernet adapter.
 

mannyvel

macrumors 65816
Mar 16, 2019
1,153
1,964
Hillsboro, OR
is the port set to manual? If not, try setting it to manual and force the speed. Auto-negotiation does fail occasionally.

Also, you might want to peek into the port and see if some of the pins are bent.
 

Stephen.R

Suspended
Nov 2, 2018
4,356
4,734
Thailand
Shucks, reset the adapter and no dice, and cables are cat5e so I guess I'll buy a USB to ethernet adapter.
Did you try the cable(s) and port(s) with another device(s)? Essentially, have you confirmed the ports you're trying to use, and the cables you're trying to use, actually operate at Gbit speeds?
 

Fishrrman

macrumors Penryn
Feb 20, 2009
24,184
9,589
OP wrote:
"I guess I'll buy a USB to ethernet adapter."

If you do this, could you come back here afterwards, and report if the adapter fixed the problem and is giving you the proper speed...?
 

Boyd01

Moderator
Staff member
Feb 21, 2012
6,281
3,144
New Jersey Pine Barrens
Sorry if I'm missing something here, but doesn't your 2010 Mini only have USB 2.0? If so, I don't think you can get gigabit speed from a USB adapter. The highest speed I've ever gotten with a USB 2.0 external disk drive is about 35 megabytes/second, yet the same drive runs at about 170 megabytes/sec on a USB 3.0 port. Gigabit ethernet should give you over 100 megabytes/sec.

A few years ago, I wanted an ethernet adapter for my 2013 MacBook Air, and Apple's USB adapter was only capable of 100baseT. I ended up getting a third party USB 3.0 adapter, which did give me gigabit speed, but it required a special driver that was somewhat buggy and I experienced periodic crashes.
 
Last edited:

Vandar

macrumors newbie
Aug 23, 2020
1
0
Are you using a surge protector for the ethernet? 90% of those are 10/100 so will cut your speed to 100
 

johnny9999

macrumors newbie
Sep 16, 2020
8
0
@super_kev did you fix this? I've got the same issue on my 2010 MacMini - will only go to 100 megabit or so - whereas my iMac will go to around 900 megabits. Have tried swapping physical switch ports and cables, but it's always the MacMini that's slow. Upgraded from El Capitan to High Sierra and it made no difference. Have also tried the PRAM/SMC resets.

Last thing to try is to wipe the HD and reinstall High Sierra from scratch. But I've been unable thus far - just takes too long to boot from the High Sierra USB stick.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.