Mac Mini won't boot! Disk0s2: I/O error

Discussion in 'Mac mini' started by Jeff-H, Oct 31, 2009.

  1. Jeff-H macrumors newbie


    Mar 30, 2009
    My little (out of warranty) Mac Mini has been a champ, and I love it. Last night it locked up, and now when I try to restart it, I get stuck at the grey screen with Apple logo and a spinning doo-dad. This goes on for a while until it shuts itself down.

    I have boot camp installed, and when I hold the Option key down at startup, I see the Windows Vista drive (but can't select it). After about a minute, the Mac OSX drive shows up. I can select the Mac drive, but then I get stuck at the grey screen again.

    I tried starting up in Single User mode and at the command prompt, ran /sbin/fsck -fy but got a couple "disk0s2: I/O errors" followed by "Invalid node structure" and "The volume Macintosh HD could not be repaired." (see attached photo of exact message).

    photo (1).jpg

    I'm running Leopard (not Snow Leopard), and the installation disc is three hours away at my daughter's place (ugh).

    Any brilliant suggestions?

    On the bright side, I have been running Time Capsule to a 1TB external drive, so in theory, I'm good, right? :)
  2. HellDiverUK macrumors 6502

    Oct 24, 2009
    Belfast, UK
    New HDD, reinstall using Recover mode using your Time Machine backup. You should be back and running in an hour.
  3. Jeff-H thread starter macrumors newbie


    Mar 30, 2009
    Installed a new 320 GB 7200 rpm WD HD this past weekend, and everything restored via Time Machine perfectly! Worked like a charm.

    Thanks for the reassurance!

Share This Page