Mac Mini won't install any OS

Discussion in 'Mac mini' started by HereBeMonsters, Oct 13, 2014.

  1. HereBeMonsters macrumors 6502

    HereBeMonsters

    Joined:
    Jul 5, 2012
    Location:
    Fareham, UK
    #1
    OK, I've fiddled with it. It was originally late 2006 1,1 with CoreDuo - I upgraded it to the spec you can see in my signature below.

    It ran Snow Leopard (the OS it came with) blisteringly fast, and it worked perfectly fine with the flashed 2,1 firmware for a couple of months, but of course I had to have more. I'm pretty good with hardware, it's my job after all, but mainly with PCs.

    So I followed the instructions from this thread: http://forums.macrumors.com/showthread.php?t=1325709
    And installed Mountain Lion. It was buggy as hell. Multiple re-installs and tweaks did nothing. Apps refused to install, would crash all the time, and the machine was basically unusable. So I wanted to go back, but I can't...

    When trying to re-install Snow Leopard from the original DVD (the one that came with the Mac Mini) I keep getting:

    "Install Failed. Mac OS X could not be installed on your computer.
    The installer could not copy the necessary support files.
    Click restart to restart your computer and try installing again."

    This is the same if I try to install on the internal SSD, an external USB or FireWire disc, or even if I switch the drive back out to the original one it came with.

    So, how about Leopard (10.5) then? I have a retail disc for that that I used to rebuild my G4s. No, that errors at the same bit, with an error:

    "Not able to validate the contents of the AdditionalSpeechVoices Package"
    and asks me to restart to try again.

    So now I'm getting desperate, someone mentions that my hacked 2,1 Mac Mini should be able to run Lion, so I buy that from the App Store, and make a bootable USB stick as per these instructions: http://osxdaily.com/2011/07/08/make-a-bootable-mac-os-x-10-7-lion-installer-from-a-usb-flash-drive/ and verify that the stick works on a Mac Pro 1,1.

    Trying to boot from that just gives me a grey "No Entry" sort of symbol on the screen.

    So now I'm really desperate. The Mac Pro 1,1 at work is running Lion...I take a Carbon Copy Cloner image of its build (removing the PlatformSupport.plist), and boot from that on my Mac Mini. Success! It boots into an OSX desktop, for about two minutes, before coming up with a message on the screen that hangs everything telling me to turn off the computer.
    These two minutes are long enough for me to run the Lion installer app from that desktop though. "This version of Mac OSX Lion cannot be installed on this computer."


    At this stage, I am all out of ideas. I really want to get this thing working, I've spent a small amount of money on it, but really a hell of a lot of time trying to get it to work. I feel daft for fiddling with a working OS, but then, would we be men if we didn't always think "this is good, but how could it be better?" and what I really feel daft about is not making a CCC backup of the image before I wiped it. As I had no data on there I needed, and the install when I first replaced the hard drive was fine, I figured it would be just as easy to re-install if I ever wanted to.

    :apple: So, after all that, has anyone got ideas as to what I can try next? Ideally I'd like it to run Lion as I've just spent £14 on it, but Snow Leopard would be good enough! :apple:
     
  2. mcnallym macrumors 6502a

    Joined:
    Oct 28, 2008
    #2
  3. DblHelix macrumors 6502

    Joined:
    Mar 19, 2009
    #3
    Do you have aftermarket memory? My mbp does and I had the same issue. Swap to factory memory installs fine. It recently started working with my aftermarket memory so I am guessing maybe I changes slots the last time I put it back in. Try reseating your modules or switching the modules to see if that fixes it
     
  4. HereBeMonsters thread starter macrumors 6502

    HereBeMonsters

    Joined:
    Jul 5, 2012
    Location:
    Fareham, UK
    #4
    Really? You had exactly the same issue?

    I only ask, as getting into a Mac Mini ain't the easiest of things to do - and I've only just got it all back together since swapping the hard drives around again!

    Plus I'll need to buy a new paint scraper as the wife has since used it for its actual intended purpose! :eek:

    Although I'm now thinking it came with 2 x 1GB...and now it has 2 x 2GB (Crucial, so not exactly cheap stuff!) and I have no idea where the original stuff went...I might even have chucked it. :confused:

    OK, well as I can't get another paint scraper until tomorrow now anyway, I'm going to kick back with a nice glass of whisky and have a fiddle with a Raspberry Pi instead! Thanks :)
     
  5. HereBeMonsters thread starter macrumors 6502

    HereBeMonsters

    Joined:
    Jul 5, 2012
    Location:
    Fareham, UK
    #5
    Update:

    I managed to get Lion on there by creating a new install of Lion using the Mac Pro at work onto an external drive.
    Mounted that from my Powerbook and edited the PlatformSupport.plist to include the line: <string>Mac-F4208EC8</string> (which I found at http://www.insanelymac.com/forum/to...on-on-any-coreduo-mac-upgraded-to-a-core2duo/)

    This enabled me to boot from external drive onto the Mac Mini. Ran Carbon Copy Cloner and copied the build onto the internal drive, while creating a recovery partition as well.

    I was then able to remove the external drive and boot the Mac Mini with its cloned OS. I straight away did a Time Machine backup, then left it overnight to install some updates.

    This morning it was stuck on a screen telling me to turn it off, then when I turned it back on, it wouldn't get past the grey Apple logo screen with the spinning wheel thing.

    So, now I have to try to roll it back using the Time Machine, or do the CCC thing again. But that sucks if it won't install updates. I've not even tried to put any software on there yet!
     

Share This Page