Mac mini won't turn on

Discussion in 'Mac mini' started by sambb, Aug 11, 2015.

  1. sambb macrumors newbie

    Joined:
    Aug 11, 2015
    #1
    I need some advice my mac mini is working fine I have just updated, but light won't light up.So we have opened and not seems to be wrong we have, remove the small battery and put all parts together.We plug on the power and once again it works but no lights on.Turn off and unable to turn back on.Any suggestions of what could be?We have not used much the mini actually still brand new to be honest.But no more warranty.
     
  2. Celerondon, Aug 12, 2015
    Last edited: Aug 13, 2015

    Celerondon macrumors 6502a

    Celerondon

    Joined:
    Oct 17, 2013
    Location:
    Southern Cal
    #2
    Which Mac mini do you have? What exactly did you do to that mini? An OS X Yosemite upgrade or SSD installation could cause characteristic problems. Perhaps we can help if you provide more specific information.
     
  3. grcar Suspended

    grcar

    Joined:
    Sep 28, 2014
    #3
    If "updated" means installing a new hard drive, then the install might have been botched. Removing the jumpers for the power-on light and the infra-red remote is very delicate and can tear the posts they connect to on the logic board. If you hear the chimes when the power is turned on then the machine has at least passed the power-supply tests.
     
  4. sambb thread starter macrumors newbie

    Joined:
    Aug 11, 2015
    #4
    The mini model is MD387LL/A mid 2012,I just update the OS X Yosemite, I'm seriously thinking it could be the small battery,I bought 2 years ago and honestly I haven't used the mini.Since was a gift, and now when I try to use there is no power unless we open it and re-connect everything.But also the light does lid up when it was on.

    Thanks for help guys!
     
  5. Arthurian Legend macrumors newbie

    Joined:
    Aug 15, 2015
    #5
    Hi. I've got a 2010 Mini running Yosemite. I usually send it to Sleep overnight, and over the past few weeks I would find that in the morning it had either shut itself down already, or if still in sleep mode, it would randomly shut down when attempting to wake it.

    I could always reboot it, until this morning. I've tried different power leads, checking for faulty RAM, resetting the PMU and SMC - but nothing! Would really appreciate some more suggestions!
     

Share This Page