Mac must repair library for you to run applications

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Mork, Jun 22, 2017.

  1. Mork macrumors 6502

    Joined:
    Jan 9, 2009
    #1
    Since I installed Mac Sierra server three days ago, I've had to restore the entire machine from backup twice.

    What happens is I do something like try to start Safari, but it won't start from the dock. About that time, I get a pop-up that says that the MacOS needs to repair my Library so I can run applications.

    My login user ID is pre-loaded, but no matter what password I enter (like the one that goes with the login shown), this dialog won't accept it.

    Then, to make matters worse, if I reboot, I then get a two field login prompt and no matter what I type in the fields (valid user names) nothing is accepted.

    Then, I have to restore the entire machine from a backup if I want to get back in.

    Has anyone seen this issue?

    TIA

    - M
     
  2. modemthug macrumors regular

    Joined:
    Apr 20, 2010
    #2
    I've never seen this. Do you have a screenshot?
     
  3. Mork thread starter macrumors 6502

    Joined:
    Jan 9, 2009
    #3
    No, but the next time it happens, I'll post a screenshot.

    Thanks,
     
  4. guzhogi macrumors 68030

    guzhogi

    Joined:
    Aug 31, 2003
    Location:
    Wherever my feet take me…
    #4
    I've seen this (or similar) issue before. I find that it needs an admin user's credentials. It usually comes back a few times. Pressing the Cancel button (or Command-Period) closes this window.
     
  5. Mork thread starter macrumors 6502

    Joined:
    Jan 9, 2009
    #5
    The problem isn't that I can't close the window. And, it won't take the admin password (root) either. The real problem is once you reboot, no passwords work at all.
     
  6. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #6
    I asked this question in the thread where you originally posted this: Are you trying to sign in to the server with an Open Directory or Active Directory account? If so, don't do that; make a local administrator account on the server and sign in with that.
     
  7. Mork thread starter macrumors 6502

    Joined:
    Jan 9, 2009
    #7
    I tried to log in to the Mac with the user account and with the root password. Neither worked.

    One time there was a little red dot next to the mac login text field and when I hovered over it, it said that the network was unavailable or something like that.

    Thanks,
     
  8. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #8
    Make an account in the system preferences Users & Groups panel and use that to log in at the server. Do not use Open Directory users to log in on the desktop of the server. I can't find documentation about this right now but it's always been problematic and not recommended.
     
  9. Mork thread starter macrumors 6502

    Joined:
    Jan 9, 2009
    #9
    I never used any Open Directory user ID to log into the machine, always a regular user. I created a root user using Apple's technique. But, when this issue happens, no login works.

    Thanks
     
  10. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #10
    Where are the home folders located?
    Have you made a regular admin account, rather than root, and logged in as that? Running as root in a Mac server has led to strange behaviors at times for me, and there really is no need to do it.
     
  11. Les Kern macrumors 68040

    Les Kern

    Joined:
    Apr 26, 2002
    Location:
    Alabama
    #11
    Its bound somewhere. Don't use a backup, restore the machine with the recovery disk or over the internet first.
     
  12. D200 macrumors newbie

    Joined:
    Nov 23, 2010
    #12
    I have the same message popping up, after installing High Sierra on a mid13 iMac.

    It is not a network computer. We actually rarely use it and it has been slow as hell from the very beginning...

    Any way, has there been a solution to this messsge? Disk utility didn’t solve it...

    Thanks!

    M
     

Share This Page