Mac no longer reads External HDD; PC still can

Discussion in 'Mac Basics and Help' started by Yallo248, Jun 12, 2014.

  1. Yallo248 macrumors newbie

    Joined:
    Jun 12, 2014
    #1
    Hello!

    I have an external hard drive to which I've previously been able to use with both my Windows 7 PC and my Macbook. However, although the PC can still access the drive, it simply stopped working with my mac and "cannot be repaired."

    I could probably re-format the drive (A WD My Passport), but I want to know why so I can prevent this in the future and hopefully fix the issue without reformatting the drive.

    Thank you!
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Please do not use the WD software. This software doesn't like OS X upgrades and have been known to cause major problems. Next is the drive HFS+ (Macos Extendend) or FAT32?

    Plus did you attempt to repair the drive from your PC?
     
  3. rjvcrisen5 macrumors newbie

    Joined:
    Jun 12, 2014
    #3
    This is very ironic because I was about to post a thread about this very same problem. I've had a macbook for a year now and it worked fine with my external hard drive. Just yesterday me and my girlfriend switched mac's because she wanted to use a program on there, and the external hard drive worked with the macbook yesterday. However today I find that external the hard drive will not be read by my girlfriends macbook. It is greyed out in the disk utilities section, and when I try to repair it I am told that it cannot be repaired to back it up. However the hard drive works fine on my brother's PC.

    Edit: Would the reason be that my macbook doesn't have mavericks installed but hers does?
     
  4. Yallo248 thread starter macrumors newbie

    Joined:
    Jun 12, 2014
    #4
    Oddly enough, my Mac recognized it again once and I was able to use it, but I accidentally unplugged it and have had no luck since then.

    Disk utility even recognizes it, but cannot mount, repair or eject it. I am running Mavericks.
     
  5. Yallo248 thread starter macrumors newbie

    Joined:
    Jun 12, 2014
    #5
    It actually may be my drive. Now the same thing happens with my PC. It can see the drive, but can't access it.
     

Share This Page