Mac not sleeping when Safari or Firefox are open? (Not Flash)

Discussion in 'macOS' started by Richard Flynn, Jul 6, 2011.

  1. Richard Flynn, Jul 6, 2011
    Last edited by a moderator: Jul 6, 2011

    Richard Flynn macrumors regular

    Sep 4, 2006
    OK my Mac Pro is having sleeping problems again. This has been annoying me for more than a month now but I haven't had the opportunity to do any investigation.

    I have narrowed the problem down to being caused by Web browsers—specifically Safari and Firefox. If neither of those applications is running, the Mac goes to sleep by itself pretty much as it should.

    In short, the Mac won't go to sleep by itself if any of the following is true:
    • Safari is open (with or without a window open)
    • A Firefox window is open
    I have tried removing both the Flash plugin and the Click-to-Flash plugin (following Gruber's suggestions to do that) from /Library/Internet Plug-Ins and ~/Library/Internet Plug-Ins respectively.

    The Mac will go to sleep by itself if any of the following is true:
    • Neither Safari nor Firefox is open (no windows, applications completely quit)
    • Firefox is running (the application), but no Firefox window is open
    Can anyone please give me an idea for what I should be looking for to isolate this problem? The way I work it isn't really feasible to quit Safari (my preferred browser) every time I want the computer to sleep. I tried using the latest WebKit nightly builds, but they prevent sleep in the same way as Safari.

    I have several other plug-ins in the Internet Plug-Ins folders, including Adobe PDF viewer, Flip4Mac, iPhotoPhotocast, Java, nsIQTScriptablePlugin, Quartz Composer, QuickTime, SharePoint, Silverlight, and Wacom. I also use the slightly hacky Glims, but that hasn't caused me problems in the past and there haven't been any recent releases which might have triggered this problem.

    I'd be seriously grateful for any suggestions which anyone here can give.


    Have I really flummoxed the great minds at MacRumors? Surely not!

    Seriously, guys—grateful for any ideas you can give to resolve this.
  2. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    It's possible that your Mac Pro has the "wake for network administrator access" option checked in System Preferences, and the network your Mac is connected to makes it think it ALWAYS needs to be awake whenever the network port is in use. Try unchecking that option. I cannot, for the life of me, remember what the name is of the preference pane it's found in - I'm thinking Energy Saver, but I'm not sure.
  3. Richard Flynn thread starter macrumors regular

    Sep 4, 2006
    Thanks for replying. Yes, the prefpane in question is Energy Saver.

    I had already got Wake for Network Access turned off, so that's not the problem here.

    This Mac Pro is still an insomniac.
  4. quinnat macrumors newbie

    Jul 22, 2011
    Has anyone found a solution yet. I'm having a similar problem. My MacBook WILL eventually sleep with Firefox open, but it takes several minutes!! As above, no problem sleeping with Firefox completely quit.
  5. jive turkey macrumors 6502

    Mar 15, 2008
    I can't speak on Safari, but the Firefox issue has been a long running one. Apparently it has do with the calculation of the "frecency" database, which runs every couple of minutes if a window is open, regardless of whether that window is active. My machines never sleep if I have a Firefox window open. The Firefox bug database has several open bugs related to this (here is just one example), but so far no workaround has worked for more than one release.
  6. brycenesbitt macrumors newbie

    Aug 15, 2008
    Use "please sleep"

    The Dragon One "please sleep" utility has solved this problem for me.

    Mac OS has definitely underperformed expectations when it comes to sleep. It could be much easier to determine and control when a particular mac sleeps. But anyway, the Please Sleep utility fixes the problem.

Share This Page