Mac OS 10.5.5's Disk Utility formatting Ext. HD differently from 10.4?.

Discussion in 'macOS' started by thedragonb, Nov 11, 2008.

  1. thedragonb macrumors newbie

    Joined:
    Nov 11, 2008
    #1
    Mac OS 10.5.5 Disk Utility not formatting Ext. HD properly.

    I was originally able to use my external Hard drive Seagate 300GB right out the box without formatting on my Phillips DIVX-compatible DVD players as well as my Sony PS3 to watch .AVI and MPG files on TV.

    Well, last night I needed to swap some files via Time Machine and had to re-formatted my Ext HD. So once that is done I go to format back with Mac OS 10.5.5's Disk Utility, but this time using the MS-DOS (FAT32) option since that is how it will work with the DVD players and PS3. But the drive wasn't recognizable with either DVD players or Sony PS3.

    Now here's the kicker! I had my old iBook with Mac OS 10.4 and decided to format the drive using it's Disk Utility version and now the drive is recognizable on both DVD players and PS3.

    Obviously something is different with the latest version of Disk Utility on Mac OS 10.5.5! Does anyone know why Leopard Mac OS's Disk Utility is formatting differently than previous versions of Mac OS? What's the deal here?

    Good thing I didn't give away my old iBook... Is this an Apple conflict or ???
     
  2. NoSmokingBandit macrumors 68000

    NoSmokingBandit

    Joined:
    Apr 13, 2008
    #2
    Are you just formatting it or are you repartitioning it? Iirc, PPC-based macs partition with a different partition map than intel macs.
     
  3. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #3
    I feel sure that NoSmokingBandit's take on it is exactly right.

    Leopard's Disk Utility offers three types of Partition Map Schemes: APM (Apple Partition Map- bootable on PPC Macs), GUID Partition Table (bootable on Intel Macs) and MBR (Master Boot Record (as it would be formatted from a Windows machine, and often the partition map that comes on new drives).

    You can see what your drive is currently by selecting the drive in the left column of Disk Utility and looking at the info at the bottom of the page. Look at the "Partition Map Scheme:" entry for the answer.

    To make it work almost surely, the drive could be redone to simulate a new drive prepared for PC use as most new ones are by going into the Partition part of Disk Utility and setting the Partition Scheme to "Master Boot Record" (using the "Options" button at the bottom) and the format type to "MS-DOS (FAT)" as Apple calls FAT32.

    Other combos may work (MS-DOS (FAT) and APM partition scheme come to mind) but the previous combo should pretty much guarantee it.
     
  4. thedragonb thread starter macrumors newbie

    Joined:
    Nov 11, 2008
    #4
    Thanks for the feed back everyone!

    I was formatting the entire drive. No partioning using the ERASE tab and MS-DOS option. There is no option to make it a Master Boot Record to make it bootable or compatible with MS-DOS format. It would be completely unrecognizable on my DVD pleyers and PS3.

    Yet, when trying to create a partition I didn't see about the OPTION button and have the option to partition with MS-DOS(FAT32) until you guys alerted me to it. It was right there all along at the bottom. NOW I see how I can partition for part MS-DOS and part MAC - I'll need to try that Master Boot Record option and see if that corrects my problem.

    Thanks for the heads up.. I will try it out on my external drive and see if it works.
     
  5. brkirch macrumors regular

    Joined:
    Oct 18, 2001
    #5
    You probably accidently selected the partition when you actually wanted to format the whole disk; that would explain why reformatting didn't change the partition map to MBR (IIRC, reformatting the whole disk with FAT32 defaults the partition map to MBR).
     
  6. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #6
    Just be aware that the partition map scheme (the MBR, APM or GUID) applies to the whole disk, not single partitions- only one per physical hard drive.

    The format (MS-DOS (FAT), Mac OS Extended (Journaled), etc.) can be applied on an individual partition by partition basis.
     
  7. tjthom macrumors newbie

    Joined:
    Dec 7, 2012
    #7
    I need to start from fresh!

    Hi everyone,

    Sorry to reopen this, but I've been having issues reformatting my external hard drive for several days. Everything I have found has been related to fixing the drive that Mac is installed on, which is not what my issue is.

    The story:
    I had this external hard drive that I was occasionally making Time Machine back-ups to. Then I did the following and screwed it up...
    • created a second partition on the device
    • used Time Machine to encrypt the first and second partitions
    • (this then created what appered to be two separate devices in the list; obviously not the case)
    • Tried to delete the second partition that I made to go back to what I originally had

    Now I have this mess (see attached picture.)

    At this point there is zero data on any of the partitions. I've "erased" each partition several times and tried reformatting them to different types of systems (Mac, ExFAT, etc.) But overall... I cannot merge them to start over for the life of me.

    If I click the top level device, the ONLY two tabs that are listed are "First Aid" and "Partition"

    When I click on the "Partition" tab, the button below that says "Options" is grayed out and I cannot click it. The only thing that is available is the "minus" sign for only ONE of the partitions (the first one.) And when I click it, the pictured error is what I get.

    LONG STORY SHORT....
    I THINK if I am able to reformat the MBR on the external hard-drive, that it will fix it enough to the point where I can delete partitions. I'm just struggling to figure out how to redo the MBR. ADDITIONALLY: when I click on the device, the info at the bottom doesn't even list "Partition Map Scheme" which leads me to believe it's really messed up.

    Can anyone help?

    I'm using Mac 10.8.2 if it helps. Thanks!
     

    Attached Files:

  8. tjthom macrumors newbie

    Joined:
    Dec 7, 2012
    #8

Share This Page