Mac OS 10.5.8 on iMac G4

Discussion in 'PowerPC Macs' started by T2theR, Jul 22, 2013.

  1. T2theR macrumors newbie

    Joined:
    Jul 22, 2013
    #1
    Good day everyone. First of all, I hope that I am posting this in the correct forum. Excuse me from any spelling mistakes, since English is not my native language.

    So, here's the thing. A friend of mine gave me an iMac G4. We both really dig the design, and don't want to throw it away because the operating system that was on it (10.3.9) can't do anything useful to us (like loading a google search for example.....).
    So I started digging around on the internet and found some pages stating that you can in fact install OS X Leopard on 'unsupported' machines. The trick was some fiddling with the clock frequency and then it should install. Anyway, I tried to find a 10.5.8 disc for powerpc somewhere, but the only thing I could find was a stripped down version of it that you could replace your current HD with. So okay, I started going down that road and now I'm here, confused, the iMac has no OS anymore and I have no idea what options are left.

    Now I think the easiest thing to do is name the things I tried, along with the result, so you guys might be able to help me.

    - First of all the iMac: 15", PowerPC G4 processor, 256 MB RAM, Nvidea Geforce 2, not fully functional optical disk drive (I'll get to that later)

    - Tried to restore the 10.5.8 image within 10.3.9 -> didn't work (probably a 'duh' but I figured that would be easiest)

    - Created a partition so I could restore the image to. Did it eventually with GnomeParted within a live CD of Lubuntu for PPC.

    - Tried to restore image to partition. -> didn't work

    - Eventually after some things I tried which I can't remember, but weren't that important anyways, I ended up taking out the HDD, hooking it up to another iMac via USB, restored the image to it, put it back in. -> Didn't work (folder icon flashing '?' and finder smiley)

    - Now at a point with no OS, trying to boot from a DVD with snow leopard (wasn't sure if it would work because it isn't powerpc, but if it at least booted I might be able to do something with Disk Utilities) -> didn't work, spat out the disc.

    - Tried to boot from the Lubuntu disc again -> Works like a charm, though ONLY if I type 'boot: live-powerpc nouveau.modeset=0' (also the first time, took me a while to figure that out). It looks very psychadelic, and then when I tried to install it, the install window shows, but actually only shows the borders and the inside looks like the wallpaper behind it, but if you move it, it takes that image with it (hard to explain). Anyway, I can't install it.

    - Downloaded a 10.4 tiger retail image. Put it on USB, dvd, and I got a 4 CD version of it, all of which didn't boot even a tiny bit. I tried it via OF with specifying the entire path ànd alias, holding C, holding option. Nothing.

    - Opened up the iMac, plugged in another DVD drive to see if it might work. -> Nope. When I let it boot freely it only gives a white screen in stead of the folder icon. When I open OF and type 'eject cd:', nothing happens. Weird.

    Why I suspect that the dvd drive is partially broken is because when 10.3.9 was still installed, and I put in a DVD, it didn't really read it. Though when I put in a CD it had no trouble reading it. I also burned some stuff to DVD and it made a weird clicking noise when I tried to boot from it, though when trying to boot from CD it spins/hums normally.

    Now I am left with a Mac with, in theory, a fully installed 10.5.8 on it's HD, but unable to boot, and trying to boot anything burned on a DVD or via USB seems impossible. The only thing I can get to boot is the Lubuntu Live CD (which by the way recognizes the HDD and sees the HFS+ partition).

    Okay, I hope this is at least a tiny bit clear, it's hard to document every step because I have been working on this damned thing for three day straight now and it only has gotten worse.
    The main thing I'm trying here is to get 10.5.8 working on this thing, but now booting up anything also seems like a main concern to me.
    Please, if anything is unclear, ask.

    Thanks in advance,
    Tristan
     
  2. ihuman:D macrumors 6502a

    Joined:
    Jul 11, 2012
    Location:
    Ireland
    #2
    I wouldn't install it if I were you, install Tiger/10.4 instead. The graphics processor in that iMac is crap for Leopard. You should also upgrade the RAM when you get a chance.
     
  3. MisterKeeks macrumors 68000

    MisterKeeks

    Joined:
    Nov 15, 2012
    #3
    The reason that you were only finding the stripped down versions of Leopard for PowerPC is that every single Leopard retail disk was Universal (worked with both PowerPC and Intel based Macs).
     
  4. DrakkenWar macrumors 6502

    DrakkenWar

    Joined:
    Nov 7, 2010
    Location:
    San Antonio,Texas
    #4
    10.4 is the way to go with that mac.

    I have to agree with the suggestion of going with 10.4.11 on that particular mac. The Geforce graphics is really going to be a problem if you try to install 10.5. Also, as previously said; 256mbs of ram is not going to allow you to to much of anything. Even with 10.4.11. I would say absolute bare minimum would be 512, though with RAM prices as the they? Depending on where you live that is. I would max it out.
    There is still quite a bit of life in 10.4.11, I had to go back to it here on my power book a few months ago for some software issues and I am in really no hurry to install 10.5 again.
    At any rate, good luck. :)
     
  5. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #5
    Yeah, I have to say too that Tiger is your best bet. That iMac is one of the older ones. It doesn't even have USB 2.0.
     
  6. T2theR thread starter macrumors newbie

    Joined:
    Jul 22, 2013
    #6
    Alright, well that's what I will try now then.
    The problem still remains though, I can't boot succesfully. I have acquired a Tiger 4 CD installation, and when entering disc 1 it loads up to the blue screen with the spinning colorwheel, but then nothing happens.
     
  7. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #7
    Does it show up within Panther? Like in Finder?
     
  8. SkyBell macrumors 604

    SkyBell

    Joined:
    Sep 7, 2006
    Location:
    Texas, unfortunately.
    #8
    I would suspect that the reason it won't boot Leopard is that your iMac has only 256 MB of RAM, and Leopard requires at least 512 MB. (On that note however, I would not suggest any less than 1 GB if you're still aiming for Leopard; it tends to have a bit of an appetite for memory.)
     
  9. T2theR thread starter macrumors newbie

    Joined:
    Jul 22, 2013
    #9
    Okay, I will suggest a memory update to my friend, because it is not mine. But first of all I will have to get it to boot somehow. The point is that the iMac has no OS installed anymore! Because I tried to restore the HDD with the 10.5.8 image, but it isn't recognized.

    Also, when I enter a Lubuntu live CD, which I can boot from if I hold C, and try to boot it from OF, with 'boot cd:\' or something similar, it tells me that the Load-Size is too small. The same happens with the 10.4 CD. But then holding C doesn't get me further then a light blue screen with spinning colorwheel.
     
  10. MysticCow macrumors 6502a

    MysticCow

    Joined:
    May 27, 2013
    #10
    I have a G4 tower at 733 MHz with 1.5 Gb of RAM and the "evil" GeForce 2 card. It runs Leopard fairly well--not as fast as my G5 dual 1.8 GHz model, but it runs it at a respectable pace.
     
  11. uncle macrumors member

    uncle

    Joined:
    Dec 23, 2004
    #11
    Old-ish thread but you may not have chucked it out yet:)

    http://eshop.macsales.com/OSXCenter/XPostFacto/

    XPostFacto 4
    "Supports Mac OS X 10.4 (Tiger)!
    Runs on Mac OS 9.x or 10.2 through 10.4.
    Will install Mac OS X 10.2 through 10.4.
    Works with "New World" machines that Apple dropped support for in 10.4 (such as the original iMac, original iBook, and the Lombard Powerbook)."

    This will work but you'll need to read some of the info first or you'll get stuck.

    It sounds like you'll need to boot from 10.3.9. Instal this or earlier, (even as low as os 9) on an external usb drive. (It might boot from a usb flash drive??) Install XpostFacto to this external drive then boot your imac from it. Launch XpostFacto and if you like you can try to see if it will boot from your 10.5 install on the internal drive.

    If not then use your 10.4 on cd and allow XpostFacto to install it and then boot from that installation.

    Good luck... I had great success with this installing an 800Mhz G4 proc upgrade into an 8600 (604e)

    B;~)
     
  12. T2theR thread starter macrumors newbie

    Joined:
    Jul 22, 2013
    #12
    Well in the end I got it to work. Turned out that I didn't partition the harddrive appropriately. I had to check some box about how the filesystem was installed or something, I can't really recall. But I got it to work by removing the HDD, hooking it up to a new iMac with a external usb drive thingy and then formatting the drive and installing the image.
     

Share This Page