Mac OS Install Error!

Discussion in 'MacBook Pro' started by mrseanz, Apr 15, 2017.

  1. mrseanz macrumors newbie

    Joined:
    Apr 15, 2017
    #1
    Hi there.

    I'm attempting to reinstall Sierra OS on my 2012 MacBook Pro.( I've done a full back up on an external drive using time machine.)

    Issue: With 20 seconds remaining, the install fails and I get this message:

    "An Error occurred while preparing the installation."

    Most on-line discussions I've looked into on this particular issue reference the wrong date/time as a cause for the problem. The fix is simple - go into Terminal and correct the date/time (writing it in a specific and precise format) which I have done.

    Prior to this point, the install attempt begins with me shutting down the Mac, then holding down the power button while simultaneously holding down Command-R. (I've also tried this method while holding Option-Command-R - an alternative option for a slightly different version of the OS).

    In all cases, the install fails, with the same error message as above.

    So, if the issue is generally deemed to be the time/date, and yet the time/date has been corrected through Terminal (Terminal accessed within 'macOS Recovery'), then my question is:

    What is the solution to get past the error message? What is the next step or option?

    Currently, and since attempting to reinstall Sierra OS, the MacBook will not reboot, not even in safe mode.

    Any suggestions or guidance would be gratefully received.

    I apologize in advance if I haven't provided appropriate technical information. I will happily provide any additional information that is required.

    Thanks and regards,

    Sean


    Sent from my iPhone using Tapatalk
     
  2. bartvk macrumors 6502

    bartvk

    Joined:
    Dec 29, 2016
    Location:
    The Netherlands
    #2
    I'd create a bootable USB stick and install from there.
     
  3. Sanpete macrumors 68020

    Joined:
    Nov 17, 2016
    Location:
    Utah
    #3
    I had a similar issue with a 2011. Can you still boot into recovery mode? If so, you can use the disk utility to check your boot drive.

    The simplest thing to do regardless if you're near an Apple Store is to take it in for free diagnosis, which in this case might involve fixing it if it's only a software issue. If it's the hard drive/SSD, or a cable, you can probably fix that yourself by replacing them.
     
  4. mrseanz thread starter macrumors newbie

    Joined:
    Apr 15, 2017
    #4
    Thanks Sanpete. No I can't boot to recovery mode. Also, we have no Apple Store here in NZ! Also, I had new Hard drive installed around 1 year ago. I'll be taking the Mac back there I think. Thanks anyway.
     

Share This Page