Mac os leopard's Itunes & iphone

Discussion in 'iPhone' started by mithun914, Sep 28, 2007.

  1. mithun914 macrumors member

    Joined:
    Jun 5, 2007
    #1
    I live in canada.

    So i will keep my unlocked iphone, but never ever update to 1.1.1

    i will also install 3rd paty apps while am at it.

    but for sure i will get mac os 10.5 when it'z out, i was just wondering , is it possible it might have a new itunes that forces us to do a firmware update when we plug in our iphones , or even doesn't let unlocked iphones sync.

    might Apple do that???
     
  2. overcast macrumors 6502a

    Joined:
    Jun 27, 2007
    Location:
    Rochester, NY
    #2
    Ok, I can't handle the iPhone forum anymore. I'm going to bed.
     
  3. Canuck4 macrumors 6502a

    Canuck4

    Joined:
    Jul 31, 2007
    #3
    I highly doubt it.
    Updates are voluntarly, you dont have to if you dont want.
    And you can install any version of itunes on your system.
     
  4. sblasl macrumors 6502a

    sblasl

    Joined:
    Apr 25, 2004
    Location:
    Heber Springs, AR
    #4
    Actually, there might be this possibility where Leopard will only allow a minimum version # of iTunes to run. We are at 7.4.2 on the Mac, it might very well be the case that any older version will not run.


     
  5. Canuck4 macrumors 6502a

    Canuck4

    Joined:
    Jul 31, 2007
    #5
    I wonder if they will push it that far.
    Maybe....
     
  6. acrafton macrumors 6502

    Joined:
    Jan 18, 2006
    #6
    I think there is a real possibility that Apple will put some stuff into Leopard (final release) that contains a new version of ITunes which will only work on IPhones that are at 1.1.1.

    This could be kind of the 1-2 punch for hacked IPhones:
    Step 1 - release 1.1.1 that kills unlocked IPhones keeping you at 1.0.2
    Step 2 - Leopard comes with ITunes 8 that will ONLY sync IPhones at 1.1.1

    So, if you want Leopard you will update to IPhone 1.1.1. This will kill the unlocked/hacked IPhone underground because most are happy at 1.1.1 everyone wants Leopard.
     
  7. mithun914 thread starter macrumors member

    Joined:
    Jun 5, 2007
    #7
    when i buy leopard , i'll do an upgrade or a archive & install, so when i do this would it replace my itunes ( if there is lets say itunes 8 in-leopard) or can i chose not to install it ( itunes 8 (if that;s the case))?
     
  8. spacepower7 macrumors 68000

    Joined:
    May 6, 2004
    #8
    Then don't post!

    I'll keep my backup laptop on 10.4 if Leopard messes with the iPhone.

    Firmware 1.0.2 forever if need be.
     

Share This Page