Mac OS X 10.6.2 ~ Folder Icon Gone

Discussion in 'Mac Basics and Help' started by iband48, Feb 18, 2010.

  1. iband48 macrumors newbie

    Joined:
    Feb 18, 2010
    #1
    I'd like to start out by simply saying hello, and thanking in advance for any of the advice given, regardless of the outcome. I understand this is all out of the kindness of people's hearts, so... thank you.

    Now, to the problem... I'm running OS X 10.6.2 Snow Leopard (I also Boot Camp to Windows XP on occasion if it matters) on a 20" Intel-based iMac (the first aluminum series when there was still an aluminum border around the screen). I have had it since mid-late of last year, and it has been running fine aside from a few common issues. The issue I've run in to now is that the folder icons have vanished from everywhere; the desktop, the dock, the finder, etc. They are replaced by either just a blank space, or the question mark.

    Upon closer inspection, diving into the system files, I discovered a number of the system applications are also lacking icons.

    Here is a screenshot to illustrate my point: http://i1003.photobucket.com/albums/af157/iband48/Screenshot2010-02-18at53450PM.png

    I have done a fair bit of crawling around and discovered a few methods to correct this, but to no avail. I have...

    1. Simply tried restarting the computer, multiple times.

    2. I have tried Force Quitting the Finder.

    3. I have tried going into the Terminal and typing 'killall Finder'.

    4. Deleting the various .plist files that have been suggested for similar problems.

    5. I tried repairing the permissions through the Disc Utility

    6. There was another very long command that was recommended be put into the Terminal as well, but I can't recall the command at the moment.

    Another concerning fact about this whole mess is that I jumped into Candybar, more out of curiosity than anything, and the place where the Folder icons should have appeared doesn't even get displayed anymore, as though they don't exist.

    I'm not using any different programs for Spotlight, or anything of the nature. The most I've done is I have CleanMyMac that I run pretty regularly, and the last thing I installed before the issues began was iStat for the Dashboard.

    I know that my end all solution would be to just back up the files that I need and reinstall SL, but if there is a way to fix this without it coming to that, I would prefer to go that route. In part because I don't have the restore disc with me, stupid move on my part and I recognize that.

    I appreciate any help that can be given. I've tried to give as much details as I possibly can so that you guys aren't wasting your time trying to solve a problem I don't have, based on lack of info on my end.
     
  2. rs49a macrumors newbie

    Joined:
    Apr 19, 2010
    #2
    me too

    I had exactly the same problem with 10.6.3 last week. I tried a similar set of possibles fixes, but nothing worked. I ended up restoring my system from a time machine backup.

    Were you ever able to fix this without restoring or reinstalling?
     
  3. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #3
    two months old

    You might not get a reply to that question.
     
  4. rs49a macrumors newbie

    Joined:
    Apr 19, 2010
    #4
    Sure, but on the off chance that he or she later found the solution to the problem, I would care to learn what it was.

    This is the most mysterious and intractable problem I've encountered on Mac OS X! Fixing it by restoring the system from time machine without really understanding what was going on is unsatisfying.
     
  5. Aaron H. macrumors newbie

    Joined:
    Jun 8, 2009
    #5
    My Solution

    I had this problem after having copied some stuff with hidden folders from the Snow Leopard DVD to my desktop. Using terminal to look at the file listing of the desktop I noticed an odd '@' sign at the end of the permissions. Some googling found this thread explaining extended attributes.

    If you enter the following command in terminal it will remove those extended attributes (like a custom icon, etc.) and everything will be back to normal.

    xattr -d com.apple.FinderInfo <directoryName>

    For me, using xattr -d com.apple.FinderInfo ~/Desktop totally fixed my problem.

    Good luck. I hope this helps.
     

Share This Page