Mac OS X 10.6.3 with Coolbook 2.16 ???

Discussion in 'macOS' started by applevx, Mar 30, 2010.

  1. applevx macrumors member

    Joined:
    Mar 10, 2009
    #1
    Does anyone know if Coolbook 2.16 still work with Mac OS X 10.6.3 update?

    Thanks in advance :)
     
  2. derlockere macrumors member

    Joined:
    Jun 16, 2009
    #2
    It seems to work somehow awkward :(

    When you set the values and load the CPU with the Coolbook slider the voltage for e.g. 2660 (which is set to 1.0875 for my setup) is set to 1.0875 at first glance, but then somehow overwritten by whatever to the default value of 1.175 :(

    bottom line: seems not to work properly :(
     
  3. applevx thread starter macrumors member

    Joined:
    Mar 10, 2009
    #3
    derlockere, thank you for you reply, I am a little bit worry too and I will wait for a little longer to install 10.6.3, because I really need coolbook to cool my MBP :)
     
  4. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #4
    didnt work for me, but 2.17 was released yesterday and after a couple reboots, it seems to work ok.

    if you run this command in terminal, it will display what coolbook driver is running:
    kextstat | grep cool

    mine shows se.coolbook.driver2 (2.1.0)
     
  5. chaurjyh macrumors newbie

    Joined:
    Feb 15, 2008
    #5
    2.17 didnt work for me.... i'm having the exact same issues as in v2.16 also.... I can add freq and voltage etc to the list... but the information area always show only 1 frequency at its unmodified voltage (1200Mhz @ 0.9375V)... that number never changes to show any signs of throttling.. anyone else having same issues?
     
  6. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #6
    i was having the exact same problem yesterday and thought updating to 2.17 fixed it, but maybe it was something else. i was installing other stuff and rebooting a lot, so maybe something got updated in the process that also coincidentally fixed coolbook.

    i would try repairing permissions and rebuilding the kext cache.

    to rebuild kext cache, in terminal:
    touch /System/Library/Extensions/
     
  7. chaurjyh macrumors newbie

    Joined:
    Feb 15, 2008
    #7
    been doing that for the past few hours and many reboots... nothing seems to help it much..... the freq and voltage reading is screwed and it seems to me degrading my system performance a lot.....
     
  8. danilcha macrumors newbie

    Joined:
    Apr 7, 2010
    #8
    The same with 2.17 on 10.6.3

    The same with CoolBook 2.17 on Mac OS X 10.6.3. Everything seems to work, kextstat | grep cool outputs se.coolbook.driver2 (2.1.0) <4 3 1>, but controller shows maximum processor voltage:

    [​IMG]
     
  9. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #9
    it seems like more than a few people are having this problem. contact support support@coolbook.se and maybe point magnus to this thread.

    when i had this issue after upgrading to 10.6.3, i did some other software updates and installed the iphone sdk. after a couple reboots, the problem magically went away. maybe some setting or permission outside of coolbook got reset, which allowed coolbook to function. i don't know.
     
  10. applevx thread starter macrumors member

    Joined:
    Mar 10, 2009
  11. D A macrumors regular

    Joined:
    Nov 21, 2008
    #11
    I think I got it working for me, with 2.1.6, after lots of tries:

    1. Install 2.1.7 and reboot.
    2. Go to a 2.1.6 CoolBookController, right/control click on it and choose "Show Package Contents".
    3. Navigate to Contents/Resources, and there you'll see CoolBook2SL.kext.
    4. Right click on it and again choose "Show Package Contents".
    5. Navigate to Contents/Mac OS
    6. Open a new Finder window and go to /System/Extensions
    7. Find CoolBook2.kext, right click, "Show Package Contents".
    8. Navigate the new window to Contents/Mac OS.
    9. Drag the other CoolBook2 to the one found in /System/Extensions and replace it
    10. Open Terminal and type sudo nano /System/Library/Extensions/CoolBook2.kext/Contents/Info.plist (you'll be prompted to enter your password)
    11. Look for CFBundleVersion, on the row below it should say 2.1.0, edit it to say 2.0.9
    12. Press ctrl+x to save the document (press y to confirm saving).
    13. Now the final thing that needs to be done is to reset the ownership of the kext.
    14. In the terminal type sudo chown -R root:wheel /System/Library/Extensions/CoolBook2.kext/
    15. To make sure it reads the updated kext type this in the terminal: sudo touch /System/Library/Extensions/
    16. Reboot.
    17. Open the 2.16 CoolBookController, with it you should be able to set voltages correctly.


    To confirm that the voltages actually are working open Terminal and type:
    sysctl -a | grep coolbook2

    Look for the lines
    kern.coolbook2_vid
    kern.coolbook2_ctl

    The first is the current voltage and the second the CPU frequency. If they match what you had set with CoolBookController CoolBook is working as it should
     
  12. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #12
    so what did you to get it working? did you get help from magnus?
     
  13. blomma macrumors member

    blomma

    Joined:
    Apr 13, 2010
    #13
    Solution

    I had the same problem and no whatever cleaning, vodoo i tried it wouldnt work. So as a last solution i simply uninstalled CoolBook from preferences and restarted. After this i reinstalled CoolBook and reentered all the frequencies/voltage and restarted. And whatdoyouknow, it worked.

    So if nothing else works just uninstall it and reinstall and see if that works for you.
     
  14. applevx thread starter macrumors member

    Joined:
    Mar 10, 2009
    #14
    This is what I did too. First uninstall coolbook 2.16 ---> reboot ---> then install coolbook 2.17, after that you can set it like before.

    Good luck :)
     
  15. dia3olik macrumors member

    Joined:
    Sep 14, 2007
    #15
    hi guys!
    10.6.4 is ok with coolbook 2.17?
    i was thinking of update with combo...
    thanks!
     
  16. iNtaCt macrumors member

    Joined:
    Aug 23, 2008
    Location:
    Bulgaria
    #16
    Hello guys. I just want to know something about this program. Is it Necessary to open it every time a start up my mac or it is On but hidden somewhere ? Thank you
     
  17. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #17
    upon running the main app the first time, it will ask you to install some components. one is a background daemon:
    /System/Library/LaunchDaemons/se.coolbook.switcher.plist

    the other is a kernel extension:
    /System/Library/Extensions/CoolBook2.kext

    the background deamon controls the cpu speed and voltage based on your settings. this is always running in the background, so you can quit the main app.
     

Share This Page