Mac OS X 10; G5 DVD Player Problem

Discussion in 'Mac Apps and Mac App Store' started by MoldyClay, Oct 29, 2006.

  1. MoldyClay macrumors newbie

    Oct 29, 2006
    Out of nowhere, I am getting an error message that says:


    The disk you've inserted cannot be read by this computer.

    And I get this with ANY DVD that I put inside the tray.

    - The Mac is brand new (like, I got it in July)
    - The DVD player HAS worked before, and on DVDs that don't work now (I put Advent Children in it a month ago, and put it in today and it won't work)
    - It still reads CDs and CD-Rs.
    - DVD Player opens up fine and plays stuff previously copied to the computer.

    I don't get what happened.
  2. Fearless Leader macrumors 68020

    Mar 21, 2006
    try these two things: repair permissions, if that doesn't work turn off your computer and hit the power button then hold down the shift key until your mac is up. Try then.
  3. MoldyClay thread starter macrumors newbie

    Oct 29, 2006
    Ahh... um...

    1. I haven't a clue what Repair Permissions is.

    2. I held down shift for a long time, then the computer had a fit, and turned off a while after I let go (the disc thing started making a loud spinny noise). Then I turned it back on and it said that the disc was unreadable. I'm going to try it again, letting go before it starts loading like insanity... but I didn't entirely understand what you meant.

    Edit: I totally just fixed it with what I just said I was going to do, the SHIFT thing. Thanks a lot. *internet affection* lol
  4. BengalDuck macrumors regular

    Oct 27, 2006
    holy hell, i have the same problem on a year old powerbook g4. i just registered to these forums and made a post about three days ago with this exact same problem. DVD's don't work, but DVD does... CD's and installing CD's work fine.
  5. BengalDuck macrumors regular

    Oct 27, 2006
    well, hell, Clay... I didn't have as easy as a time as you did.

    I also have no clue what Repair Permissions is.

    I turned off my powerbook, then rebooted and held down shift as soon as I heard the fan going. I held shift for maybe 5 minutes and I never got past the white screen where the circle thingy seems to be loading in a circle.

    I held down power again to turn it off...then just held it down again to turn my computer on, holding down shift from the blue screen. I still got the same disk insertion message as before.

    MoldyClay, help me out man!

    (I should note that I took my powerbook in to the mac store to get it fixed, and free of charge they gave me a new superdrive. and now my powerbook runs worse...slower, takes forever to boot up. i'm really pissed.)
  6. BengalDuck macrumors regular

    Oct 27, 2006
    What I've done since then...

    I turned off the powerbook, then rebooted in safe mode (held down shift) WITHOUT the DVD in it. The DVD mounted on the desktop fine, but it said that there was no program readible (or something like that message... I double-clicked the DVD on the desktop and it gave me a VIDEO_TS folder, with no movie in it (just the chapters in .formats I have never seen)... I tried, in safe mode, to open DVD and I got the same error message as when I initially inserted the disk in safe mode, where there was not a program which could read the disk (essentially the message).

    I turned off the computer, and booted the computer normally without the DVD in it. I instered the DVD and I get the same message as I did originally...DISK INSERTION

    The disk you've inserted cannot be read by this computer.


    I rebooted in safe with the disk inside this time, and the same error occured when I tried to open DVD "There was an initialization error. A valid video device could not be found for playback [-70017]". I took out the disk (in safe mode) and inserted another DVD and I had the same problem.

    I again rebooted in normal mode and inserted a disk. Once again it was the first error... "disk insertion...disk is not readable"
  7. Fearless Leader macrumors 68020

    Mar 21, 2006
    ok so is it working? To repair permissions go into Applications->Utilities open disk utility. In a list of drives on the left, select your main partition (the same one you see on your desktop). Under the white box look for the button "Repair Disk Permissions"
  8. Markleshark macrumors 603


    Aug 15, 2006
    Carlisle, Up Norf!
    I had this on Jaguar on my iBook, while trying to upgrade to my new shiny copy of Tiger (On DVD) I had to go via my CD copy of Panther because Jaguar wouldn't read the Tiger DVD, however, Panther read it fine. It seems a bit strange.
  9. Frank Clark macrumors newbie

    Mar 4, 2008
    I have the same problem, with "the disk you have inserted is not readable by this computer" message.

    This is not a disc specific problem, but a general problem affecting all software disks. DVD's are not a problem.

    I just noticed it a week ago when trying to install software from a HP scanner.

    Then it wouldn't read my tax software, nor would it read any of my kids "Reader Rabbit" disks.

    I have tried the restart with shift key down, and got the "safe" boot message on the screen (this actually took care of a screen wake up problem I was also having).

    But so far, nothing has helped with the "the disk you have inserted is not readable by this computer" message, which prohibits use of whatever disk is inserted.

    Still looking for help.
  10. mrlino macrumors newbie

    Mar 4, 2008
    DVD initialization error

    hi guys, here's what has happened. I was watching a movie on my G4 tower. My monitor turned white with horizontal lines but I had the sound. I turned the power off and replaced the monitor. Turned power on, double-clicked on the DVD icon and got an "error" message box. It read:

    There was and initialization error.
    A valid video device could not be found for playback. [ -70017 ]

    I tried others DVD movies, same message. I see the DVD disk on the screen.
    I can open the DVD program but can't play anything from it.
  11. Frank Clark macrumors newbie

    Mar 4, 2008
    No luck yet

    Just to update my previous message...

    I bought (through a download) and used the DiskWarrior program that another poster had recommended.

    It did not help at all.

    I spoke with Apple Support and they said it sounded more like a bad disk drive.

    They warned against using DiskWarrior with the Leopard OS. I still use Tiger fortunately.

    I still don't have it fixed. A local Apple certified repair center has not returned my request for an estimate for a new disk drive. Hopefully that repair (if affordable) will fix the problem.

    I am still open for more economical solutions....

  12. maxiemain macrumors newbie

    Feb 6, 2009
    Repair Permissions

    Hey so I googled repair permissions and I found out how to access them. Once I ran it my dvd player worked fine. Here's what the website said:

    To improve your system's performance, use the permissions repair function in OS X's Disk Utility program:

    To open Disk Utility, from your Applications folder, open your Utilities folder and double-click the Disk Utility icon.

    In the column on the left, click your startup disk's icon.

    Click the First Aid tab, and then click Repair Disk Permissions. Disk Utility will reset any files and folders with incorrect settings.

    The website where I got the is here:

    Hope it helps!
  13. Frank Clark macrumors newbie

    Mar 4, 2008
    Thanks for the reply. For a few minutes I had hope that it might work.

    Unfortunately even after following the directions three times, it still did not fix the "The disk you have inserted cannot be read by this computer" message. I also now have to shut down the computer and restart it for the disk to eject.

    I will probably take it to a Mac repair place. The closest one to me though is a three hour drive, and I don't get there often. Thanks again for your efforts!

Share This Page