mac os x can't be installed on this computer.

Discussion in 'iMac' started by Marcnutt, Sep 12, 2012.

  1. Marcnutt macrumors newbie

    Sep 12, 2012
    I tried reinstalling Os x on an imac but came up with this message. Read many forums and they recommended erasing the hard drive and then reinstalling the software.

    I have erased the hard drive, so now I have the flashing question folder but when I come to install mac os x it continues to say can't install.

    I have used the cd before to install so not CD error and I have also done a hardware test and everything is okay.

    Any ideas?
  2. iBookG4user macrumors 604


    Jun 27, 2006
    Seattle, WA
    What OS are you trying to install? What model of iMac is it from what year?
  3. Marcnutt thread starter macrumors newbie

    Sep 12, 2012
    its a IMAC 10.1, intel core 2 duo. Had for 2 years.

    Trying to install OS X 10.6.4 from CD.
  4. GermanyChris macrumors 601


    Jul 3, 2011
    Zero out the HD, and delete the recovery partition.

    I'll assume you had Lion or ML on there before. If not just zero it out.

    don't use erase disk use partition and create one partition once you have your new disk then go to erase disk and zero it out.
  5. Marcnutt thread starter macrumors newbie

    Sep 12, 2012
    I have erased all HD, deleted the partitions.

    Unmounted everything, Zero'd everything as well.

    Now when I start it shows the question mark folder and still won't install from CD.
  6. GGJstudios macrumors Westmere


    May 16, 2008
    Are you using the discs that came with that iMac, or from another Mac, or a retail copy of Snow Leopard? The grey install discs that come with Macs are model-specific and will not work on other models. You can order replacement discs for your model by calling Apple (800-767-2775 in the US).
  7. Zedsdead185 macrumors 6502

    Sep 14, 2006
    if you have another mac, see if you can boot the imac into target disk mode, link it with the other mac via firewire and try and install it onto the imac hard drive that way.
  8. G4DP macrumors 65816

    Mar 28, 2007
    It will do. You have nothing on the system, so when you turn the Machine on, it can't find the system disc.

    So when you start the machine from the OS disc you get the error?

    If so call Apple, they'll send you a new DVD with the machines original Software, as you are still covered by applecare - if you got it - this will be free.
  9. readymade524 macrumors newbie

    Sep 13, 2012
    You deleted the partitions, but did you create a new one? There needs to be a partition on the drive, otherwise installation will fail.
  10. nagareru macrumors regular

    Jun 11, 2012
    Lima, Peru
    Your hard drive is faulty. You have to replace the hard drive.
  11. cyclotron451 macrumors regular


    Mar 16, 2005
    I'm getting this too on a stock iMac core2Duo post ML install. My ML prompted me to do the 10.8.2 upgrade, and it failed, never restarting. I've now (on and off) spent 2 months trying everything I can think of! luckily it's not a mission critical iMac.

    I CAN successfully install Snow Leopard 10.6 from the 2Z691-6428-A install DVD, or
    I CAN successfully install ubuntu 10.04 LTS Lucid Lynx as main OS,
    (the above installations however don't feel right, get a lot of dimmed blue screen/extremely slow booting/sometimes no desktop for ten minutes post reboot!)

    everything else I try, usb & dvd based Lion/ML/Original iMac grey install 10.6 2Z691-6590-A discs/ any other ubuntu including the 11's fails. I've erased HDD in Mac, erased in ubuntu 10.04, partitioned with disk-utility or Gparted, basically tried nearly every logical step. AHT v.3A178 on iMac Applications DVD won't even run.

    I don't like the fact that the iMac is not able to be returned to a blank condition. ML has obviously done something slightly tricky to the HDD, which normally wouldn't be a problem, but here we're experiencing the "one-in-a-thousand' type of problem which could affect very many people if they also have an ML upgrade go-wrong.

    I think I nearly agree that the HDD is 'faulty' - except it is passing all the s.m.a.r.t. tests in Linux - and that my only choice is to open up the iMac and swap the 250GB HDD for something newer and untouched by ML. With the available tools, and quite a bit of time spent in terminal, I certainly would have gained much time by a physical swap. There is a whiff of danger about a failed Mountain Lion installation - it seems to 'break' the HDD!

    in comparison, I'm beta testing ML 10.8.3 12D50 (not on this iMac obviously) and it's nearly ready!
  12. Gazally macrumors newbie

    Jun 14, 2013
    I've got the same problem. can it be a problem with the hard disk?

Share This Page