Mac OS X has a weird boot icon

Discussion in 'macOS' started by LeoTheLion89, Mar 28, 2012.

  1. LeoTheLion89 macrumors 6502

    LeoTheLion89

    Joined:
    Feb 14, 2012
    #1
    i installed Mac OS X 10.5. on my computer and now i have a strange thing it installed fine i rebook shows the boot screen then right in the middle of the Apple icon i get a white square with a NO symbol in it the pinwheel loading icon still moves but after this strange icon appears it just sits there
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
  3. LeoTheLion89 thread starter macrumors 6502

    LeoTheLion89

    Joined:
    Feb 14, 2012
    #3
    meaning?
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    Mac OS X knows that it's a stolen copy and won't boot. That's what DSMOS stands for "Don't Steal Mac OS". It's rare that it does this, but it can happen.
     
  5. LeoTheLion89 thread starter macrumors 6502

    LeoTheLion89

    Joined:
    Feb 14, 2012
    #5
    thing is it works fine until i install a ktext IOPCIFamily patched or the fix to make OS X properly detect PCI devices
     
  6. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #6
    That's one of the things the DSMOS verifies on startup. There are a few other key kexts and binaries it checks as well.
     
  7. LeoTheLion89 thread starter macrumors 6502

    LeoTheLion89

    Joined:
    Feb 14, 2012
    #7
    i selected to patch DSDT will this help?
     
  8. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #8
    Possibly. I don't know much about Hackintoshes.
     
  9. charlieegan3 macrumors 68020

    charlieegan3

    Joined:
    Feb 16, 2012
    Location:
    U.K
    #9
    isn't this thread discussing an illegal issue?

    not sure where the forum stands on piracy?
     
  10. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #10
    Hackintoshes are a gray area as far as legality goes. They are allowed to be disused on MacRumors. But LeotheLion89 does have a history of bad ethics when it comes to pirating and stealing software.
     
  11. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #11
    It is in the grey area, since it is a violation of the EULA. But for discussion about Hackintosh matters, the following sites will be more helpful:


    ----------

    And that as a vendor.
     
  12. LeoTheLion89 thread starter macrumors 6502

    LeoTheLion89

    Joined:
    Feb 14, 2012
    #12
    my main thing is my Broadcom Wifi card does not work even with the driver and even following the steps on InsainlyMac it didnt help so i decided to install the IOPCIFamily.ktext and get this issue

    ----------

    i am a vendor of myself
     

Share This Page