Mac OS X Lion broke Internet Sharing with my Xbox 360

Discussion in 'Mac Basics and Help' started by tuna, Jul 23, 2011.

  1. tuna macrumors 6502

    Joined:
    Apr 11, 2010
    #1
    I had successfully configured my MBP to share internet with my Xbox 360 under snow leopard. After installing lion, without making any settings changes, it no longer works.

    I was even able to configure another MBP still running Snow Leopard with the exact same settings as on my Lion computer, and it still works. The problem is from Lion.

    Here are my wifi settings:

    [​IMG]

    Here are my ethernet settings:

    [​IMG]

    Here are my internet sharing settings. I have also tried "Airport" rather than "Wifi", that doesn't work either:

    [​IMG]

    My wifi router is at 192.168.1.1

    My Xbox 360 has the following configuration:

    IP: 10.0.0.2
    Subnet Mask: 255.255.255.0
    Gateway: 10.0.0.1

    Primary DNS Server: 192.168.1.1
    Secondary DNS Server: 8.8.8.8 (Google DNS)


    What do I do?
     
  2. MasterTick macrumors 6502

    Joined:
    Jun 22, 2009
    #2
    Having the same issue, really annoying.
     
  3. MacFS macrumors newbie

    Joined:
    Jul 24, 2011
    #3
    Lion stopped my Xbox Sharing.

    Since installing OS X Lion on my Mac i am unable to share my internet connection with my Xbox as well. So frustrated as i don't nor do i want a massive cable running around the house, and i also don't want to buy an Xbox wireless piece as i don't need one thanks to Mac sharing, which is now unavailable! Please someone help us out with a way to fix this.
     
  4. MasterTick macrumors 6502

    Joined:
    Jun 22, 2009
    #4
    Bear in mind I did this using a Windows machine, but I'm able to get it to work if I leave it plugged in and restart my Mac. That seems to fix it every now and then.

    I may just install Snow Leopard on a small partition since Lion won't work half the time.
     
  5. PRSBOY macrumors newbie

    Joined:
    Jul 25, 2011
    #5
    I had this same issue.

    My fix was to change the options to "Automatic", where as before I had them manually set. Hope this helps someone.
     
  6. tuna thread starter macrumors 6502

    Joined:
    Apr 11, 2010
    #6
    Change which settings to automatic? On the Mac or the Xbox? If on the Mac, do you mean the ethernet settings? On either, do you mean the IP settings or the DNS settings?

    If you could post your exact configuration for your Mac's Ethernet and Internet Sharing, and then the exact settings for your Xbox's ethernet, I would appreciate it!
     
  7. mac00l macrumors 6502

    Joined:
    May 3, 2011
    #7
    The problem is not that Lion broke it. Actually Lion fixed it, and now it works as it should.

    Just set internet sharing on as you usually do
    System Preferences/Sharing/
    Set:
    Share your connection from: WIFI
    To computers using: Ethernet

    And then go to your ethernet configuration
    System Preferences/Network/
    Highlight: Ethernet
    Set:
    Configure IPv4: Using DHCP

    Then click apply

    And that should be it
     
  8. -tWv- macrumors 68000

    -tWv-

    Joined:
    May 11, 2009
    Location:
    Ohio
    #8
    Well if thats the case that will be nice, I remember going through an annoying half hour long process when I was trying to share my internet with my xbox.. It was really frustrating
     
  9. zwash7212 macrumors newbie

    Joined:
    Jul 30, 2011
    #9
    Something I found that works:

    Its real simple. When you installed Lion, AirPort became Wi-Fi, if your sharing settings say "share from AirPort" then you are not sharing a connection. Make sure they say "sare from Wi-Fi), set you connection to share to Ethernet, set your Xbox to Automatic settings, and connect.

    Good luck. See when MW3 comes out.
     
  10. benhollberg macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #10
    Last year somebody helped me figure out a way to make my Mac a router with Internet Sharing so I could use my Apple TV wirelessly without a router, since Apple TV doesn't accept Ad-hoc networks. Since upgrading to Lion I can't share my connection using the same method you all were, I think. Just opening Internet sharing and select share Ethernet connection to users on WiFi. Now when do that it says it is active but the WiFi indicator in the top bar doesn't have the arrow it used to and the Apple TV can't find the network.
     
  11. beansperkins macrumors newbie

    Joined:
    Aug 1, 2011
    #11
    Interesting. I tried this, to no avail. Could you elaborate on the settings needed on both the Mac and the Xbox?
     
  12. leonrangel macrumors newbie

    Joined:
    Aug 2, 2011
    #12
    Finally resolved!

    Finally I have internet on my Xbox using Mac OSX Lion Internet Sharing, it´s so easy:

    MAC:

    1.- You have to set Internet Sharing "FROM WI-FI" (not Airport as it used to be)
    2.- In Network Settings - Ethernet - Configure IPV4 - "use DHCP" (that´s it, configuration will set automatically)


    XBOX:

    1.- Just put all settings in Automatic (IP, DNS, etc)

    Test your connection, and THAT´S IT!
     
  13. jakester2 macrumors newbie

    Joined:
    Feb 6, 2008
    Location:
    Monmouth, OR
    #13
    Thank you! worked perfectly
     
  14. Hermes Monster macrumors 65816

    Hermes Monster

    Joined:
    May 4, 2010
    Location:
    UK
    #14
    does this allow you to stream movies and music to your xbox then?? I wasn't aware you could that... without buying an app at least..
     
  15. -tWv- macrumors 68000

    -tWv-

    Joined:
    May 11, 2009
    Location:
    Ohio
    #15
    No, this is only sharing the internet connection from your mac to the xbox so you can connect to xbox live
     
  16. Hermes Monster macrumors 65816

    Hermes Monster

    Joined:
    May 4, 2010
    Location:
    UK
    #16
    Oh right....

    Excuse my ignorance..but why would you do this? Not being funny, just don't understand the circumstances in which this would be needed. :confused:
     
  17. MasterTick macrumors 6502

    Joined:
    Jun 22, 2009
    #17
    To connect your Xbox to the Internet? To stream Netflix/Hulu+/Zune Marketplace/Online games/Voice and text chat/Download new games, maps, etc.

    There's a lot of reasons lol.
     
  18. Hermes Monster macrumors 65816

    Hermes Monster

    Joined:
    May 4, 2010
    Location:
    UK
    #18
    Yeah I get why you would want to connect it to the internet....I didn't ask why you would connect it to the internet..

    but why would you do it via your mac? Is the xbox connected to the mac via an ethernet cable or something, rather than connecting directly to the router via ethernet or wireless?
     
  19. MasterTick macrumors 6502

    Joined:
    Jun 22, 2009
    #19
    My bad.

    The older Xboxes didn't come with a built in wifi adaptor, so instead of buying one you can just plug an ethernet cable from your Mac to the Xbox and it will use the wifi from your laptop to get online.
     
  20. beansperkins macrumors newbie

    Joined:
    Aug 1, 2011
    #20
    Okay, so I've got this to work a few times, but most the time it doesn't work at all... What gives? Sometimes it decides to prefer to get internet from the ethernet line, which is the xbox, and that doesn't work. Other times it just will not get an IP from my mac... Is anyone else having troubles getting this to work consistently? I've followed the directions here exactly, and sometimes it still doesn't seem to work.
     
  21. jpearce8 macrumors newbie

    Joined:
    Mar 5, 2012
    #21
    Fixed it - had the same issue as many who followed these guys tips, but not work

    Hello everybody, I tried everyones' suggestions as to the "easy" fix but it never worked for me. The reality is for many people, including myself, OS Lion would not let my xbox use my macbook's internet connection (even though I did the suggestions of making everything automatic etc.). It use to work before updating it to OS Lion. I don't know why it messed it up, but whatever it did to make it "easier" it didn't for me.

    Anyways, this is what fixed it for me.

    1) Do as the others said, go to network then wi-fi and make sure it's turned on and set as using DHCP and the IPv6 as automatic. Also, make sure under sharing turn on internet sharing FROM wi-fi TO ethernet. **I restarted my macbook just to make sure all the settings were set in. Not sure if this is necessary, but I did it.

    2) Go to xbox then the network settings and in basic settings set the top section (IP settings, IP address etc.) as automatic. However, for the bottom part, set it as Manual then in the "Primary DNS server" type in YOUR ROUTER NUMBER. Next step to find your router number if you don't know it.

    3) Go to network on the macbook again, then under wi-fi click advanced. Go to TCP/IP then look for "router". Type that number into the "Primary DNS Server" on the xbox.

    That made it all work for me. If it doesn't, try restarting the xbox with that changed settings and the ethernet plug connected between the macbook and xbox.

    I hope this works for you because I tried everyone else's suggestions on here and on youtube, but it never worked for me. I don't know why it didn't for me or for others like me, but this worked.

    Feel free to message me if you have issues and I'll try to sort out if I missed a step. Take care!
     
  22. gmanist1000 macrumors 68030

    gmanist1000

    Joined:
    Sep 22, 2009
    #22
    Confirming that this method works with Mountain Lion as well.
     

Share This Page