Mac OS X Lion install problem/Drive issue.

Discussion in 'MacBook Pro' started by Mspearin, Apr 19, 2013.

  1. Mspearin macrumors newbie

    Joined:
    Apr 19, 2013
    #1
    A few days ago I got an error when I tried to take a snapshot of my screen. It told me that I couldn't take it because the place I was going to save it to I didn't have permission to save there. I the tried to copy and paste items from one part of the drive to the other . Even just trying to duplicate items on the desktop it would give me a unexpected error. I can't remember the number. I then just went about working on my computer for about 2 more days I didn't shut it down I just let it go into standby. I then got a error message that popped up and it was a force quit window saying that I had maxed out the available memory and to close out of the applications. I closed all the applications open at the time and then I went to the disk utility and checked my hard drive and sure enough I had about 550GB free of a 1TB drive. I then got the error again with the force quit window. I closed disk utility and when I tried to open it again it wasn't able to be found in the spotlight search. I opened a finder window and clicked on the application folder and there was nothing in there . After that the computer just started running very very slow. I click the reset button and then when it went to boot it would just stay at the gray screen with the apple logo and the spinning wheel. I then tried booting in Safe-mode. It would load the bar about a quarter then it would switch to just the spinning pin wheel. After this I went into the single user mode and ran the repair code. It says the the drive was fixed and there was no issues. S I removed the drive and hooked it up to my Mac mini. I removed all my data and ran a the disk repair and it was fine. I was looking up online for a fix and it says to just format and reinstall the OS. When I launch the installer from the USB drive I get to the lion install page. I the click on dick utility and try to format it. It is now giving me a cannot unmount error. I went to terminal and was able to force unmount it but it wouldn't allow me to format it. It would just freeze up. I left it for about 2 hr just invade it was formatting and it was the Same. Is there a fix to this? I really need this fixed by Monday for work.
     
  2. Mspearin thread starter macrumors newbie

    Joined:
    Apr 19, 2013
    #2
    Okay so I decided to take the hard drive out ad just test and see if I could hook it up externally and see if I could format it from my laptop. Sure enough i took it out and plugged it in and it works fine. I now have the OS being installed on the external drive. What could cause the problem? Is this just a data cable issue? Or a motherboard issue?
     
  3. justperry macrumors G3

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #3
    If I were you I would run Apple Hardware Test to see if there are any problems.

    But, I think the problem was permissions, did you change any permissions by yourself?
    There are people which change the permissions on the HD and end up messing up their OS Install.
    Don't change anything you don't know of.
     
  4. Mspearin thread starter macrumors newbie

    Joined:
    Apr 19, 2013
    #4
    I tried to run the apple hard where test on boot by holding the "D" key audit won't do anything. Before I was having the errors I didn't change any of the permissions. That's why I was starting to think maybe its a bad sata cable. I was able to install the OS on the internal drive when it is hooked up externally but when I reinstalled it in my laptop it won't boot. If I have it plugged icon the outside and I hit the option key at boot it fires right up with no issues.
     

Share This Page