Mac OS X Lion install problems

Discussion in 'macOS' started by jpa317, Jul 20, 2011.

  1. jpa317 macrumors newbie

    Joined:
    Feb 12, 2011
    #1
    I am installing the Lion update through the app store. When the computer restarts into the Lion installer it says "Install Failed"
    "Mac OS X Lion couldn't be installed, because the disk Macintosh HD is damaged and Can't be repaired."
    The only option it gives me is to "Click Restart to restart your computer and try installing again"
    I have tried quitting the installer and going to Startup Disk but that wont let me reboot into Snow Leopard.

    Please Help!
     
  2. brzezj macrumors newbie

    Joined:
    Jul 20, 2011
    Location:
    Chicago
    #2
    Same thing happened to me, and when I try to repair the disk it tells me that the drive cannot be repaired because it cannot be written too...anyone have some insight on this matter?

    EDIT: when verifying the disk it gives me the error "invalid node structure"
     
  3. jpa317 thread starter macrumors newbie

    Joined:
    Feb 12, 2011
    #3
    I have tried verifying and fixing disk permissions from my Snow Leopard install dvd. They both stop and say that it cant be repaired. Is it possible to delete the Lion Installer using terminal when I boot up from the DVD?
     
  4. paulobrad macrumors regular

    Joined:
    Jun 30, 2007
    Location:
    UK
    #4
    This has happened to me too :-(

    In the installer log it says:
    PFPackage::packageWithURL - can't instantiate package: /System/Instalation/Packages/OSInstall.mpkg

    Verify/Repair failed with error -69845 (file system verify or repair failed)

    Any ideas??
     
  5. Mikizi macrumors newbie

    Joined:
    Jul 20, 2011
    #5
    I have the same problem. "Lion can not be installed because the macintosh HD is damaged and can not be fixed".

    Downloadind starts and it gives the estimation about 32 or 33 minutes, and then this announcement is coming, that it can not be installed...

    Does anybody has any ideas what to do? Is this happeninhg because there is so many people trying to download at the same time or what?
     
  6. Jehede macrumors newbie

    Joined:
    Jul 20, 2011
    #6
    I've got the same problem :-( If someone out there have a solution to this PLEASE reply!

    Is it possible to gain access to any of your documents? My Mac wont start in safe mode either :(:(:(...............
     
  7. romanas macrumors newbie

    Joined:
    Jul 20, 2011
  8. RyanTheGeneral macrumors regular

    Joined:
    Sep 10, 2009
    #8
    My download had failed- but it restarted where it had left off. As for installing luckily I did not have a problem. If I hear anything I will report back- but I don't think its because of the traffic if its for the installer not the downloading.
     
  9. stahlmannen macrumors newbie

    Joined:
    Sep 16, 2009
    #9
    I have the exact same problem. Is there no way of reverting to the Snow Leopard installation, or does the Lion installer wipe it? Seems strange...
     
  10. romanas macrumors newbie

    Joined:
    Jul 20, 2011
    #10
    I could not find a way to switch back to Leopard.

    What really scares is that it's not possible to mount Leopard hard drive anymore. Even after reload from Leopard DVD disk.

    Damned, there are all my photographs from vacation on this drive and I don't have a backup! :D
     
  11. APisano17 macrumors newbie

    Joined:
    Jul 20, 2011
    #11
    Glad I'm not the only one that's having this problem. When it reboots, it goes back into the install program. Can't get it to boot into Snow Leopard. Any solutions yet?
     
  12. elvtnedge macrumors regular

    Joined:
    Jun 11, 2007
  13. heiflo macrumors newbie

    Joined:
    Jul 20, 2011
    #13
    Same here. I could finally install Lion this way:
    1. Insert your Mac OS X Install DVD and restart the computer.
    2. Press and hold the <alt> (aka option key) as soon as you hear the start sound, so you'll be able to choose to boot from the DVD.
    3. Open the Disk Utility program (by choosing it from the menu bar), select your disk and first click "Repair permissions" then "Repair disk" (in this order).
    4. Once finished, restart your computer. The existing Snow Leopard installation should boot by default.
    5. Finally, start the Lion installation again.
    Hope this helps!
     
  14. verschel macrumors newbie

    Joined:
    Jul 20, 2011
    #14
    Tried this, get "can't repair the disk
     
  15. APisano17 macrumors newbie

    Joined:
    Jul 20, 2011
    #15
    ditto.
     
  16. romanas macrumors newbie

    Joined:
    Jul 20, 2011
    #16
    tried a number of times without success.

    "repair permissions" button is always inactive, so I can't click it.
     
  17. jpa317 thread starter macrumors newbie

    Joined:
    Feb 12, 2011
    #17
    I have already done and disk utility says it cannot repair my drive.
     
  18. dvd1984 macrumors newbie

    Joined:
    Jun 26, 2011
    #18
    I'm having the same problem with the server version. I get a kernel panic when the computer restarts. I was on the phone with Apple support for 2 hours today. Somehow my boot drive was deleted in the initial install. They finally recommended reinstalling Snow Leopard then trying the process over again. When I try to reinstall 10.6.6 off the disc I'm told that I can't upgrade to this version because a newer version is already installed (10.6.8). I am also unable to reformat the hard drive.
     
  19. jpa317 thread starter macrumors newbie

    Joined:
    Feb 12, 2011
  20. heiflo macrumors newbie

    Joined:
    Jul 20, 2011
    #20
    Sorry to hear it did not work out for you.

    Have you tried (in Disk Utitlity launched with your installation DVD) "Verify Disk Permissions" (will take a while), then "Repair Disk Permission", then "Verify Disk" (will take a while, too), then "Verify Disk"?

    If you see an inactive "Repair Disk" button you have to "Verfiy Disk" first.

    These where the troubles I initially encountered before the installation finally worked:
    1. When I used the Disk Utility that came along with Lion's installer and tried to repair disk I got the error message "Invalid node structure".
    2. When tried to boot from a Snow Leopard Installation DVD (that I bought for my previous MBP which originally had Leopard installed) the installer did not boot. It turned out that my current MBP (2010) only boots from the DVD that was delivered with it (which is Snow Leopard 10.6.3) and does not boot from the bought Snow Leopard DVD which is 10.6.0).
    3. When I first hit the "Repair Disk" button in Disk Utility (launched with Snow Leopard 10.6.3 Installation DVD) I got the "can't repair disk" error message.
    Hope that you guys will succeed!
     
  21. jpa317 thread starter macrumors newbie

    Joined:
    Feb 12, 2011
    #21
    When you insert the install DVD for Snow Leopard restart our computer while holding down the option key. Select the DVD and from there go to utilities and then Disk utility. From there you need to select your Macintosh HD and then erase the whole thing.

    If you don't want to erase it, maybe because you don't have a back up or maybe too old of a back up and you have stuff on the computer you want to save, then I might have another solution for you. In the next post.
     
  22. jpa317 thread starter macrumors newbie

    Joined:
    Feb 12, 2011
    #22
    Ok here is a possible solution. You will need an external drive and you Mac OS X install disk. Launch the install disk on your Mac and then creates GUID partition on your external hd. Then in the installer out can install Mac os x on the new partition, and the migration assistant can acess your files still on Macintosh HD. After that you can boot from your external hd. And then save your pictures elsewhere(potentially on the same drive in a different partition or DVDs). Then you have to wipe your Macintosh had with disk utility from the install disk and then reinstall Mac os x on your computer. And you should be able to transfer files directly using the migration assistant like you did before.
    Please don't hesitate to ask for further explanation. I wrote this on my iPhone and didn't feel like making it too crazy. So if you have questions or need help please ask.
     
  23. hxxrmonkey macrumors newbie

    Joined:
    Mar 18, 2011
    #23
    Stuck in Install Loop

    If you're just at the stage where you're stuck at the installer loop where it fails and reboots into the installer and you can't get back to SL try resetting the PRAM by holding down command + option + P + R at boot.

    I had this problem yesterday and eventually had to wipe and repartition my drive to reset the partition map, restore my time machine backup from the morning, then trash and re-download the Lion installer and start all over, it worked after that.

    Would have helped if I'd known about the PRAM thing before I wiped my drive :p
     
  24. jpa317 thread starter macrumors newbie

    Joined:
    Feb 12, 2011
    #24
    For some reason my drive was corrupt and I had no partitions on it so I don't know if this would have helped.
     
  25. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #25
    If I'd read this thread, maybe I wouldn't have installed Lion. Ouch. I downloaded Lion (which took forever). I then made a backup of the install app, following the method suggested over at ars. When I was satisfied I had a backup of Lion (so it couldn't delete itself after install), I let the install run. It finished without incident. (Whew). One thing I did before starting was I spent some time in disk utility checking over the status of macintosh hd. For instance, I re-checked to make sure the partition table was GUID. I had recently upgraded my HDD and I ignored the whole GUID partition table instruction. Luckily disk utility set it up that way by default. If it wasn't GUID, I think the Lion install would have simply refused to start but I can't help but wondering if some partition table issue is related to some of the issues reported in this thread. I hope you guys get your problems figured out or at least get back to Snow Leopard.
     

Share This Page