Mac OS X Lion Virtual Host Troubles

Discussion in 'Mac OS X Server, Xserve, and Networking' started by digisavvy, Oct 21, 2011.

  1. digisavvy macrumors newbie

    Joined:
    Oct 3, 2011
    #1
    The issue
    I have a mac server running Lion. I'm using the built-in apache web server along with virtualhostx, to host multiple sites.
    The first site i installed http://digilab.co, works just fine in terms of it's URL (permalink) structure. Beautiful. However, I am hosting another site http://theurbandater.net on my server. When you go to theurbandater.net, it resolves just fine, but when you click any of the links you get something like this: http://digilab.co/~digisavvy/theurbandater/hello-world-1/. Both sites run wordpress and I'm not wanting to use MAMP.

    The redirect seems to work fine, but for whatever reason, it doesn't present the link structure as http://theurbandater.net/hello-world…

    I was hoping you might give me some insight into what might be going on. I've been banging my head on this one for a while now and can't get it figured out…

    Thanks!
     
  2. brokenreed67, Oct 23, 2011
    Last edited: Oct 23, 2011

    brokenreed67 macrumors newbie

    Joined:
    Oct 23, 2011
    #2
    Virtual Server Issue

    In Lion there are two noteworthy hosting problems.

    1) MySQL has been pulled out (fixable by way of a download from mysql.org)

    2) The virtual hosting must be enabled by hand by editing /etc/apache2/httpd.conf

    If you need help with details for either or both items, feel free to post back and I will post what I have done to work around the problem.

    I think that the latest Lion update fixes the virtual hosting issue, but I have not applied it to my server yet.
     
  3. alandail macrumors 6502

    Joined:
    Jul 23, 2002
    Location:
    Ohio

Share This Page