Mac OS X not recognising my camera

Discussion in 'Mac Apps and Mac App Store' started by Yixian, Aug 8, 2009.

  1. Yixian macrumors 65816

    Joined:
    Jun 2, 2007
    Location:
    Europe
    #1
    I have a Fujifilm S5500. About a year ago I used to it to take photos and download into iPhoto on my macbook pro. I got it out again today to use but now the same laptop isn't picking up the camera, not in the finder, not in iPhoto, not in Image Capture... nothing!

    Any ideas?
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #3
    Is it showing up under System Profiler under USB?
     
  3. Yixian thread starter macrumors 65816

    Joined:
    Jun 2, 2007
    Location:
    Europe
    #4
    Wow.. does not appear to be >_>
     
  4. NIPRING macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Waukesha WI
    #5
    I'm not trying to be a smart-@$$ but are you turning the camera on? Also my Canon 720IS wouldnt get recognized until i downloaded the newest software from canon.
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #6
    Canon does not support USB automount, but Fuji does. Canon may require that the user install its own software, but Fuji cameras should just work.
     
  6. Yixian thread starter macrumors 65816

    Joined:
    Jun 2, 2007
    Location:
    Europe
    #7
    Yeha it's on, and I've tried having it connected while on each settings: playback, camera etc.

    Nothing works.
     
  7. Yixian thread starter macrumors 65816

    Joined:
    Jun 2, 2007
    Location:
    Europe
    #8
    Almost a year on and I still can't find a solution :(:(
     
  8. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #9
    Why not get a cheap SD/XD USB card reader and use that? That way it doesn't matter what the camera is/does, you just copy the photos from the card.
     

Share This Page