Mac OS X Server v10.5.8 / Promise Vtrak E-Class Server

Discussion in 'Mac OS X Server, Xserve, and Networking' started by jah6719, Apr 22, 2013.

  1. jah6719 macrumors newbie

    Apr 22, 2013
    We have a Mac OS X Server (v10.5.8) and a Promise Vtrak E-Class Server. The Promise server (RAID) is hooked directly to the Mac Server via four cables. The Promise used to show up as an orange (external) drive. The drive was accidentally ejected from the Mac Desktop (Hence gone from our network too). The staff who set it up left behind no documentation on the settings / IP Address.

    What is the best way to find the IP Address the Promise server is putting out so we can re-mount the drive?

    The Promise does not have a monitor, keyboard, etc.
  2. CptSky macrumors regular

    Feb 1, 2013
    If you have access to the router / managed switch, you should have access to a DNS table with all MAC addresses. I know that a Xserve RAID controller have a sticker with its MAC address, for the Vtrak, I can't say, you could get the IP this way.
  3. jah6719 thread starter macrumors newbie

    Apr 22, 2013
    The Promise doesn't go through a switch / router. It is connected directly to the Mac Server.
  4. slackman1 macrumors newbie

    Jan 9, 2011
    I think the promise webinterface will present itself via Bonjour, so it should be visible from Safari, under the Bonjour menu if it is enabled.
  5. jah6719 thread starter macrumors newbie

    Apr 22, 2013
    The Promise Server is connected via a Fibre Channel (4 port PCIe card). Under System Preferences/Hardware/ Fibre Channel it shows all 4 ports have "link established". However I don't see a way to manage it.

    Under server admin app I do see not anything as an available server.
  6. chrfr macrumors 604

    Jul 11, 2009
    Server Admin is to manage the Mac server. Have you reviewed Promise's documentation? It should all be available for download on their website.
    Edit: have you rebooted the Mac? (note that the Promise unit is not a server in itself; it's a RAID system.) If the volume was merely unmounted, it should show up again on reboot.
  7. jah6719 thread starter macrumors newbie

    Apr 22, 2013
    Yes, we tried the reboot... no luck.

    I'm trying to find the Promise WebPAM utility to download. It looks like I need to hook the Promise up to our router then access from anywhere on the network with the utility.
  8. jah6719 thread starter macrumors newbie

    Apr 22, 2013
    And yes, I read reviewed the manual. I tried the default IP Address, no luck.
  9. Promise1 macrumors newbie

    Apr 25, 2013
    Hope this helps. If not please contact technical support via or call 408-228-1400 opt 4

    Assuming you have the "Mac supported" version of the Vtrak and assuming you have the network management ports of the Vtrak connected. The Mac host must also be connected to the ethernet switch. Simply open safari and look up the Vtrak in Bonjour. The Vtrak management interface "Web Pam Pro" can then be opened. The default login: administrator
    Password: Password

    If you don't find it in bonjour you need to resort to using the serial cable shipped with the unit. You will need Zterm.

    Give us a ring. You can also find the how to in the user manual or

    Hope this helps!
  10. hwojtek macrumors 65816


    Jan 26, 2008
    Poznan, Poland
    It may be a silly suggestion, but doesn't the volume show up in Disk Utility ready to be mounted?
  11. freejazz-man macrumors regular

    May 12, 2010
  12. jah6719 thread starter macrumors newbie

    Apr 22, 2013
    The Vtrak is only connected via four fibre cables to the Mac Server. The Vtrak is not directly connected to the network otherwise. The Mac Server is connected to the network switch.

    No, the Promise doesn't show up as a volume is the disk utility.

    Hiring a consultant isnt going to happen.
  13. chrfr macrumors 604

    Jul 11, 2009
    You need to connect the RAID to your network to configure it, unless as the poster from Promise said, you want to use the serial cable, which is assuredly more difficult than configuring the unit via the network.
  14. macalec macrumors 6502

    Mar 12, 2012
  15. jah6719 thread starter macrumors newbie

    Apr 22, 2013
    Let me clarify... the Promise server had been previousley set up (RAID) and connected to the Mac Server and working fine. The Promise has about 8TB of data on it. While it was working fine it was not connected to our network switch for the last ~2 years. It was only connect via four fibre channel cables to the Mac Server. The Promise showed as a (orange) removable disk of the Mac Server desktop and shared to the network. The Promise disk on the desktop was accidentally ejected. I am only trying to re-connect it so we can share it again in the same manner.

    I understand this isn't the standard setup, but that is how it was set up by others who no longer are around to help. It worked fine how it was set up and I would think it should be not too difficult to reconnect.
  16. chrfr macrumors 604

    Jul 11, 2009
    Yes, and now that it's not working correctly, you need to diagnose the problem. There is no way that machine has had 2 years of uptime, so the volume should have come back on its own if it was working as expected.
    You can't begin to diagnose the problem– and it's clear there is a problem with the RAID– if you're not communicating with the RAID controller.
    Connect it to the network, and then call Promise. Anything else you're doing is guesswork and a waste of time, and puts your data at risk.
  17. pitaya macrumors member

    Jun 17, 2012
    If it's not a really old vtrak it'll be running its own web server where you can access a configuration web page. You can check it out to see if there are any problems with the disks or arrays and so on, and configure various settings. but you'll have to hook it up to either the mac's ethernet port or the network first. You wouldn't remount the raid using this interface, and it doesn't need to be hooked up to the network for normal use. I would guess that it should show up automatically when you reboot. You can go to to download/read the setup guide, but you probably should open a support ticket.

    It actually sounds like that's the optimal setup. Gotta read the docs.
  18. Memphis Mac macrumors newbie

    Apr 29, 2013
    You're in over your head

    Your promise RAID is connected correctly (fibre) and is a managed Share Point within 10.5 server. That is why is shows up on the desktop of the server. The Share Points are created and shared out to users based on their privileges. I know you don't want to hire a consultant but my recommendation is you get someone that knows and understands server and Promise RAIDs. Ultimately you are going to cost yourself more time, money and frustration and you run the risk of losing data. The more you poke at the RAID the more chance you have to mess something up. Recovering data from a RAID is a costly endeavor, it can run upwards of $15-20k depending on how much data and how bad it is. It's easier to pay someone that understands it rather than wasting time.
  19. freejazz-man macrumors regular

    May 12, 2010
    Too bad. I guess it's more cost effective to expect consultants to do the same service for free on macumors

Share This Page