Mac OS X showing incorrect storage space

Discussion in 'MacBook Pro' started by macfreak101, Dec 15, 2014.

  1. macfreak101 macrumors regular

    Joined:
    Nov 6, 2012
    #1
    Hey,

    I am having some sort of storage issue with my mac. When the storage in use is 77gb in actual, finder and disk utility and all are showing it as 99gb. I even tried turning the time machine off and tried this "sudo tmutil disablelocal" in terminal and still there is no change.TimeMachine is also turned off but the something is eating almost 22gb up.

    Here are a few screenshots
    What does this seem like?
     

    Attached Files:

  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hi,

    force Spotlight to re-index should solve the problem.
     
  3. macfreak101 thread starter macrumors regular

    Joined:
    Nov 6, 2012
    #3
    I tried re-indexing it twice with spotlight, didn't make a difference
     
  4. Bending Pixels macrumors 65816

    Joined:
    Jul 22, 2010
    #4
    I think you're worrying about something (again) that isn't worth worrying about.

    Time Machine includes what's known as local snapshots, so this 22gb is most likely that.
     
  5. macfreak101 thread starter macrumors regular

    Joined:
    Nov 6, 2012
    #5
    As I mentioned I don't use time machine and it's turned off. I don't come here and post things because of I have extra time, I only come when there's a genuine problem. It's my hard luck that I'm facing so many of them
     
  6. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #6
    Download and use OmniDiskSweeper. It will provide a sorted list of what's consuming your space.

    Another option which is more comprehensive is to use this terminal command
    sudo du -d 1 -x -c -g /

    I prefer to redirect it to a text file (this puts it in your Documents folder
    sudo du -d 1 -x -c -g / > ~/Documents/du.txt
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    I think you are fine. That app and others like it cannot see all the hidden and system files that use space, so the numbers are always off.

    Run that Terminal command maflynn gave you to see a real shot of what is going on.

    Code:
    sudo /Applications/OmniDiskSweeper.app/Contents/MacOS/OmniDiskSweeper
    Or, you can run this command to launch Omni from Terminal and give it admin rights to see all those files. It still misses some though.

    Here is mine with a regular Omni run.

    [​IMG]

    ...and here it is run as sudo. See the difference.

    [​IMG]
     
  8. Bending Pixels macrumors 65816

    Joined:
    Jul 22, 2010
    #8
    What programs do you have installed on your MBP? Certain programs like Photoshop will create a scratch disk to temporarily write data to/from. That may be what is taking up that mysterious 22gb of space.
     
  9. macfreak101 thread starter macrumors regular

    Joined:
    Nov 6, 2012
    #9
    I'm using omnidisk sweeper only. Thanks that command solved my problem.
    There was something wrong with my disk and it told me to go in recovery mode and repair it , now it seems to be fine. There like a 3-4gb difference but I guess thats normal.
    Thanks a ton :)
     

Share This Page