Mac OS X won't shut down. Whining noise. (Not me.)

Discussion in 'macOS' started by ltldrummerboy, Aug 22, 2008.

  1. ltldrummerboy macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #1
    The past six months my MacBook hasn't been shutting down. Let me explain. It acts like it shuts down; it logs me out, the screen goes black, and by all appearances it's turned off. But there's a quiet high-pitched whine if I put my ear next to the keyboard. If I press the power button to turn it on (I "shut it down" remember) nothing happens. If I hold the power button down for 10 seconds the whine goes away. I then try turning it on and everything starts great except for that on startup it tells me OS X quit unexpectedly and would I like to send an error report. I've tried logging out manually and then shutting down from the login screen but it does the same thing. Any ideas?

    PS- It only does this in OS X and not Windows, leading me to believe that it's a software problem and not hardware.
     
  2. ltldrummerboy thread starter macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #3
    I've done that. It doesn't do anything. I also usually only run iTunes, Firefox, iChat, and Mail.
     
  3. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
  4. ltldrummerboy thread starter macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #5
    I opened Onyx and went to Automation and checked all boxes and ran it and it still did the same thing. Here's the crash log.


    Fri Aug 22 08:56:30 2008
    panic(cpu 0 caller 0x001A8CD4): Kernel trap at 0x80f68214, type 14=page fault, registers:
    CR0: 0x8001003b, CR2: 0x0000054f, CR3: 0x010d1000, CR4: 0x00000660
    EAX: 0x0077b0c2, EBX: 0xffffffff, ECX: 0x0050d444, EDX: 0x000bf43d
    CR2: 0x0000054f, EBP: 0x5ad53c98, ESI: 0x06848000, EDI: 0x80f6a3e8
    EFL: 0x00010286, EIP: 0x80f68214, CS: 0x00000008, DS: 0x00000010
    Error code: 0x00000000

    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x5ad53aa8 : 0x12b0fa (0x4592a4 0x5ad53adc 0x133243 0x0)
    0x5ad53af8 : 0x1a8cd4 (0x46280c 0x80f68214 0xe 0x461fbc)
    0x5ad53bd8 : 0x19ede5 (0x5ad53bf0 0x6d72400 0x5ad53c98 0x80f68214)
    0x5ad53be8 : 0x80f68214 (0xe 0x530048 0x6a70010 0x10)
    0x5ad53c98 : 0x80f6676b (0x80f6a428 0x6848000 0x78a380 0x3eac3a)
    0x5ad53cc8 : 0x80f667ee (0x6848000 0x7966dc 0x6848000 0x944b78)
    0x5ad53ce8 : 0x40e17d (0x735a080 0x0 0x6848000 0x3eb869)
    0x5ad53d18 : 0x40ed72 (0x6848000 0x6d39800 0x0 0x6848000)
    0x5ad53d58 : 0x412e9c (0x6848000 0x6741c40 0x0 0xffffffff)
    0x5ad53da8 : 0x41304f (0x6a22c00 0x7 0x1 0x1c90a74)
    0x5ad53dc8 : 0x5f17b2 (0x6a22c00 0x3 0x1 0x6996000)
    0x5ad53de8 : 0xcbcd79 (0x6a22c00 0x3 0x6996704 0x6996700)
    0x5ad53e28 : 0xcbcf15 (0x6996000 0x60b224 0x1 0x91f360)
    0x5ad53e68 : 0xcb8e0c (0x6996000 0x69f6170 0x5ad53e98 0x6cbb430)
    0x5ad53ea8 : 0xcba9fd (0x6998c00 0x0 0x5ad53ed8 0x5f8d7f)
    0x5ad53ed8 : 0x416430 (0x6998c00 0x0 0x6998c00 0x6998c00)
    Backtrace continues...
    Kernel loadable modules in backtrace (with dependencies):
    com.baltaks.driver.DoubleCommand(1.6.5)@0x80f65000->0x80f6afff
    dependency: com.apple.iokit.IOHIDFamily(1.5.2)@0x75e000
    com.apple.driver.AppleUSBHub(3.1.5)@0xcb7000->0xcc1fff
    dependency: com.apple.iokit.IOUSBFamily(3.1.5)@0x5e4000
    com.apple.iokit.IOUSBFamily(3.1.5)@0x5e4000->0x60bfff

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    9E17

    Kernel version:
    Darwin Kernel Version 9.4.0: Mon Jun 9 19:30:53 PDT 2008; root:xnu-1228.5.20~1/RELEASE_I386
    System model name: MacBook3,1 (Mac-F22788C8)


    Could it be a background app like MainMenu or iStat Menus? DropBox comes to mind.

    Edit: The culprit is in bold above.
     
  5. ltldrummerboy thread starter macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #6
    Just to let you all know, I think I solved the problem. I looked at the crash report and within lies this bit of something:

    "com.baltaks.driver.DoubleCommand"

    Just doing a Google search for this brings up a bunch of crash reports for people with Leopard machines that won't shut down completely. It seems to be an issue with an older version of DoubleCommand.

    Edit: I have now deleted the following items after installing the latest version of DoubleCommand and my computer restarts and shuts down perfectly.

    /Library/StartupItems/DoubleCommand (folder)
    /Library/PreferencePanes/DoubleCommand.prefpane
     
  6. soberbrain macrumors 65816

    soberbrain

    Joined:
    May 9, 2008
    #7
    2000 points for searching and solving your own issue. Well done! :)
     
  7. alipensen macrumors newbie

    Joined:
    May 19, 2009
    #8
    I was trying to sort that out in my head too.
    ltldrummerboy: Thanks for coming back to the thread and sharing the solution. Many people pose these problems then never share the solution with future readers. Kudos to you!
     
  8. maracaiboguest macrumors newbie

    Joined:
    Dec 11, 2010
    #9
    Thanks!

    Thanks to ltldrummerboy I just reinstalled latest version of DoubleCommand and now my Macbook Pro (OSX 10.5.8) shuts down perfectly, restarts from my user name and guest ID as well.

    I did not delete the items mentioned by ltldrummerboy after installing the latest version of DoubleCommand because I could not find them (or didn't know how to find them) on my computer, but it still worked anyway without doing this.

    /Library/StartupItems/DoubleCommand (folder)
    /Library/PreferencePanes/DoubleCommand.prefpane

    this where I got my version of DoubleCommand:
    http://doublecommand.sourceforge.net/

    What a relief, this was a very annoying problem.
     
  9. aehenderson macrumors newbie

    Joined:
    Mar 18, 2011
    #10
    March 18, 2011

    I've tried both installing the newest version of DoubleCommand as well as deleting out the suggested files from library\...\etc and no luck. Any other suggestions? Help!
     

Share This Page