Mac OSX 10.10 Terminal, [Process Completed]

Discussion in 'OS X Yosemite (10.10)' started by devin9086, Nov 1, 2014.

  1. devin9086 macrumors newbie

    Joined:
    Nov 1, 2014
    #1
    Hello all,

    This is my first post.

    I have been getting problems on my Macbook pro 13", Early 2011. Yes, Old I know. My mac is running OSX Yosemite and when I open my terminal to mash in some codes, I get greeted with a "Process Completed" in the Terminal and I can't seem to get rid of that!

    I would greatly appreciate some professional help. But I know that the last resort is to restore my Mac.

    Thanks for y'll answers in advanced! :)
     
  2. Brian Y macrumors 68040

    Joined:
    Oct 21, 2012
    #2
    Upon quitting and reopening terminal you shouldn't get process completed.

    Some things to check in Terminal preferences:

    1. Under general, check sure "shell opens with" is set to Default login shell.
    2. Under profiles -> shell make sure run command is empty and unticked.

    It could be a problem with your user too. In System Preferences, go to Users and Groups, unlock if necessary, right click on your user, and choose advanced. The login shell should be /bin/bash - if it isn't, you can change this, but don't change anything else or you could screw your account up.
     
  3. devin9086, Nov 1, 2014
    Last edited: Nov 1, 2014

    devin9086 thread starter macrumors newbie

    Joined:
    Nov 1, 2014
    #3
    Hey! Thanks for the response!

    Sad to say, Everything is the way it should be. But it still gives the [Process Completed] Command! I did delete the "com.apple.Terminal.plist" too, As suggested by another site! But other than that, Still the same problem!

    And I have just checked, It affects all accounts on the computer.
     
  4. dsemf macrumors regular

    Joined:
    Jul 26, 2014
    #4
    Does the [Process Completed] occur after every command or just the exit command?

    If it is just the exit command and you want the terminal window to close, go to Terminal Preferences, select the Profiles tab, select the profile that you are using, select the Shell sub-tab and change the When the shell exits: drop down. Change it from the default Don't close the window.

    DS
     
  5. devin9086, Nov 2, 2014
    Last edited: Nov 2, 2014

    devin9086 thread starter macrumors newbie

    Joined:
    Nov 1, 2014
    #5
    Hey! Unfortunately, It shows that when I open the Terminal. So, Basically.. I cannot type anything into the terminal. Like I'm locked out of the Terminal.

    Here are some Images of when I open the terminal:

    http://i.imgur.com/kkkxZtQ.png - When Launching - Notice the top of the Terminal.
    http://i.imgur.com/2B19HO3.png - When Terminal has Initialised. No commands can be inputted.
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    Open a new shell (Shell menu, New window, Basic)
    Do you still get the Process Completed?
     
  7. devin9086 thread starter macrumors newbie

    Joined:
    Nov 1, 2014
    #7
    Yes I do. I get it for all the different types of windows too.
     
  8. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    You won't get much change if you try deleting the com.apple.terminal.plist file - as Yosemite keeps those plist files cached, and retains the same settings if you don't restart before deleting the plist.
    So, Launch terminal. Then, close whatever window opens. Check in the Windows menu to make sure that there's no hidden windows still open.

    Quit the Terminal app.
    Now, restart your Mac.
    After that restart, before doing anything else, delete that com.apple.terminal.plist file. (drag to the trash, and be sure to empty the trash, too)
    Now - launch Terminal, which should be back at the defaults.
    If not, try the same sequence, along with restarting again.
     
  9. rrl macrumors 6502

    rrl

    Joined:
    Jul 27, 2009
    #9
    Try renaming your .profile and .bashrc files. There could be something in one or both of those files that is causing the shell to exit.
     
  10. devin9086 thread starter macrumors newbie

    Joined:
    Nov 1, 2014
    #10
    I've tried that, But still.. The same problem.

    ----------

    Could you walk me through it? Sorry, I'm not good in these stuff. :)
     
  11. rrl macrumors 6502

    rrl

    Joined:
    Jul 27, 2009
    #11
    If you go to the Terminal -> Preferences menu, the default looks like this:

    Screen Shot 2014-11-04 at 6.50.43 AM.png

    Make the changes in the red box below and open a new window.

    Screen Shot 2014-11-04 at 6.51.09 AM.png
     
  12. devin9086 thread starter macrumors newbie

    Joined:
    Nov 1, 2014
    #12
    I have done so but still, Same thing. :/

    Screen Shot 2014-11-05 at 5.32.40 pm.png
     
  13. rrl macrumors 6502

    rrl

    Joined:
    Jul 27, 2009
    #13
    Bummer. I thought maybe it couldn't find /bin/bash, but when I change the shell command name I get a different message than you're getting. I'm just grasping here, but there might be something corrupted with your user account, so I would create a new user account with administrative privileges and try again.

    ----------

    Also, maybe it's time for you to poke around the Console utility and look for interesting error messages.
     
  14. jhnv macrumors newbie

    Joined:
    Feb 3, 2015
    #14
  15. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #15
    Could it be from previous session? Try

    Code:
    defaults write com.apple.terminal NSQuitAlwaysKeepsWindows -bool false
     
  16. Block_Monkey macrumors newbie

    Block_Monkey

    Joined:
    May 31, 2016
    #16
    Guys now I am having the same problem, process completed as soon as I log in. I have tried literally every single thing on this page except erasing my computer.

    Made a new user- same problem
    Remove the plist file- same problem
     
  17. PuremaltOne, Sep 23, 2016
    Last edited: Sep 23, 2016

    PuremaltOne macrumors newbie

    Joined:
    Sep 23, 2016
    #17
    Try to use "New command" (right click on the terminal icon or use the menu; File-New Commad) and paste in: rm -i ~/.profile ~/.bash*
     

Share This Page