Mac OSX 10.6 does not install updates

Discussion in 'Mac Basics and Help' started by Beto Braga, Jul 5, 2010.

  1. Beto Braga macrumors newbie

    Joined:
    Jul 4, 2010
    #1
    Hello!

    I've noticed that all of a sudden my MacBook Pro stopped installing updates. Lately, the only one that was installed up to the end was an HP printer update. Updates from Apple or from Microsoft Office will not get to the end of the process. It doesn't matter if I try via Software Update or directly from the Apple site. What happens it that the process goes up to the point I click "install" (after choosing the volume - which is the main HD), then nothing happens - no dialog box, nothing. I can click "install" a hundred times (the button remains available). Then I have to quit the installation process.

    Otherwise, the computer runs fine. I have tried to repair permission, The only weird message I get is that "SUID - cannot repair permission"

    I would appreciate your help.
     
  2. cjbriare macrumors member

    cjbriare

    Joined:
    Nov 8, 2008
    Location:
    Las Vegas, NV
    #2
    Hmm Thats strange.

    Does it do that for ALL installer packages or just the ones you tested?

    Because there could be a chance that you have bad updater packages.

    Maybe try to reset the PRAM?

    (Restart, then hold CMD+OPT+P+R)

    Then try to install them again.


    Or maybe if you have an Anti-virus program or other security app, check to see if it's blocking installations.
     
  3. Beto Braga thread starter macrumors newbie

    Joined:
    Jul 4, 2010
    #3
    Hi, Cjbriare.

    Thank you for the answer. In fact, the only update I was able to run successfully was the printer driver. All Apple and Office updates do not work (as I said, when I hit ïnstall", nothing happens). Not even iTunes.

    When I try to repair permissions, I get the message:

    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.

    Could that have any relation to it?

    Thanks!
     
  4. dashcs macrumors regular

    Joined:
    Oct 2, 2009
    #4
    thats permissions error is normal
    http://support.apple.com/kb/TS1448

    You have any anti virus software maybe blocking the installation?
    If you create a 2nd admin.Does it have the same problem?
     
  5. Beto Braga thread starter macrumors newbie

    Joined:
    Jul 4, 2010
    #5
    Hi, dashcs.

    No, I do not have an antivirus. How do I create a 2nd administrator?

    Thanks!
     
  6. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #6
    System Preferences -> Click lock to make changes, enter your password -> hit the "+" button to make a new account.
     
  7. Beto Braga thread starter macrumors newbie

    Joined:
    Jul 4, 2010
    #7
    Ok, new information: it seems like I've lost my admin access because when I clicked the lock, it showed "authenticating" and then it did not open. Any thoughts?

    Thanks!
     
  8. Beto Braga thread starter macrumors newbie

    Joined:
    Jul 4, 2010
    #8
    Mistery solved!

    Ok. The cause was the US International keyboard layout I had installed. For some reason, it did not allow any updates.

    I hope this may be useful for people with the same problem.

    Bye!
     

Share This Page