Mac OSX Snow Leopard SSH problems

Discussion in 'macOS' started by bitbyte-tw, Oct 17, 2011.

  1. bitbyte-tw, Oct 17, 2011
    Last edited: Oct 17, 2011

    bitbyte-tw macrumors newbie

    Joined:
    Oct 12, 2011
    #1
    hay guys,

    im running on 10.6.8 and im having issues with my ssh. im trying to get it so my hacked HTC can ssh into my laptop and had it working once before but now the ssh won't even load up.

    ive been to sharing and turned it on. then when i go to terminal and check the running processes ( ps aux ) sshd isn't even loaded or any ssh relevant stuff.

    even when i narrow down to "ps aux | grep ssh" nothing shows up other then the grep request.

    it would be nice to know how to get it to work. this is a fresh install of snow leopard with just updates so nothings been touched.

    when i had it working before that was on a previous install. due to some problems i had to fresh install. so any insight would be awesome thanks. also just ask for any information and i'll put up screen shots and stuff within reason :)

    any help would be great thanks.
     

    Attached Files:

  2. willfurnell macrumors member

    willfurnell

    Joined:
    Feb 24, 2011
    #2
    Make sure you have 'Remote Login' turned on in the sharing pane of System Preferences, then you should be able to ssh into your computer.
     
  3. bitbyte-tw thread starter macrumors newbie

    Joined:
    Oct 12, 2011
    #3
    well i did say i do have ssh turned on i.e. the remote login and that it does not show up in the process list.
     
  4. Mattie Num Nums macrumors 68030

    Mattie Num Nums

    Joined:
    Mar 5, 2009
    Location:
    USA
    #4
    Try creating another user, granting admin rights, and testing on that account. If it doesn't work I have some more ideas.
     
  5. animasperdidas macrumors newbie

    Joined:
    Oct 14, 2014
    #5
    sshd

    sshd is actually started by "launchproxy". This is a program that listens on all its configured ports and then launches daemons/program appropriately, but only when needed.

    SSH is configured by default, but perhaps it's been changed? You can find the instructions online somewhere... A good simple test is try "ssh localhost" from terminal, by the way.
     

Share This Page