Mac Pro 1,1 SuperDrive no longer recognised

Discussion in 'Mac Pro' started by mikechalmers, Nov 4, 2011.

  1. mikechalmers macrumors newbie

    Joined:
    Nov 4, 2011
    #1
    Hi Folks,

    I was trying to install a second optical drive in the free slot. I followed the instructions provided by apple and put everything back together. After booting up neither the new drive nor the superdrive (that came with the Mac) were recognised. I checked Disk Utility etc.

    I removed the new drive and tried again, no luck.

    I connected the superdrive (by itself) to the end connectors of both cables, no luck.

    I don't know if I've damaged something (I don't think so) or if I'm missing something or what?

    Any help would be greatly appreciated!

    Mike
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    Only Two Things

    Come to mind here. First you have bent the pins on the board, (I hope not) or you are not seating the power connection properly?
     
  3. mikechalmers thread starter macrumors newbie

    Joined:
    Nov 4, 2011
    #3
    Thanks for your response.

    Which pins do you mean?

    I tried a few times so I think the power connection is fine, I've plugged in a few drives in my time.
     
  4. mikechalmers thread starter macrumors newbie

    Joined:
    Nov 4, 2011
    #4
    Just looked back over the guide, found something weird about reattaching:


    Attach the power and ribbon cables to the back of the drive(s).
    Important: Attach the connector on the end of the optical drive ribbon cable and the
    connector in the middle of the optical drive power cable to the top drive. If there is a second
    drive in the carrier, attach the remaining optical drive ribbon and power connectors to the
    bottom drive​

    I'm at work right now, but I may not have tried top of ribbon cable and middle of power cable, will check when I get in..
     
  5. mikechalmers thread starter macrumors newbie

    Joined:
    Nov 4, 2011
    #5
    SO YEAH

    The cables were connected properly, but I think I've got the real problem: the ribbon cable has a very small incision.. No idea how it happened.

    I can't even see where the ribbon cable goes after leaving the optical drives bay.. Am I out of luck here or any ideas?

    Thanks

    MC
     
  6. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #6
    Check jumper settings of drives. If both are set to master/slave they won't work. One must be master and second one slave (or set them to cable select).
    IDE cable goes to connector located under front fan assembly.

    [​IMG]
     
  7. nambuccaheadsau macrumors 6502a

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #7
    Also be aware the power cable connectors (molex) can be as tight as all get out. You may need a pair of needle nose pliers to get them apart and together again.
     

Share This Page