Mac Pro 2009 Processor Upgrade Issues - W3690

Discussion in 'Mac Pro' started by raeshao, Feb 26, 2014.

  1. raeshao macrumors newbie

    Joined:
    Oct 4, 2010
    #1
    So I've been following the threads on this subject with great interest after acquiring an early 2009 Mac Pro. The 2013 Pros look great, but they're pricey. I thought this upgraded machine would suit me well for a while. I hunted down the best deals on a Radeon 7970, 32GB of ram, airport card, and finally a W3690. Flashed the boot rom and had everything working great before the processor arrived. As I had upgraded the processors on my 1,1 Mac Pro previously, I thought this would be a plug and play operation. Unfortunately it hasn't been.

    The first time I tried powering it up with the W3690 (purchased used, pulled from a Dell), it hung at a grey screen after the boot chime. I could've gone about things a little better, as I should've brought the machine back to factory specs as closely as possible, testing the processor, then adding the upgraded bits one at a time. I even had a Newer Technology eSATA card in one of the slots. Knowing that I had to start swapping parts, I removed that card and then booted again, this time it fired right up and identified the new graphics card, the airport card, and all of the ram. Feeling more confident, I tried adding the eSATA card again, in a different slot, and haven't been able to boot fully ever since.

    Thinking it might be power issues, I tried bringing things back to stock - putting the GT120 back in, inserting 2x2GB of ram, hooking up an original keyboard, and not much else. The airport card is still installed. I repaired the disk and the permissions from another machine (from where this Mountain Lion install is cloned from), zapped the pram, reset the smc, uninstalled and reinstalled the processor, ran it with no system disks installed, tried booting from multiple install DVDs and a Mountain Lion USB, downloaded and ran Apple Hardware Test for a 5,1 machine, and possibly a couple other things I'm forgetting.

    The machine passed AHT the first time I ran the short test, then froze eight minutes into the long test (before I swapped the ram from 2x8GB to 2X2GB). After the swap, it passed the long test as well as a couple subsequent short tests. That said, I'm unable to boot from anything I try including a USB created with recovery assistant. It always hangs at the same place, just after these lines (screenshot included).


    MAC Framework successfully initialized
    using 16384 buffer headers and 10240 cluster IO buffer headers



    Once after putting the GT120 back in did it mention a kernel panic after those lines. It hasn't since. I'm trying everything I can to get this to work so I don't have to go through the process of trying to get a refund / find another processor. Thanks for your help and ideas.



    __
     

    Attached Files:

  2. xcodeSyn macrumors 6502a

    Joined:
    Nov 25, 2012
    #2
    Based on your description, it seems you got an unstable CPU at best, which is worse than a dead one because it gives you false hope like what you did until it is too late to return for refund. If I were you, I'd put back the original CPU and make sure everything else still works as before. If the CPU doesn't function properly with all your components, then it doesn't work to its specification, and there are others that would. Partially works doesn't mean anything, that's my 2 cents.
     
  3. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #3
    I hate to ask the obvious, but did you try plopping the old CPU back in. And if so, did the problems go away?
     

Share This Page