Mac Pro 2009 Yosemite: freezes, restarts, kernel panic, no boot...wait a day or two, and it's fine?

Discussion in 'Mac Basics and Help' started by Jolio, Aug 29, 2015.

  1. Jolio, Aug 29, 2015
    Last edited: Oct 2, 2015

    Jolio macrumors newbie

    Joined:
    Oct 21, 2013
    #1
    I bought a used 2009 Mac Pro a few weeks ago. I performed a clean installation of Yosemite and began using it as my primary machine. It seemed to work perfectly, for about a week, before I ran into this issue:

    As I was browsing the internet, the cursor froze, I could get no response from the keyboard, and then after about 30 seconds, the machine powered off and restarted. The startup chime sounded garbled, and I was greeted with this:
    [​IMG]
    and, upon booting into OSX, this:
    [​IMG]
    (This second one, perhaps not exactly this message, I'm going from memory here)

    I chose "Open", and everything came back up, including the browser, which I used immediately to begin researching the problem. One or two minutes later, as I was reading this Apple support page, the problem recurred. This time, however, I did not receive the same "Your computer restarted..." message; it went straight to the "progress bar" OS loading screen, but the bar only moved slightly and then stopped for several minutes. I hard restarted the machine, and now could get no display at all. I powered it off and unplugged it, thinking I would troubleshoot it the following day...which I set about to do, but now could not reproduce the problem. It started immediately up without issue.

    I ran ASD on it and everything* passed. Hoping it was a random, one-time thing, I continued to use the computer...for about a week, before it happened again. Same situation, for the most part. Slight differences (no "Your computer restarted..." message, no boot into OSX at all immediately after the first restart, no panic log that I could find), but essentially the same: it froze, restarted, hung on the loading bar screen, I hard restarted, it would not display at all, I let it sit for a few days, and it booted up again, no problem.

    I'm at a loss; please help me figure out what's going on here. Following is the kernel panic log from the first event, I can't seem to find any from the subsequent events:

    *everything except for something to do with the Ethernet MAC address, which I haven't quite figured out; I suspect may be a false positive, and don't believe is relevant here. If you think it is, I'll provide the details.
     
  2. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #2
  3. Jolio thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #3
    I'm fairly sure (not 100% positive) that both times, once I was unable to get any display, I did in fact unplug it for at least fifteen seconds before trying once again to restart the machine, and this didn't have any effect. I will be sure to do this, as well as the Shift-Control-Option method, if the problem recurs, but I don't think the SMC is the problem here.

    Any other ideas? Can anyone give insight into my panic report?
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    Maybe you could download the free software EtreCheck. It will scan and report on all the services, programs, etc and print out a text fike show all this files and the ones that not compatible so you can Manually Delete this file. Just reboot if you delete sevices!
     
  5. Jolio thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #5
    It's happening again.

    Froze, automatically restarted after about 30 seconds.

    Garbled startup chime, displays blank grey screen, no change after 5 minutes.

    I hard powered it off, unplugged it for 60 seconds (to reset SMC), and plug it back in.

    It automatically powers on, garbled startup chime, displays grey screen with Apple icon and loading bar...but the loading bar doesn't fill at all, no change after 5 minutes.

    I hard power it off again, attempt to simultaneously press Shift+Control+Option+Power. Not sure if I hit it successfully, but it does power on.

    This time, no startup chime at all, no display at all. Hard power off and try the key combination again. Same thing: no startup chime at all, no display at all.

    Hard power off and unplug for 60 seconds. Plug it back in, automatically powers on, but still: no startup chime at all, no display at all.

    Unplug, guess I'll wait. Chances are it'll power up with no problem tomorrow.
     
  6. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #6
    What happens when you try to start your computer with your hard drive unplugged(Is the chime clean sounding rather garbled? Does it stop at a No Boot Disk or Recovery Screen etc..)? Do you have another HDD hanging around? Are the HDD connections snug? Are all unnecessary peripherals(to boot) unplugged from the machine? Have you done a PRAM(NVRAM) reset?
     
  7. Jolio thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #7
    I'll try that next time, since it's back up and running today.

    Yes. What are you thinking? Reinstall on that, see if the problem recurs? I will if I have to, I'm hoping it won't come to that.

    The HDD seems to be properly in place, but I just now removed it, cleaned the contacts with compressed air and reseated it just in case. Nothing connected to the outside of the machine except the display, keyboard, and mouse; the inside is stock, except for the HDD.

    Just now. I can't do one when the problem occurs, if I can't get a startup chime.
     
  8. CoastalOR, Sep 1, 2015
    Last edited: Sep 2, 2015

    CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #8
    Do it anyway. I had a situation where I was not getting any startup chime. Per Apples Support direction they said do the NVRAM reset (Command-Option-P-R) and the chime returned. I held the keys down and waited until I heard the chime 3 times.

    Just in case you have not seen these Apple pages.
    Startup key combinations:
    https://support.apple.com/en-us/HT201255
    Apple NVRAM info:
    https://support.apple.com/en-us/HT204063
     
  9. OldGuyTom macrumors regular

    Joined:
    Sep 6, 2013
    Location:
    US
    #9
    If possible I'd take the HD out of the interior and put it into an external enclosure and boot from that to see if the problem goes away. The 2009 units are known to have SATA cables that like to fail erratically. If they did so during a kernel read or write event it might produce what you're describing. That type of problem is erratic in nature.

    I had an external drive with a faulty cable some time ago. I got a copy of Scannerz to test it because it can check for a lot of hardware stuff. The drive being tested was new and I expected Scannerz to find bad sectors and then I could send WD the report and say "See…the new HD is bad" but instead it found cable problems. I replaced the cable and the problem went away.

    If the problems continued with the drive removed from then it's either the logic board or a bug somewhere in the software or maybe something that's loaded at boot time. Have you tried running it in Safe Mode? Do you have the latest version of Yosemite? It was hardly bug free, but they got a lot of them fixed. You might also want to reseat the RAM just as a precaution.

    Good Luck.
     
  10. Jolio thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #10
    Problem occurred again last night. It's getting more frequent.

    Froze, automatically restarted, no display and no chime. Powered off and reseated the RAM and the processor board. Boots and chimes normally, but after a few minutes, the display started flashing (link to video). This is a new thing.

    I unplugged the mini-DP cable from the back and plugged it back in, but the display would not come back up at all. Thinking I should have tried to see, before unplugging the display cable, if the system was responsive at all, or frozen, I tried the sleep key combination, Command-Option-Power, but nothing happened.

    I hard power it off and back on, garbled chime and blank grey screen.

    Reseat video card, power on, normal chime, normal grey loading screen with apple logo and loading bar...bar moves slightly, stops, and then this: IMG_0298.JPG

    Hard power off, attempt PRAM reset...garbled startup sound, blank grey screen, no automatic restart.

    Hard power off, replaced video card with an old Radeon HD 2600 XT I had from a 2008 MP, but now there's no chime and no display.

    Restarted three times, each with a different single RAM stick, but each time, no chime and no display.

    Today, of course, it starts up fine with the 2600 XT, and runs fine (for now).
     
  11. Jolio thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #11
    I'm going off my notes from last night...I thought I tried it with the HDD removed, and it made no difference, but...I'm not sure. I will definitely do it the next time.
     
  12. Plutonius macrumors 603

    Plutonius

    Joined:
    Feb 22, 2003
    Location:
    New Hampshire
    #12
    Did someone upgrade the processors or does it have the original processors ?
     
  13. Jolio thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #13
    There's only one processor, 2.66GHz, the lowest-end offering in this series; I have no reason to believe it isn't the original processor. Don't know for sure, though. Why do you ask?
     
  14. Plutonius macrumors 603

    Plutonius

    Joined:
    Feb 22, 2003
    Location:
    New Hampshire
    #14
    Reading through the hardware forum, you sometimes see issues with the 4,1 Mac Pro when someone botches a processor upgrade.

    Seeing as you have the original processor, I'm not sure what your problem is. Could it be your power supply ?
     
  15. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #15
    If I had to guess I'd say it's an intermittent short somewhere or a supply problem. The way the video is blanking out indicates there's intermittent power loss to the video card, causing it to drop it's output intermittently. The only thing I could suggest is to remove as many items plugged into the unit as possible, re-seat the remaining items, restart the system, see if it works. If it works, start plugging other stuff in one by one. This would include all I/O connections too. If it doesn't it's most likely the supply or the board. I wouldn't rule out the other possibilities others have suggested about it being a botched processor upgrade, but if it was that I'd think it would have been doing this all the time. Almost anything plugged into the unit including the video card could be failing intermittently.
     
  16. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #16
  17. Jolio thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #17
    No change with the HDD removed. No change with different RAM configurations.

    Why does this problem only happen after several hours of use?

    Why does it clear up after 12-24 hours of disuse?
     
  18. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #18
    I would personally suspect it's heat related, which could be the supply, the CPU cooling, or the system cooling, or a component that's starting to fail as it heats up.

    On at least some of the older BSD operating systems (OS X is a variant) if the CPU temperature got too hot the OS would throttle the CPU down to lower use, causing the system to bottleneck, but not crash. This would be recorded in the log files. Unfortunately, I've never seen any such logging messages showing up in OS X, so apparently for some reason they took them out. IMHO the most likely cause would be one of the output stages of the supply because the logic board has sensors that should shut the thing down or (I'd think) at least warn you and/or log the event. No such monitoring is on the power supply to the best of my knowledge, especially if the problem is limited to only one of the several output lines.

    You might want to look at the log files, especially system.log (/var/log/system.log) and see if right before the crashes there were any messages generated about temperature or some component being out of whack. It might tell you something, but if it's from the power supply, likely nothing will show up.

    UPDATE:
    I just looked at the white screen photo in detail. The line in the backtrace is referring to the CPU power management, FWIW, so something may be logged if you're lucky.
     
  19. Jolio, Sep 6, 2015
    Last edited: Sep 7, 2015

    Jolio thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #19
    I've got little doubt it's heat related. Some component is failing once it comes up to a certain temperature, and resuming normal operation once fully cooled.

    I don't believe it's one of the major components overheating, either. I had Hardware Monitor running during the last crash, and the final temperature readings are:

    I also have a history temperature as well as fan speed, voltage, current, and power readings, if they would be helpful. I did notice a large dip in power, temperature, and current readings about ten minutes before the crash; I'm not sure if this means anything, it may just have been due to reduced demand. The voltages never fluctuated.

    I had a look at the system.log files; I've got six crashes on file now. I'm no expert at reading these logs, and while I do see some errors and warnings, there's nothing consistent or that seems related to heat or power. What I did notice that seemed a bit odd is that immediately after each crash, the time resets to Dec 31 19:00:10. Does this mean anything to you?

    I really wish I had access to a known-good PSU and CPU/RAM/tray.

    Following are excerpts from each log, including the time of the crash and a few lines prior:

     
  20. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #20

    Voltage levels shouldn't be changing, or at least not much. The purpose of the regulator (supply) is to ensure that the voltage levels are stable as the current load changes. If something dropped from say 12V to 11.5V, it's probably not a big deal, but if it's something like going from 12V to 2V, that's entirely unacceptable and to me points at a malfunction. Possibly that's the way the supply on that works but I've never heard of such a thing.

    I would do a web search on power supply problems with those units, particularly looking out for capacitor problems. For reference, you might want to look at this article:

    https://en.wikipedia.org/wiki/Capacitor_plague

    Although theoretically all those caps were effectively gone by 2007, I had an LCD display that I got in 2009 that did have some of those caps in them. The top of an electrolytic capacitor should be perfectly flat but if it's bloated upward like it is in some of the photos they show, it's bad.

    FWIW on my monitor it would periodically, once in a while, fail to start until I pressed the button a few times. Then it got to the point when it would just blank out after hours of use. Finally it got to the point it wouldn't even turn on at all. I was going to replace the monitor but heard about the problem because it was somewhat rampant, opened the the thing up and sure enough, bloated caps (3 of them). I replaced them, fired the unit up, and it's been working fine ever since.

    Unfortunately, you're looking at a lot of possibilities and you're really down to the point of isolating which component it is and then finding what's wrong with it once the main component is identified. Checking the caps can at least be done visually.

    Good luck.
     
  21. Jolio thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #21
    There, fixed that, sorry.

    I'll take a look at the logic board caps next time I've got the machine off, and the PSU caps if I can get to them without breaking a seal.

    I ran a stress test on it yesterday, with the "yes" command on all cores, for nearly an hour; no freeze and shutdown. If it is heat-related, it must be one specific component...
     
  22. Jolio thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #22
    Well, I decided to just tear it apart and have a look. I didn't see any bulging caps in the PSU, but I didn't take it apart. I just looked in from the outside, but the grating is so large I can see almost everything inside.

    I took the motherboard (technically, the 'backplane board') out, and I see no bulging caps, but there are a few things I'm concerned about: white residue, marked caps, oily residue, and...something, see the pictures.

    There's white residue in three places on the back of the backplane board:
    One near the front...
    white front.JPG

    One near the PCIe x4 slots at the rear...
    white back.JPG

    And one large spot around the entire rear port area:
    white back ports.JPG

    The first two spots are centered around capacitors on the front of the board. These caps, and only these three, have been marked with blue marker (why?); this is the one near the front:
    caps.JPG

    The third, larger white spot around the rear ports contains no caps that I can see, unless they're inside the port housings.

    There's also some oily residue on many of the contacts on the back of the backplane board, including but not limited to: some, but not all, PCIe slot pins (not pictured); PCIe booster pins (pictured); front-panel-board-to-backplane-board-connector pins (pictured); processor cage fans (front pictured); speaker (pictured).
    oily fpconn.JPG

    There's also some oily residue on the processor tray, coming from under the heatsink near the thermal pad, by the connector to the backplane board. You can see where I smudged it:
    oily processor.JPG

    And finally, there is some sort of "blistering" or "bubbling" on one of the types of components. On the backside of the backplane board, near where the power supply connector plugs in, there are eight components labelled "R001", and each shows these features:

    blistering.JPG

    I'm hoping the oily residue is nothing to be worried about, perhaps solder flux, but I'm a little more worried by the white residue. It seems to take the shape of EM flux lines. I don't know what to think about the blistering components.
     
  23. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
  24. BradHatter, Sep 8, 2015
    Last edited: Sep 8, 2015

    BradHatter macrumors regular

    Joined:
    Oct 7, 2014
    #24
    Large caps, the type that go bad, will typically be found in the supply. Few if any of them will be on the logic board. If the supply faults while in use it's unlikely any monitoring software will catch it because the fault will reset the logic board and in doing so terminate that program. The problem is probably going to be heat or a capacitor intermittently zapping it's voltage levels on it's slow way to death. I'd try to find one of the service manuals for that thing on eBay (or wherever) because they would have a lot more detailed troubleshooting steps than you could possibly get from a message board like this.

    Another thing you might want to try might be a free fan control program just to see if you could set the default fan speeds a little higher. Some of them are free. I'm not suggesting that as a solution but if the base fan speeds are upped a little and the problem goes away then you'll know it's heat related. Read the cautions about them as well.

    Regarding the logic board stuff, I doubt that's anything but leftovers from board assembly.
     
  25. Plutonius macrumors 603

    Plutonius

    Joined:
    Feb 22, 2003
    Location:
    New Hampshire

Share This Page