Mac Pro 2010 5,1 High sierra Screen black even at boot

Discussion in 'Mac Pro' started by ntemples1, Oct 4, 2017.

  1. ntemples1 macrumors newbie

    Joined:
    Jul 11, 2013
    #1
    Hi all I have a real Mac Pro 2010 5,1 (not flashed) I also have a flashed gtx 680 which worked perfectly in sierra, but after the upgrade the screen doesn't turn back on after the machine sleeps. I've tried everything to get it to come back including moving the pci express slot, checking connections.

    It did come back one a couple of times whilst plugging in different cables but when it sleeps again it doesn't come back, I think the machine has booted up through and pressing eject does open the dvd drive.

    Is this a hardware problem? I saw that high sierra wanted to do a firmware update before install, would this affect it? I don't have another graphics card on hand and will have to buy a mac 5770 to test.

    Any advice would be appreciated, thanks.
     
  2. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Most likely High Sierra’s sleeping function is broken. Nothing to do with the firmware.
     
  3. mattspace macrumors 6502a

    mattspace

    Joined:
    Jun 5, 2013
    Location:
    Australia
    #3
    if you've got another machine, enable remote login on the 5,1 and see if you can ssh in when it's showing the symptoms. running top you might find something like the loginwindow / windowserver process has hung etc.
     
  4. ntemples1 thread starter macrumors newbie

    Joined:
    Jul 11, 2013
    #4
    many thanks for the replies, I don't have another machine to remote login into unfortunately, also as this affects the machine at boot how can it be software related? shouldn't the apple logo show up at the very least? I have ordered a replacement genuine apple 5870 to try as I am desperate to get it working again for work.
     
  5. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #5
    My understanding is that your original post was talking about "wake from sleep", but not "boot".
     
  6. ntemples1 thread starter macrumors newbie

    Joined:
    Jul 11, 2013
    #6
    Sorry badly worded on my part, the problem started when the computer was on normally then went to sleep but upon waking it with the keyboard, the screen would turn on. Then I had to completely turn the computer off and reboot (by holding in the power button) but the screen still doesn't come back on, tried resetting pram and smc ect but still not working.
     
  7. MSastre macrumors 6502

    MSastre

    Joined:
    Aug 18, 2014
    #7
    Do you have a cloned drive with Sierra or El Capitan to use for boot? Easiest way to get you back up and running plus answer questions if the trouble is High Sierra
     
  8. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #8
    I see, in this case. It's much more point to hardware (but still not firmware).

    However, it could be GPU, PSU, Logic board, CPU tray, RAM..... It could be even just the battery on the logic board need to be replaced.

    So, you mean, just no screen, but the cMP actually able to boot to desktop? If yes, then you are right, almost narrow down to GPU, cable, and monitor.
     
  9. marioliv66@ macrumors newbie

    Joined:
    Oct 2, 2017
    Location:
    France
    #9
    Hello, with which cable is your screen connected? DVI or Display port? I had several worries with cables Display port in standby outputs (MacPro with Nvidia and sierra) and I almost failed to be able to restart the Mac. I ended up abandoning the Display port cables for a DVI which is no longer a problem.
     
  10. ntemples1 thread starter macrumors newbie

    Joined:
    Jul 11, 2013
    #10
    I have both DVI and Displayport, neither worked.

    UPDATE:

    tried it this morning and it booted up and the screen came on, I copied the crash report error here:

    Anonymous UUID: 92A6A830-A82B-8C28-4AC5-9F58BE0F7B01

    Wed Oct 4 09:43:19 2017

    *** Panic Report ***
    panic(cpu 8 caller 0xffffff8015abadfd): "a freed zone element has been modified in zone kalloc.16: expected 0xe4988e0afe0854d4 but found 0xdeadbeef00000001, bits changed 0x3a3530e5fe0854d5, at offset 0 of 16 in element 0xffffff8042d90440, cookies 0x3f00118bd08232d6 0x535216ef027d8ed"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-4570.1.46/osfmk/kern/zalloc.c:1120
    Backtrace (CPU 8), Frame : Return Address
    0xffffff82dc9c3780 : 0xffffff8015a6d366
    0xffffff82dc9c37c0 : 0xffffff8015b98494
    0xffffff82dc9c3800 : 0xffffff8015b8a429
    0xffffff82dc9c3880 : 0xffffff8015a1f190
    0xffffff82dc9c38a0 : 0xffffff8015a6cd8c
    0xffffff82dc9c39d0 : 0xffffff8015a6cafc
    0xffffff82dc9c3a30 : 0xffffff8015abadfd
    0xffffff82dc9c3a90 : 0xffffff8015aba6d0
    0xffffff82dc9c3ae0 : 0xffffff8015ab9113
    0xffffff82dc9c3c10 : 0xffffff8015a789f4
    0xffffff82dc9c3c50 : 0xffffff801603f98b
    0xffffff82dc9c3c90 : 0xffffff8016041f37
    0xffffff82dc9c3cc0 : 0xffffff80160701c2
    0xffffff82dc9c3ce0 : 0xffffff80160703a0
    0xffffff82dc9c3d20 : 0xffffff7f96995c0f
    0xffffff82dc9c3dc0 : 0xffffff7f96995576
    0xffffff82dc9c3e20 : 0xffffff7f96994fd7
    0xffffff82dc9c3e40 : 0xffffff801607e18d
    0xffffff82dc9c3e80 : 0xffffff801607ded1
    0xffffff82dc9c3f00 : 0xffffff801607d3f7
    0xffffff82dc9c3f50 : 0xffffff801607f006
    0xffffff82dc9c3fa0 : 0xffffff8015a1c4f7
    Kernel Extensions in backtrace:
    com.apple.iokit.IOStorageFamily(2.1)[0E8BC828-5A1E-3308-ADAB-1F4373F9402F]@0xffffff7f9698a000->0xffffff7f969b0fff

    BSD process name corresponding to current thread: kernel_task
    Boot args: rp=file:///Backups.backupdb/.RecoverySets/1/com.apple.recovery.boot/BaseSystem.dmg

    Mac OS version:
    Not yet set

    Kernel version:
    Darwin Kernel Version 17.0.0: Thu Aug 24 21:48:19 PDT 2017; root:xnu-4570.1.46~2/RELEASE_X86_64
    Kernel UUID: B84FDEFC-9081-35CE-8C51-25A9583AACDE
    Kernel slide: 0x0000000015800000
    Kernel text base: 0xffffff8015a00000
    __HIB text base: 0xffffff8015900000
    System model name: MacPro5,1 (Mac-F221BEC8)

    System uptime in nanoseconds: 2195016653
    last loaded kext at 2187701326: com.apple.driver.AppleXsanScheme 3 (addr 0xffffff7f98cdf000, size 40960)
    loaded kexts:
    com.apple.driver.AppleFileSystemDriver 3.0.1
    com.apple.driver.AppleFWOHCI 5.5.8
    com.apple.filesystems.hfs.kext 407.1.3
    com.apple.driver.Intel82574LEthernet 2.7.2
    com.apple.BootCache 40
    com.apple.driver.AirPort.Brcm4331 800.20.26
    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0
    com.apple.driver.AppleAHCIPort 329
    com.apple.driver.AppleRTC 2.0
    com.apple.driver.AppleHPET 1.8
    com.apple.driver.AppleACPIButtons 6.1
    com.apple.driver.AppleSMBIOS 2.1
    com.apple.driver.AppleACPIEC 6.1
    com.apple.driver.AppleAPIC 1.7
    com.apple.driver.AppleIntelCPUPowerManagementClient 220.0.0
    com.apple.nke.applicationfirewall 183
    com.apple.security.TMSafetyNet 8
    com.apple.security.quarantine 3
    com.apple.driver.AppleIntelCPUPowerManagement 220.0.0
    com.apple.IOBufferCopyEngineTest 1
    com.apple.driver.AppleXsanScheme 3
    com.apple.iokit.IOAHCIBlockStorage 301.1.2
    com.apple.iokit.IOAHCISerialATAPI 267
    com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 6.0.0f7
    com.apple.iokit.IOBluetoothHostControllerUSBTransport 6.0.0f7
    com.apple.iokit.IOBluetoothHostControllerTransport 6.0.0f7
    com.apple.driver.usb.AppleUSBHub 1.2
    com.apple.iokit.IOFireWireFamily 4.6.8
    com.apple.iokit.IO80211Family 1200.12.2
    com.apple.driver.corecapture 1.0.4
    com.apple.driver.AppleUSBMergeNub 900.4.1
    com.apple.filesystems.hfs.encodings.kext 1
    com.apple.iokit.IOAHCIFamily 288
    com.apple.driver.usb.AppleUSBEHCIPCI 1.2
    com.apple.driver.usb.AppleUSBUHCIPCI 1.2
    com.apple.driver.usb.AppleUSBUHCI 1.2
    com.apple.driver.usb.AppleUSBEHCI 1.2
    com.apple.driver.usb.AppleUSBHostPacketFilter 1.0
    com.apple.iokit.IOUSBFamily 900.4.1
    com.apple.driver.AppleUSBHostMergeProperties 1.2
    com.apple.driver.AppleEFINVRAM 2.1
    com.apple.driver.AppleEFIRuntime 2.1
    com.apple.iokit.IOHIDFamily 2.0.0
    com.apple.iokit.IOSMBusFamily 1.1
    com.apple.security.sandbox 300.0
    com.apple.kext.AppleMatch 1.0.0d1
    com.apple.iokit.IOBufferCopyEngineFamily 1
    com.apple.driver.AppleKeyStore 2
    com.apple.driver.AppleUSBTDM 439
    com.apple.driver.AppleMobileFileIntegrity 1.0.5
    com.apple.iokit.IOUSBMassStorageDriver 140
    com.apple.iokit.IOSCSIBlockCommandsDevice 404
    com.apple.iokit.IOSCSIArchitectureModelFamily 404
    com.apple.driver.AppleCredentialManager 1.0
    com.apple.driver.KernelRelayHost 1
    com.apple.driver.AppleSEPManager 1.0.1
    com.apple.driver.IOSlaveProcessor 1
    com.apple.iokit.IOTimeSyncFamily 600.15
    com.apple.iokit.IONetworkingFamily 3.3
    com.apple.driver.DiskImages 480.1.2
    com.apple.iokit.IOStorageFamily 2.1
    com.apple.iokit.IOBluetoothFamily 6.0.0f7
    com.apple.iokit.IOUSBHostFamily 1.2
    com.apple.driver.usb.AppleUSBCommon 1.0
    com.apple.driver.AppleBusPowerController 1.0
    com.apple.iokit.IOReportFamily 31
    com.apple.driver.AppleFDEKeyStore 28.30
    com.apple.driver.AppleACPIPlatform 6.1
    com.apple.driver.AppleSMCRTC 1.0
    com.apple.driver.AppleSMC 3.1.9
    com.apple.iokit.IOPCIFamily 2.9
    com.apple.iokit.IOACPIFamily 1.4
    com.apple.kec.Libm 1
    com.apple.kec.pthread 1
    com.apple.kec.corecrypto 1.0

    EOF
    Model: MacPro5,1, BootROM MP51.0084.B00, 6 processors, 6-Core Intel Xeon, 3.46 GHz, 24 GB, SMC 1.39f11
    Graphics: NVIDIA GeForce GTX 680, NVIDIA GeForce GTX 680, PCIe, 2 GB
    Memory Module: DIMM 1, 8 GB, DDR3 ECC, 1333 MHz, 0x0198, 0x393936353531362D3030312E4230304C4620
    Memory Module: DIMM 2, 8 GB, DDR3 ECC, 1333 MHz, 0x0198, 0x393936353434372D3036332E4130304C4620
    Memory Module: DIMM 3, 8 GB, DDR3 ECC, 1333 MHz, 0x0198, 0x393936353531362D3033362E4130304C4620
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8E), Broadcom BCM43xx 1.0 (5.106.98.100.26)
    Bluetooth: Version 6.0.0f7, 3 services, 27 devices, 1 incoming serial ports
    Network Service: Ethernet 1, Ethernet, en0
    Network Service: Wi-Fi, AirPort, en2
    PCI Card: NVIDIA GeForce GTX 680, Display Controller, Slot-1
    PCI Card: NVIDIA GeForce GTX 680, NVDA,Parent, Slot-1
    PCI Card: pci144d,a801, AHCI Controller, Slot-4
    Serial ATA Device: SAMSUNG MZHPV256HDGL-00000, 256.06 GB
    Serial ATA Device: HL-DT-ST DVD-RW GH61N
    Serial ATA Device: WDC WD40EFRX-68N32N0, 4 TB
    Serial ATA Device: Hitachi HDS5C4040ALE630, 4 TB
    Serial ATA Device: WDC WD40EFRX-68WT0N0, 4 TB
    Serial ATA Device: WDC WD40EFRX-68WT0N0, 4 TB
    USB Device: USB Bus
    USB Device: USB Bus
    USB Device: BRCM2046 Hub
    USB Device: Bluetooth USB Host Controller
    USB Device: USB Bus
    USB Device: USB Bus
    USB Device: USB Bus
    USB Device: USB Bus
    USB Device: USB 2.0 Bus
    USB Device: USB 2.0 Bus
    FireWire Device: built-in_hub, Up to 800 Mb/sec
    Thunderbolt Bus:
     
  11. ntemples1 thread starter macrumors newbie

    Joined:
    Jul 11, 2013
    #11
    Just an update to this, I have replaced the GPU with an actual apple 5870 and it has stopped the crashing!!
     

Share This Page