Mac Pro 3,1: GTX 570 HD, can't get dual display with web driver

Discussion in 'Mac Pro' started by weezerr, Aug 19, 2015.

  1. weezerr macrumors regular

    Joined:
    Nov 7, 2006
    #1
    Hi All,

    I have a Mac Pro 3,1 with a GTX 570 HD stock PC card. With the default OS X driver, both dual DVI ports as well as the display port work just fine. When I switch to the latest web driver, I only can get one monitor to work. I read somewhere that if I use the display port, that will work, so I got an active display port to DVI adapter. Again, works great with the default OS X driver, but the web driver only shows one monitor. I have never been able to get the web drivers to work.

    What am I doing wrong?

    Thanks!
     
  2. ActionableMango macrumors G3

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    I can't find the thread now, but it's a known problem that the web drivers have a bug with multiple monitors on certain models. I didn't think the 570 was one of them though. I'd ask in the big Nvidia FAQ thread because people in the know monitor that thread pretty well.
     
  3. nigelbb macrumors 65816

    Joined:
    Dec 22, 2012
    #3
    This has been a known problem with the Nvudia web drivers & GTX570 for a long time. I have several times reported it on this forum & even started a thread about the issue (on my iPhone ATM so can't find link). The good news is that it appears to be fixed in Yosemite with the latest Nvidia drivers which I also posted about a few days ago.
     
  4. weezerr thread starter macrumors regular

    Joined:
    Nov 7, 2006
    #4
    Cool thanks for the update. I skipped Yosemite and am still on 10.9.5 but will upgrade to El Capitan likely once it comes out of beta. Glad to see it got fixed!
     
  5. weezerr thread starter macrumors regular

    Joined:
    Nov 7, 2006
    #5
    FYI El Capitan with latest beta web drivers works great, both monitors alive and well.
     
  6. nigelbb macrumors 65816

    Joined:
    Dec 22, 2012
    #6
    Thanks for confirming this. I shall be upgrading my wife's Mac Pro to El Capitan in a couple of weeks so it's good to know that the web drivers continue to work with the GTX570.
     

Share This Page