Mac Pro 3,1: GTX 570 HD, can't get dual display with web driver

weezerr

macrumors regular
Original poster
Nov 7, 2006
189
91
Hi All,

I have a Mac Pro 3,1 with a GTX 570 HD stock PC card. With the default OS X driver, both dual DVI ports as well as the display port work just fine. When I switch to the latest web driver, I only can get one monitor to work. I read somewhere that if I use the display port, that will work, so I got an active display port to DVI adapter. Again, works great with the default OS X driver, but the web driver only shows one monitor. I have never been able to get the web drivers to work.

What am I doing wrong?

Thanks!
 

ActionableMango

macrumors G3
Sep 21, 2010
9,516
6,773
I can't find the thread now, but it's a known problem that the web drivers have a bug with multiple monitors on certain models. I didn't think the 570 was one of them though. I'd ask in the big Nvidia FAQ thread because people in the know monitor that thread pretty well.
 

nigelbb

macrumors 65816
Dec 22, 2012
1,032
201
This has been a known problem with the Nvudia web drivers & GTX570 for a long time. I have several times reported it on this forum & even started a thread about the issue (on my iPhone ATM so can't find link). The good news is that it appears to be fixed in Yosemite with the latest Nvidia drivers which I also posted about a few days ago.
 

weezerr

macrumors regular
Original poster
Nov 7, 2006
189
91
This has been a known problem with the Nvudia web drivers & GTX570 for a long time. I have several times reported it on this forum & even started a thread about the issue (on my iPhone ATM so can't find link). The good news is that it appears to be fixed in Yosemite with the latest Nvidia drivers which I also posted about a few days ago.
Cool thanks for the update. I skipped Yosemite and am still on 10.9.5 but will upgrade to El Capitan likely once it comes out of beta. Glad to see it got fixed!
 

weezerr

macrumors regular
Original poster
Nov 7, 2006
189
91
FYI El Capitan with latest beta web drivers works great, both monitors alive and well.
 

nigelbb

macrumors 65816
Dec 22, 2012
1,032
201
FYI El Capitan with latest beta web drivers works great, both monitors alive and well.
Thanks for confirming this. I shall be upgrading my wife's Mac Pro to El Capitan in a couple of weeks so it's good to know that the web drivers continue to work with the GTX570.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.