Mac Pro 3,1 not booting after High Sierra Patcher

Discussion in 'macOS High Sierra (10.13)' started by OLPMac, Apr 16, 2019.

  1. OLPMac macrumors newbie

    Joined:
    Apr 16, 2019
    #1
    Hi everyone. I'm new here. I have just installed dosdude1's High Sierra Patcher on my 2008 Mac Pro 3,1. The Patcher installed fine, I managed to run the installer, then that completed and went to reboot (as it should have). My issue is that now the machine seems to try to boot up, but shuts off half way through. Before the startup chime.

    I have never experienced this issue before and the machine has only had a month of use since I purchased it from Macbank on eBay.

    I have tried cmnd-option-p-r and cmnd-r. These get me as far as the chime sound, but it ***** off shortly after, without my Acer monitor detecting a signal.

    Is there anything I can do to fix this? Please help!

    -Phil
     
  2. bbfc macrumors 68040

    Joined:
    Oct 22, 2011
    Location:
    Newcastle, England.
    #2
    When it restarted after installing did you boot back into the external drive and run the post-install patches?
     
  3. OLPMac thread starter macrumors newbie

    Joined:
    Apr 16, 2019
    #3
    Hi! I managed to get it running. I think (emphasis on THINK) I have worked out most of the bugs too and at long last it seems to boot up every time.

    Thank you for your reply!
     
  4. saint322, May 15, 2019
    Last edited: May 15, 2019

    saint322 macrumors member

    Joined:
    Dec 12, 2013
    Location:
    OKC, OK
    #4
    I just purchased a new (to me) cMP 3,1 and went through my first run of DosDude's patch to install High Sierra. I followed all of the instructed and did the post install patches but still have a question. Towards the end of the instructions page for High Sierra after item 11 is "Additional Info," see below:

    • If selected in the macOS Post Install tool, your High Sierra install will have a program named "Patch Updater" located in your /Applications/Utilities folder. This program will alert you when new updates to patches are available for your machine, and will prompt you to install them. If you do not have Patch Updater installed, but would like it, you can download and run the script found here to do so.
    After I ran the post-patch tool and insured the necessary items were added for my 3,1 which included "Install Patch Updater" which is not located in my Utilities folder as version 1.1.0. Upon reinstall, it did launch and alert me a Dark Mode patch was available and I applied/restarted without issue. Now there is a Security Update via the Apple Store but not the Patch Updater. I believe I can run via the Apple Store and if it doesn't reboot properly to boot from my installer USB stick and run the Post-patch process again as described below:

    screen.jpg

    • If the machine does not start up properly after applying a system update, you will need to boot off your patched installer volume, and re-run the post-install patch on your High Sierra volume. Ensure you select "Force Cache Rebuild" before rebooting.
    Before I did, however, I wanted to check with others who have surely run into this and know the proper route to take.

    Best regards,

    - Saint
     

Share This Page

3 April 16, 2019