Mac Pro 3.1 & Samsung SSD 840 Pro installation issue

Discussion in 'Mac Pro' started by adamkun, Mar 26, 2013.

  1. adamkun macrumors newbie

    Mar 13, 2009
    Hi everyone, been having issues with installing ML onto a new MP 3.1 which have purchased recently.

    Currently have the SSD drive sitting in spare DVD bay connected with a IDE-Sata converter which drives a SATA B.Ray drive in another MP.

    My issue is that while i can copy a version (using CCC) which is installed on 2TB drive (installed myself earlier today - no problems) it wont boot on the SSD drive and quits during loading and results in the Question Mark Icon flashing afterwards.

    alternatively when trying to instal a fresh copy of OS X onto the drive it fails at the end with the following message being shown.
    (some images attached as reference)

    hope there are many forum viewers out there who may be able to provide a solution?

    thanks everyone!

    Attached Files:

  2. bsbeamer macrumors 65816

    Sep 19, 2012
    Curious how you first initialized and formatted the drive. Did you unbox, install drive, and use disk utility to format? If so, did you test read/write abilities as just a normal drive first?

    Have you tried hooking the drive directly to one of the SATA bays instead of IDE converter?

    How big is the disk image on the 2TB drive? How big is the 840 SSD? Are you upgrading OS to 10.8 from something else?
  3. VirtualRain macrumors 603


    Aug 1, 2008
    Vancouver, BC
    I'm not sure what all this is, but I'd start there... Connect the drive to a normal SATA connector and see what happens.
  4. adamkun, Mar 26, 2013
    Last edited: Mar 26, 2013

    adamkun thread starter macrumors newbie

    Mar 13, 2009
    Hi There, thanks for the reply.
    Hope this helps?
    Thanks again.


    Thanks i may try to grab a few connectors however at the moment there is no cable supplied with the SSD kit and the adapter plates at the local stores are all the wrong size to fit the trays on a MP.

    The other question i'm contemplating is why there are troubles in creating a recovery partition on the drive using CCC..

    Thanks for the comments so far.
    Cheers ;)

    Attached Files:

  5. bsbeamer macrumors 65816

    Sep 19, 2012
    If you don't have any cables or way to connect directly to the SATA port, the OWC drive sled is probably your best solution. Just make sure you get the right sized one for your Mac, believe there are two variations that they make, and this should be it:

    If you're going to just be adding this SSD to a PCIe adapter, then you may want to eliminate any possible issues with the SSD beforehand. Some people have issues with the PCIe adapters during setup.

    Would recommend reformatting the drive once you connect via the drive sled and then perform the clone to the SSD. Seems like your current adapter setup is what's causing the problems...
  6. adamkun thread starter macrumors newbie

    Mar 13, 2009
    Hardware Issue solved

    Hi All thanks for the input on this thread.

    The items including a PCIe board are due to arrive end of this week over the interim I did plug the drive into one of the hard drive bay slots and..

    Presto works like a charm.

    Relieved that the Drive works fine as I had swapped it from a Vector OCZ drive after reading about hardware issues with those units.

    thanks for everyone's thoughts and posts~!
    Much appreciated
  7. scottrichardson macrumors 6502

    Jul 10, 2007
    Ulladulla, NSW Australia
    Sorry I didn't reply sooner - but yes - Mac OSX Installer dislikes (very much) attempting to install the OS on a disk that is mounted via a non-standard interface/connection.

    I spent a week trying to get OS X to install on a dual samsung 840 RAID 0 stripe via a Sonnet Tempo SSD PRO PCI Card and it just wouldn't work.

    I mounted the SSDs via the built in SATA 2 backplane (i.e.: the 4 standard HD bays) and installed that way without a hitch, then moved the drives (still in RAID 0) back to the PCI card and it works fine.

    WHo knows if this is an Apple issue, or the peripheral maker issue.
  8. alphaod macrumors Core


    Feb 9, 2008
    I installed the OS to my SSD mounted in a FW enclosure before installing via a Velocity X2 adapter.
  9. chrfr macrumors 604

    Jul 11, 2009
    It's also worth noting that using the PATA severely cripples the speed of the SSD- even the stock SATA ports in the Mac Pro can't keep up with the Samsung 840 Pro. So it's a good thing you've found an approach that works. The PCIe card should give even better performance than the stock ports.
  10. m4v3r1ck macrumors 68020


    Nov 2, 2011
    The Netherlands
    Could you please share your workflow for this workarounds installing the RAID0 back to the Sonnet? Sounds very promising for my Mac Pro 3,1! :cool:

    Much appreciated! Cheers

Share This Page