Mac Pro 4,1 ATI Radeon HD 5770

Discussion in 'Mac Pro' started by MrAjsTech, Aug 31, 2012.

  1. MrAjsTech macrumors newbie

    Joined:
    Aug 22, 2012
    Location:
    Interweb
    #1
    I just recently purchased an Apple ATI Radeon HD 5770 for my Mac Pro 4,1. My mac pro is the 2 x 2.66ghz quad core cpus(8 Cores). I had a 4770 in the computer before the upgrade. I installed the Graphics card and my DVI port will not work.

    I plan on putting my 4870 back into my mac pro when I receive an adapter to split the power connector to two. (the 4870 has two power connectors.)

    If anyone knows why this is happening with my brand new card please let me know. I plan to run 3 displays off the 5770 right now only two work through the other two mini display ports.
     
  2. ashman70 macrumors 6502a

    Joined:
    Dec 20, 2010
    #2
    I have a 5770 in my 3,1 and run three displays, two from the mini display ports with adapters and one off the DVI port without an adapter. The adapters I have to use for the mini display ports are mini display to active adapters. Have you tried just one display in the DVI port with nothing in the mini display ports to see if it works?
     
  3. DPUser macrumors 6502a

    Joined:
    Jan 17, 2012
    #3
    If you are running two from the Mini Display ports via adaptors, as noted you will need the active adaptors. Google each and you will find more info. Three are supposed to work if you run native display port monitors.
     

Share This Page