Mac Pro 4.1 firmware issues

Discussion in 'Mac Pro' started by davmanypsp, Jul 24, 2017.

  1. davmanypsp macrumors newbie

    Joined:
    Jun 20, 2013
    #1
    Hi, I think I have messed up my mac's firmware. I disabled SIP from revovery and installed refind (wanted to install Ubuntu) but since I did that my mac is extremely slow to boot to anything (about 10 min). Also it doesn't completely boot, just appear the beach ball all the time. I have changed the HDD to another with a working OS X install, and it is extremely slow, but also can't start OS X. I hope i didn't broke anything.
    I reseted SMC and PRAM, and nothing. I tried to enable SIP again from the recovery (it actually gets into the recovery partition after a long time) but I get the message:

    csrutil: failed to modify system integrity configuration. This tool needs to be executed from the Recovery OS

    Which is what I'm doing, and somehow I can't reenable it again.

    [​IMG]

    Is there any way to reset the mac firmware?

    What can I do to make my mac work again?

    Thanks

    EDIT: I'm on El Capitan, the latest available for this machine.
     
  2. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    None of things you listed will modify your firmware.

    Disabling SIP is a security setting that's stored in NVRAM. Are you 100% sure you are clearing the NVRAM? Some keyboards won't do it. If you've successfully cleared the NVRAM, the computer will play a second startup "bong". If you don't hear the second "bong", the NVRAM isn't being reset.
     
  3. davmanypsp, Jul 25, 2017
    Last edited: Jul 26, 2017

    davmanypsp thread starter macrumors newbie

    Joined:
    Jun 20, 2013
    #3
    Hi, when i press alt, cmd, p,r just after pushing the power button, it seems it can't reset the PRAM, it doesn't play the second "bong", just shows me the interrogation sign inside a folder. I have firmware password (and I know it), but I can't remove it. Clicking on the "Firmware password utility" from the recovery apparently does nothing.
    --- Post Merged, Jul 25, 2017 ---
    I finally fixed it! It seemed that the firmware password was preventing me from clearing the PRAM. I managed to remove the firmware password and then cleared the PRAM, and everything is working allright again.

    Thank you so much :)
     

Share This Page