Mac Pro 4.1 pcie SSD boot issue.

Discussion in 'Mac Pro' started by aajeevlin, Jul 13, 2016.

  1. aajeevlin macrumors 6502a

    Joined:
    Mar 25, 2010
    #1
    So I'm not able to find much information on this so I want to see if someone has done this before or have similar issues. I recently purchased a Mac Pro 4.1 quad 2.66, pretty stand stuff. I then got a OWC pcie to SSD that would allow to me to take advantage of the sata3 speed on the drive. Everything was good and I was able to boot from the SSD just fine (which Mac think it's an external drive).

    Then I did two things, I wipe the existing internal drive that was previously running the OS X and made it into an storage space, I also enabled FileVault on the new pcie attached SSD (the now boot drive, which the system sees it as external drive). The system told me it needs to reboot to take effect which I said okay. After the restart, I heard the usual chime and the computer would just sit there with a black screen and do nothing. I tried to get into the boot option with no luck. I then try to get into the recovery, it sort of worked but it took me to this screen called "password reset", which I don't really have anything to reset. Under the same screen there is another option called start up desk, I clicked on it and the system told me it was not able to identify the boot disk because of encryption, but I can unlock them and boot from the identifiable one. I entered the password and choose the drive I want to boot from, restarted and nothing.....it just sits there with a black screen.

    Might this have something to do with trying to encrypt an external pcie SSD boot drive? I have never dealt with this before so I'm not familiar with the behavior. I know that you can encrypt internal boot SSD drive just fine. Anyways any help is appreciated. I'm actually starting to think I should just get rid of the pcie to SSD and just be happy with the lower speed and less hassle getting it to setup.
     
  2. xactoman macrumors member

    Joined:
    Jul 9, 2015
    #2
    I ran into this when I was rebuilding my mac pro with PCIE drives. It appears EFI boot information is stored on a physical internal hard drive partition (EFI) that is not visible with disk utility. It can be seen in the terminal with diskutil. I think that file vault uses this sector too for encryption. My guess is that wiping your internal drive removed this EFI boot information and is making it hard for you to restart. I had to remove all drives from my machine and reformat/reinstall the OS onto the PCIE so that the EFI boot sector would be installed to the correct drive. It must have somethign to do with the PCIE card not being a standard bootable bus. It also was a problem with my SSD that had windows on it, the mbr boot information was storing on the EFI internal partition and not the SSD. So, long story short, if installing OS to a PCIE SSD, make sure its the only drive in the system so that it writes a correct EFI for each drive.

    Keep at it, the installation of SSD on PCI is a pretty amazing upgrade.
     
  3. rodedwards macrumors member

    Joined:
    Jul 7, 2010
    #3
    I think you can upgrade the firmware to 5.1 on that Mac. It will then be much more current and allow greater expansion. May be worth looking in to if all else fails.
     
  4. aajeevlin, Jul 13, 2016
    Last edited: Jul 14, 2016

    aajeevlin thread starter macrumors 6502a

    Joined:
    Mar 25, 2010
    #4
    Thanks guys. I'll give both suggestion a try. It failed this morning before work so I didn't have too much time to continue to investigate this further. I'll get back to it after work. Will report back.

    Update:
    First of all I observed that Mac Pro start up into boot option as well as recovery mode is a very hit or miss process. Booting from a el captain USB recovery I think if I try to boot into recovery 10 times I might get two success. And never mind the boot option screen, wasn't even able to get that going at all.

    Anyways, my current conclusion is that you can't encrypt an external pcie SSD drive and "boot from it" on the Mac Pro.

    I tried two setup. First it's just the pcie SSD in the computer by itself. Everything was good I was able to boot from it and operate as normal. As soon as I turned FileVault on and it went to restart, it does the chime and just sat there. This is when I installed OS X onto the pcie SSD drive directly.

    Second setup, I figured okay if you need to run the encryption with an internal drive why don't I just make a fusion drive and encrypt them together. Did the fusion drive and then turned on FileVault with the same result. Restart chimes and just sat there.

    I have one more setup I have in mind to try, but if that doesn't work I'll probably just bite the bullet and run the SSD internally at SATA2 speed. Half the speed but I guess for what I want to do its not that bad.

    Anybody actually were able to boot from pcie SSD with FileVault on? I can't really find any definitive answer on that online. Most of them talks about running it as USB3 external which is different then my setup. Thanks.
     
  5. aajeevlin, Jul 15, 2016
    Last edited: Apr 15, 2017

    aajeevlin thread starter macrumors 6502a

    Joined:
    Mar 25, 2010
    #5
    Just want to update and bump this thread a little bit. I have tried many many combination but I just can't get this to work. In the process I have discovered that there is a known bug, when you try to enable FileVault2 (possible using iCloud as a backup option), after the reboot you will be greeted with a black screen. And the bug is such that the black screen is actually waiting for you to enter password. I have tired this several time, where I would be greeted with a black screen and once I entered the password, the computer was able to boot and continue.

    I have not be able to enable FileVault2 on the pcie SSD. I'm able to boot from it just fine, but once I enabled the FileVault2 on the SSD and restart, I'm greeted by a black screen and I'm not able to move forward no matter what. Is it actually possible to encrypt a pcie SSD? I have yet to find a definitive answer...

    Last update: Just to warp this up in case anyone else is interested. I DID eventually got it to work, so yes, pcie ssd on a Mac Pro 4.1 encrypted boot will work. However, this is my finding:
    1. According to multiple discussion online, there seems to be a bug that will force the boot into a "black screen". When this happens the Mac is actually fine, but its sitting there waiting for you to enter the FileVault2 password in order to move forward. And because most people (including me) simply assumed there is something wrong with the Mac, they will simply attempt to reboot, which then they are greeted with that "Reset Password" screen. Since due to the bug, the screen is blacked out. So by pressing "enter" to select your user name and "password" and enter again it will get around this issue.
    2. There is also a brief mention of something about enabling iCloud authentication, which also caused the "black screen" as well. He got pass this problem by turning off the iCloud authentication.
    None of the discussion that I was able to find actually have the same setup as me, but the symptom was similar enough that they helped. So currently when I boot I'm greeted with a black screen, and with a "connected" keyboard I can get around this problem by typing my password into a black screen.....maybe Apple will fix this next time.

    Thanks for the help and reading.

    Update (almost a year ago): I just want to record my final update to this "issue" (if I can still call it that). As it turns out, I think my problem was really a none-issue in terms of the source of the problem. So I finally discovered this when I was trying to change some hardware for my Mac Pro 4.1 (converted to 5.1), to see if I can again help with my blake screen at start up. So I have a relatively new 27inch monitor and a much older 21 inch connected to the computer. What I discovered is that when I disconnected the new 27inch monitor, I can for the very first time see the filevault log in screen on the 21inch older monitor, wow! I think having the 27inch monitor connected to the computer is preventing the login output to be displayed properly. So my solution at every reboot is to simply disconnect my 27inch monitor and boot, then reconnect back. I can see this problem becomes more frequent as we hang on to the older Mac Pros but using newer monitors with it. Hope this can help somebody out...
     

Share This Page