Mac Pro 4,1 to 5,1 upgrade... New CPU causing kernel panic

Discussion in 'Mac Pro' started by C. Alan, Jul 21, 2014.

  1. C. Alan macrumors 6502

    Joined:
    Jan 23, 2009
    #1
    Ok, so I am trying to upgrade my early 2009 Mac Pro that came with 2.66 quad core to a 5,1 with a 3.46 hex core processor.

    I have downloaded and upgraded the EFI to a 5.1 and went ahead and installed the processor, and then went to boot it.

    Now it won't boot in either 10.9 or 10.8, nor the recovery discs, and each time I try, I get the same kernel panic (see attached). Sorry for the huge picture, I'm working on my iphone here.

    I'm about out of ideas how to get my mac up and running again. Any ideas?
     

    Attached Files:

  2. DPUser macrumors 6502a

    Joined:
    Jan 17, 2012
    #2
    If all else fails, pull the new CPU, inspect the CPU socket carefully and if no damage is visible, reinstall old CPU. If everything works, check to be sure your Mac shows as a 5,1 (to be sure the EFI upgrade worked) and, if so, reinstall the new CPU. If it doesn't work, it may be bad.
     
  3. crjackson2134, Jul 21, 2014
    Last edited: Jul 21, 2014

    crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #3
    After you upgraded the firmware, did it boot normally with the old processor?

    If it did, I would reinstall the old processor to verify the system.

    EDIT: Looks like DPUser beet me to the punch.
     
  4. C. Alan thread starter macrumors 6502

    Joined:
    Jan 23, 2009
    #4
    Well I did reinstall the old processor, and it did boot normally. I then put the new 3.46 hex core in it, and it still panics. However, it will boot in console mode. I can get into /var/log/, and browse the logs with VI, but I'm not sure what I am looking for yet. Being able to get into console mode is making me wonder if it a software issue, it maybe I should try a fresh install of mavericks.

    Btw, if you look at my screenshot, it is identifying as a 5,1. Should I also check the firmware edition? I wonder if it logged somewhere, so I don't have to swap the processor again.
     
  5. ScottishCaptain macrumors 6502a

    Joined:
    Oct 4, 2008
    #5
    Your screenshot is truncating the most important bits to the right hand side. If you want to post the complete kernel panic, maybe someone can help you- otherwise, you might be able to google the machine check codes and figure out why the machine is panicking.

    -SC
     
  6. Korican100 macrumors 6502a

    Korican100

    Joined:
    Oct 9, 2012
    #6
    Maybe a bad CPU. if you purchased off ebay, take advantage of your buyer protection asap.

    I did this upgrade, and followed the path of, 4,1 -> flashed to 5,1 -> installed new cpu. Boot and ta-da.
    There should be no OSx conflicts, no software conflicts. If 4,1 worked, 5,1 should work without a hitch.

    Make sure your ram is seated properly, gpu etc all that stuff. If that looks good, and your old cpu boots no problem. REturn that new CPU asap.
     
  7. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #7
    I second Korican

    Should work, if not likely a bad CPU

    As this is single CPU machine, really no way to screw it up.

    I would be 100% certain that all the little gold dots on bottom of CPU are clean
     
  8. omvs macrumors 6502

    Joined:
    May 15, 2011
    #8
    Slight possibility it could be the ram trying to do 1333 and failing?

    Did you zap the PRAM after the install? If not, then it should be running the old speed, which would be safer. To be more sure, you could pull out all but one DIMM, try it, and if it fails, try another dimm. If still fails, its gotta be the CPU
     
  9. keringalhi macrumors newbie

    Joined:
    Jul 22, 2014
    #9
    you might be able to google the machine check codes and figure out why the machine is panicking.[​IMG]
     
  10. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #10
    Check if hex CPU doesn't have any missing parts (micro resistors specifically).
    If your machine boots with old CPU, then CPU socket is OK.
    You may also reset PRAM to clear boot args, because it looks like your MP tries to boot from recovery partition.
     
  11. C. Alan, Jul 22, 2014
    Last edited: Jul 22, 2014

    C. Alan thread starter macrumors 6502

    Joined:
    Jan 23, 2009
    #11
    Im sending it back

    Well after reseating the chip three times, and checking and cleaning the bottom, there is still no change in the behavior. From all reports, it should not be this hard. So I am sending the chip back. Hopefully I can get another 3.46 chip soon.

    Im now using the machine again with the old 2.66 quad core processor in it again. For those who are curious, here is what the panic log looked like. From what I can tell from my Google Searches, the Machine Check error means the panic is hardware related. So it may very well be the chip.:

    Code:
    Anonymous UUID:       6029F6D5-2CB8-DEE8-5542-46FA969426AA
    
    Mon Jul 21 19:50:57 2014
    Machine-check capabilities: 0x0000000000001c09
     family: 6 model: 44 stepping: 2 microcode: 15
     signature: 0x206c2
     Intel(R) Xeon(R) CPU           W3690  @ 3.47GHz
     9 error-reporting banks
    Processor 6: IA32_MCG_STATUS: 0x0000000000000004
     IA32_MC2_STATUS(0x409): 0xf602108000040150
     IA32_MC2_ADDR(0x40a):   0x00007fff8d6daa19
    Processor 7: IA32_MCG_STATUS: 0x0000000000000004
     IA32_MC2_STATUS(0x409): 0xf602108000040150
     IA32_MC2_ADDR(0x40a):   0x00007fff8d6daa19
    panic(cpu 11 caller 0xffffff800c8dcad9): "Machine Check at 0xffffff800c8e2881, registers:\n" "CR0: 0x000000008001003b, CR2: 0xffffff815e595000, CR3: 0x000000000f144000, CR4: 0x00000000000206e0\n" "RAX: 0x0000000000000000, RBX: 0x0000000000000025, RCX: 0x000000004a07ff6f, RDX: 0x0000000000000001\n" "RSP: 0xffffff818614bcf0, RBP: 0xffffff818614bcf0, RSI: 0x0000000000000002, RDI: 0x0000000000000250\n" "R8:  0x0000000000000000, R9:  0x000000000000000b, R10: 0xffffff8186140000, R11: 0x0000000000000200\n" "R12: 0x0000000000000003, R13: 0x7fffffffffffffff, R14: 0x0000000000000001, R15: 0xffffff7f8e73ec98\n" "RFL: 0x0000000000000006, RIP: 0xffffff800c8e2881, CS:  0x0000000000000008, SS:  0x0000000000000010\n" "Error code: 0x0000000000000000\n"@/SourceCache/xnu/xnu-2422.110.17/osfmk/i386/trap_native.c:168
    Backtrace (CPU 11), Frame : Return Address
    0xffffff817e6ade80 : 0xffffff800c822f79 
    0xffffff817e6adf00 : 0xffffff800c8dcad9 
    0xffffff817e6ae060 : 0xffffff800c8f3fef 
    0xffffff818614bcf0 : 0xffffff800c8e25f4 
    0xffffff818614bd10 : 0xffffff7f8e72089b 
    0xffffff818614bd40 : 0xffffff7f8e72094f 
    0xffffff818614bd80 : 0xffffff7f8e71a261 
    0xffffff818614be70 : 0xffffff7f8e7198d9 
    0xffffff818614bf30 : 0xffffff800c8ddb0c 
    0xffffff818614bf50 : 0xffffff800c83758a 
    0xffffff818614bf90 : 0xffffff800c8378d8 
    0xffffff818614bfb0 : 0xffffff800c8d7417 
          Kernel Extensions in backtrace:
             com.apple.driver.AppleIntelCPUPowerManagement(217.92.1)[CF28958D-CA8A-3A79-911C-78217F5DDAF2]@0xffffff7f8e717000->0xffffff7f8e741fff
    
    BSD process name corresponding to current thread: kernel_task
    
    Mac OS version:
    13E28
    
    Kernel version:
    Darwin Kernel Version 13.3.0: Tue Jun  3 21:27:35 PDT 2014; root:xnu-2422.110.17~1/RELEASE_X86_64
    Kernel UUID: BBFADD17-672B-35A2-9B7F-E4B12213E4B8
    Kernel slide:     0x000000000c600000
    Kernel text base: 0xffffff800c800000
    System model name: MacPro5,1 (Mac-F221BEC8)
    
    System uptime in nanoseconds: 4362246976
    last loaded kext at 1013628771: com.apple.driver.AppleUSBHIDKeyboard	170.15 (addr 0xffffff7f8e78a000, size 16384)
    loaded kexts:
    com.apple.iokit.SCSITaskUserClient	3.6.6
    com.apple.driver.AppleFileSystemDriver	3.0.1
    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
    com.apple.AppleFSCompression.AppleFSCompressionTypeLZVN	1.0.0d1
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0d1
    com.apple.BootCache	35
    com.apple.driver.XsanFilter	404
    com.apple.iokit.IOAHCIBlockStorage	2.6.0
    com.apple.driver.AppleUSBHub	683.4.0
    com.apple.driver.AppleFWOHCI	5.0.2
    com.apple.driver.Intel82574L	2.6.2b1
    com.apple.driver.AirPortBrcm43224	700.36.24
    com.apple.driver.AppleAHCIPort	3.0.5
    com.apple.driver.AppleUSBEHCI	660.4.0
    com.apple.driver.AppleUSBUHCI	656.4.1
    com.apple.driver.AppleRTC	2.0
    com.apple.driver.AppleHPET	1.8
    com.apple.driver.AppleACPIButtons	2.0
    com.apple.driver.AppleSMBIOS	2.1
    com.apple.driver.AppleACPIEC	2.0
    com.apple.driver.AppleAPIC	1.7
    com.apple.driver.AppleIntelCPUPowerManagementClient	217.92.1
    com.apple.nke.applicationfirewall	153
    com.apple.security.quarantine	3
    com.apple.driver.AppleIntelCPUPowerManagement	217.92.1
    com.apple.driver.AppleUSBHIDKeyboard	170.15
    com.apple.driver.AppleHIDKeyboard	170.15
    com.apple.iokit.IOUSBHIDDriver	660.4.0
    com.apple.driver.AppleUSBMergeNub	650.4.0
    com.apple.driver.AppleUSBComposite	656.4.1
    com.apple.iokit.IOSCSIMultimediaCommandsDevice	3.6.6
    com.apple.iokit.IOBDStorageFamily	1.7
    com.apple.iokit.IODVDStorageFamily	1.7.1
    com.apple.iokit.IOCDStorageFamily	1.7.1
    com.apple.iokit.IOAHCISerialATAPI	2.6.1
    com.apple.iokit.IOSCSIArchitectureModelFamily	3.6.6
    com.apple.iokit.IOFireWireFamily	4.5.5
    com.apple.iokit.IOUSBUserClient	660.4.2
    com.apple.iokit.IO80211Family	640.36
    com.apple.iokit.IONetworkingFamily	3.2
    com.apple.iokit.IOAHCIFamily	2.6.5
    com.apple.iokit.IOUSBFamily	683.4.0
    com.apple.driver.AppleEFINVRAM	2.0
    com.apple.driver.AppleEFIRuntime	2.0
    com.apple.iokit.IOHIDFamily	2.0.0
    com.apple.iokit.IOSMBusFamily	1.1
    com.apple.security.sandbox	278.11.1
    com.apple.kext.AppleMatch	1.0.0d1
    com.apple.security.TMSafetyNet	7
    com.apple.driver.AppleKeyStore	2
    com.apple.driver.DiskImages	371.1
    com.apple.iokit.IOStorageFamily	1.9
    com.apple.iokit.IOReportFamily	23
    com.apple.driver.AppleFDEKeyStore	28.30
    com.apple.driver.AppleACPIPlatform	2.0
    com.apple.iokit.IOPCIFamily	2.9
    com.apple.iokit.IOACPIFamily	1.4
    com.apple.kec.pthread	1
    com.apple.kec.corecrypto	1.0
     
    
     
  12. TzunamiOSX, Jul 22, 2014
    Last edited: Jul 22, 2014

    TzunamiOSX macrumors regular

    Joined:
    Oct 4, 2009
    Location:
    Germany
    #12
    Do you use a Xeon with Heatspreader?

    Do you use the "washer" or "turns count" methode?

    Look at the pictures
    http://puier.lofter.com/post/80c4b_6a8195

    This will help, but im not sure that you need to remove the clips from the Fan connector
     
  13. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #13
    ^^^^The OP is modifying a Single CPU Mac Pro 4,1. The lidless CPU problem only affects dual CPU 4,1 Mac Pros, not single CPU Models. The questions you are asking are not apropos to this thread.

    Lou
     
  14. TzunamiOSX macrumors regular

    Joined:
    Oct 4, 2009
    Location:
    Germany
    #14
    Ups, I'll take everything back and claim the opposite. :D
     
  15. TzunamiOSX macrumors regular

    Joined:
    Oct 4, 2009
    Location:
    Germany
    #15
    Can you post a photo (top) of the CPU, perhaps it is an ES Version or something like this.
     
  16. mikeboss macrumors 65816

    mikeboss

    Joined:
    Aug 13, 2009
    Location:
    switzerland
    #16
    I also had bought a faulty Xeon a few months back (this was the first time ever that I had to deal with a defective CPU). same symptoms: OS X and Windows 7 crashed almost immediately while trying to boot. interesting thing was that Apple Service Diagnostics (or was it Apple Hardware Test? not sure anymore) did NOT show any errors at all! according to the log, only CPU-0 is tested, all other five cores were untested...
     
  17. C. Alan thread starter macrumors 6502

    Joined:
    Jan 23, 2009
    #17
    Update: Its running again

    Well, I went ahead and returned the processor last week, and I finally got around to ordering another W3690 yesterday. The vendor was local to me, so the new chip got delivered today. I dropped it in, and rebooted. The machine came up with no issues. So there was definitely an issue with the last chip I ordered.

    Now my 2009 Mac Pro is happily humming along on a 3.46ghz Xeon W3690. I have also added a USB 3.0 card, and a PC version of the HD 7950. So I should be good for a couple of more years.
     
  18. DPUser macrumors 6502a

    Joined:
    Jan 17, 2012
    #18
    Bravo!
     
  19. C. Alan thread starter macrumors 6502

    Joined:
    Jan 23, 2009
    #19
    I just noticed that the OWC memory I purchased last year for this machine is now running at 1333Mhz. That was a pleasant surprise. I purchased it as 1066Mhz memory.
     
  20. DPUser macrumors 6502a

    Joined:
    Jan 17, 2012
    #20
    I had the same thing happen with a different vendor… RAM is labeled as 1066, but is really 1333.
     

Share This Page