Mac Pro 4.1 with Apple Raid Card

Discussion in 'Mac Pro' started by areandres, Oct 14, 2011.

  1. areandres macrumors newbie

    Joined:
    Oct 14, 2011
    #1
    Hi @ all,
    i have one question.
    I bought a Apple Raid Card.
    It worked fine with my 3 Seagate HDD's with Raid 5.
    Now i bought 3 Hitachi 15K600 SAS drives.
    This hdd are recognized by Raid controller but i can not make any raid ore format the hdd´s. Always error appears could not write the last byte.

    I use actual Lion.

    Is there anybody who can help me please.

    Greets Andy
     
  2. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #2
    Are there any other drives attached to the card?
    • I ask, as you cannot mix SAS and SATA drives on that card.
    Now if all disks are SAS or SATA, the 15k SAS models *should* work. However, here's what Apple has to say...
    Source.

    Even if the disks aren't the issue (incompatibility with the card's firmware = disks won't work), there could be a bad disk in the set, or even Lion causing the problem. Settings too, but IIRC, there isn't much available to the user as is the case with other RAID cards.

    Give you already have the drives, and it's out of Apple care (given it's age), you could try the following:
    1. You could try to roll back to 10.6.7 from Lion (reason = Lion and RAID haven't played well together in a lot of cases so far). 10.7.2 may be more stable, but I wouldn't go so far as to think it's all fixed without confirmation from others that are testing it out.
    2. Scan each drive before trying to run them in a set for defects (full surface scan), which may require placing them in a PC running Windows and has a SAS controller (no idea what you have access to). The reason for the PC, is that scanning software from disk vendors (Hitachi's download page) doesn't pass the low level data properly (free utilities they offer), and won't work in a MP. Disk Warrior works under OS X, but there's not a free trial ($100).
    Past this, it's a compatibility issue, which means either get new disks, or get a new RAID card (recommended solution, as the Apple RAID Pro is a pile of junk).
     
  3. areandres thread starter macrumors newbie

    Joined:
    Oct 14, 2011
    #3
    @nanofrog,
    thank you for your explanation.
    At weekend i tryed everythuing exept downgrade to OS.
    I dont want.
    I tryed each drves alone. Always the same issue.
    And i dont mix sata and sas i know this is not working.
    I will send back the drives and i will check for new one.

    Thanks
     
  4. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #4
    When you say "tried" in regards to the disks, do you mean in Pass Through mode (single disk mode on the RAID card), or did you do a full surface scan on the disks with say Disk Warrior or a PC and equivalent software?

    I ask, as a bad disk would have problems no matter how you configured it (i.e. bad sectors on the platters, bad controller board, ...).

    In terms of SAS and SATA, you can't even have a SAS or SATA array on the same RAID card (wasn't referring to trying to mix SAS and SATA disks into a single volume).
     

Share This Page