Mac Pro 4,1 won't chime after GPU upgrade!

Discussion in 'Mac Pro' started by MentalVizion, May 14, 2015.

  1. MentalVizion macrumors regular

    MentalVizion

    Joined:
    Oct 30, 2013
    Location:
    Austria
    #1
    Hey guys!

    I finally got around purchasing a used GTX 780. It is the Revision A1 model. (manufacturer - Asus).

    I also got 2 mini 6 pin to 6 pin cables aswell as a 2x SATA to 6 pin, 2x 6 pin to 8 pin and a 6 pin extension cable.

    I plugged in both of the mini 6 pin cables into the Mac's logic board and connected them to the 2x 6 pin to 8 pin adapter. The 8 pin end went into the graphics card.

    The 6 pin that came from the 2 SATA connectors I plugged in in tray 3 & 4 got hooked up to the extension cable. The other end of the extension cable runs into the 6 pin connector on the 780.

    When I power on the machine I get no boot and the screen stays black.
    When I put back in my Apple Radeon 5770 everything boots up flawlessly.

    To rule out it's a cable problem I used an EVGA Supernova 650W PSU that I connected to the graphics card. I then did the paper clip trick to power on the PSU. Still, not chime / black screen.

    The white LED is constantly lit. I do have Mavericks 10.9.5 (13F1077) installed. I installed the latest Quadro / Geforce driver from the nvidia website and selected it in the menu bar.

    Latest CUDA drivers are also installed.

    So I guess my card is faulty or it's some software issue. What do you guys think?

    Could it be the security update 2.0 thingie?
    IIRC it was responsible for many "dead" cards in Yosemite, however I am on Mavericks.

    I already tried the card in PCI slot 2 btw.

    If you guys have any idea I would be very thankful!
     
  2. bax2003 macrumors 6502a

    bax2003

    Joined:
    Dec 25, 2011
    Location:
    Belgrade, Serbia
    #2
    No chime has nothing to do with CUDA, driver or OS X version (including or excluding security update).

    Sounds like faulty card or power issue.
     
  3. MentalVizion thread starter macrumors regular

    MentalVizion

    Joined:
    Oct 30, 2013
    Location:
    Austria
    #3
    Alright, little update - card seems to be working in a windows machine!
    I talked to the previous owner of the card on the phone and he said he did a Bios flash (he called it "firmware update") some time ago, so I'll look into that.

    Downloading the driver right now, will report back once I get new results!
     
  4. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #4
    For testing you could use the Dual 6 into 8 by plugging one of the internal 6 pins into the side with FEWER cables, should allow a test.
     
  5. MentalVizion thread starter macrumors regular

    MentalVizion

    Joined:
    Oct 30, 2013
    Location:
    Austria
    #5
    Alright, card is working fine now!!! :)
    It turned out to be the bios of the card. There are two different bios versions of this model (Asus GTX780-3GD5) and on my card the newer one was flashed.

    Fortunately I had some spare PC parts lying around so I was able to hook it up in a PC machine and it worked fine there. I then flashed it using nvflash and popped it back into the mac and it's working perfectly fine.

    However I still got that fan RPM issue I had with my 5770 :/
    Again, doing the OpenGL Extension Viewer Cube test fixes it.
    Annoying.

    In case anyone want to know how I flashed the card:

    Create a folder in C: called "flash" or whatever - something simple makes life easier later on.

    So you should have:

    C:/flash

    Download nvflash - pretty much any version should do - and pase the .exe and both of the .dll files into that folder you had just created.

    Also download the right bios file for your 780!
    (This one! https://www.techpowerup.com/vgabios/139964/asus-gtx780-3072-130507-1.html)

    Rename the bios file to something simple like "GTX780.rom".

    Copy the bios file into the "flash" folder aswell.

    You now should have the 3 nvflash files aswell as the .rom file in that "flash" folder.

    Now type "cmd" into the windows searchbar and run it.

    type in cd C:/flash to switch to the right directory.
    PLEASE NOTE! - replace "flash" with the name of the folder you first created!

    Now simply type nvflash GTX780.rom
    AGAIN! replace "GTX780" with whatever you named your bios file!

    Just hit enter and confirm the next prompt by pressing Y and wait a few seconds.
     

Share This Page