Mac Pro 5,1---10.10.3 Update---Graphics Issues

Discussion in 'Mac Pro' started by Claywd, Apr 21, 2015.

  1. Claywd, Apr 21, 2015
    Last edited: Apr 21, 2015

    Claywd macrumors newbie

    Joined:
    Nov 9, 2012
    #1
    Hey Everyone,



    Having issues with 10.10.3 update. Supplemental update hasn't helped.



    Build: Mac Pro 5,1
    •16GB ECC DDR3 RAMM
    •OWC Mercury Accelsior_E2 (Basically Flash Storage)
    •6TB of SATA II HDD (SATAII instead of III because of over heating issues caused by lack of support for SATA III)
    •EVGA GeForce GTX980 SuperClocked (Also have a few AMD's available but not on board)
    •USB 3.0 PCIE card (Generic and cheap but awesome results)
    •Dell P2715Q 4k

    Use:
    •Virtualizing Windows Server Tech Preview and 2012 (Practicing integration with Active Directory)
    •Running MAC OSX Server and Plex Media Server (OD, Time Machine, Web Server, etc.)
    •Video Editing
    •General Business Use

    Problem:

    I had a Sapphire 9750 installed when I updated to 10.10.3. The card already had issues so I thought it was the card. I got a replacement card and installed it but this didn't help. I returned the card and ordered an EVGA GTX980 SC and it still didn't work. At this point I begin to understand that Apple screwed me with the 10.10.3 update. Supplemental Update did nothing. Worthless.



    Troubleshooting Steps:

    This guy, ME! I made a backup using Carbon Copy Cloner before the update. So I installed a basic AMD card and booted to it after reversing changes by trim enabler (This described here). I booted the Backup Running 10.10.2 and installed CUDA from NVidia and Web Drivers, rebooted and shut it down. I swapped out the cards and proceeded to test the ports. Everything worked under 10.10.2. When I tried all this under 10.10.3 (using the newest web drivers) I still got nothing but a black screen. As of right now I am accessing the 10.10.3 volume by booting it without external graphics card.




    Any help or guidance would be greatly appreciated.
     
  2. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #2
    Hopefully you left trim enabler alone for these tests. I don't know if he has updated it or not but recent versions used a "shotgun" approach to the boot args, overwriting anything there instead of just adding to whatever was there.

    So if you were running a GTX980 just fine and then turn on TE you would boot to black screen as the NVIDIA drivers would be turned off by that code.

    Type in terminal "nvram -p" and have a look at your boot args. You should see the Nvda driver=1 in there. If not, it needs to be.

    As far as 2 @ 7950 (right, you didn't mean 9750?) and 980 all not working, they use entirely different drivers and the recent issues have all been due to Nvidia drivers choking on new build numbers.

    So I have to point out that the other thing all 3 cards have in common is the slot and the power. Hopefully you got the memo about needing 2 @ power cables? About once a month I get an email from someone who thinks that "supplemental = optional" and that is not so. Must have 2@ 6 pins on 980 and if 7950 has an 8 pin connector it may need to sense all 8 populated. If you have power cables then have a look at the ends, sometimes a pin gets pushed back inside.

    Also try a different slot for cards. Only the bare Apple IO stuff is common in the drivers, the bulk is 100% different for AMD & NVIDIA so I doubt that 10.10.3 is the root cause of your woes.
     

Share This Page