Mac Pro 5,1 2010 won't power on.

Discussion in 'Mac Pro' started by Yurtal, May 29, 2017.

  1. Yurtal macrumors member

    Joined:
    May 8, 2009
    #1
    Hello everyone. I have found myself in a tricky situation. My Mac Pro 2010 won't turn on anymore all of a sudden. There is no click or sound when I push the power button, no light, no response whatsoever. I have replaced the power cord, plugged it into a different power source, unplugged everything and tried it but nothing works. When I press the 'DIAG LED' button inside the machine, the '5V STBY' LED illuminates (but only when I press the button). All other LED lights remain off.
    I don't have money to take it into a repair centre at this time and was wondering if there are some things I could try to get my machine up and running again.
    Thank you very in advance for your help.
    Regards,
    Ryan.
     
  2. Netherscurial macrumors newbie

    Joined:
    Oct 7, 2007
    #2
    I am having a similar problem on my mac pro too. Except I can get it to turn on but I have to play with the power button.

    Usually if I hold down the power button till I hear it click, then I let go and then hit the power button again and it comes on. I had taken it to the APple store and they said it was the power cord so I bought a new cord; it worked fine for awhle then the problem came back. It may be the power supply.

    Try holding the power button down till you hear it click, usually about 5 seconds, then hit it once right after. It may come on

    Kevin
     
  3. Macschrauber macrumors member

    Joined:
    Dec 27, 2015
    #3
    If you re located in Europe I have Power Supplies to sell ;-) pm me if so
     
  4. tracer1 macrumors member

    tracer1

    Joined:
    Jan 6, 2013
    Location:
    SC
    #4
    Mine was doing the same thing.....replaced the power supply and worked perfect. Mine would also not wake from sleep. Would have to power off, then hold power button till 1st click, then hold for 5-6 secs to power on. With new power supply, works great again. Hopefully that will fix yours.
     
  5. Sebct macrumors regular

    Joined:
    Dec 18, 2010
    Location:
    London, UK.
    #5
    Did you ever manage to get your mac pro to boot? I'm having the same problem.
     

Share This Page