Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

townlyy

macrumors newbie
Original poster
Feb 2, 2020
1
0
Hello!

I've read a bunch of different opinions on this so just looking for some clarification on some things...

1. Will I be okay installing a 980 Ti in my Mac Pro 5,1 running 10.13.6 (system overview attached)?

2. If so, is it plug and play?

3. Am I okay using the built in PSU?

Any other advice/recommendations is much appreciated! Thanks
 

Attachments

  • System Overview.png
    System Overview.png
    109.5 KB · Views: 114

tsialex

macrumors G3
Jun 13, 2016
9,508
10,253
Hello!

I've read a bunch of different opinions on this so just looking for some clarification on some things...

1. Will I be okay installing a 980 Ti in my Mac Pro 5,1 running 10.13.6 (system overview attached)?

2. If so, is it plug and play?

3. Am I okay using the built in PSU?

Any other advice/recommendations is much appreciated! Thanks
1) Yes, Maxwell NVIDIA GPUs work up to 10.13.6 and require NVIDIA webdrivers to work.
2) No, you need to install the webdrivers before changing the GPU or you won’t get a working display. See the NVIDIA sticky thread for instructions.
3) It will work better if you buy an eVGA Powerlink to balance the power requirements, doing so it will work fine.

 
  • Like
Reactions: AlexMaximus

rk44722

macrumors member
Apr 16, 2021
30
0
Hi

I'm having issues with my mac pro 5.1, and EVGA 980 ti doesn't seems to use Nvidia web graphics as default.

Did it work for you and if so, could you please guide me. my OS is 10.13.6 (17G14042) and I'm using latest web graphics 387.10.10.10.40.140 and cuda 418.163

Thanks.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.