Mac Pro 5.1 Firmware Upgrade from 140.0.0.0 to 141.0.0.0 failed.

zozomester

macrumors 6502
Original poster
Apr 26, 2017
268
63
Hungary
For some reason, the firmware is not updated from 140.0.0.0 to 141.0.0.0 Nothing happens when I hold down the button and does not update the firmware.
I've tried OSX 10.14.3, 10.14.4, 10.13.6. with Installer App on Application folder and USB installer. No results.
My OSX 10.14.4 My system as Signature....My Monitor is LG 34UC99.
Vega 64 to Lg Monitor: Displayport to Displayport. Resolution: 3440x1440
What could be the problem?
Thank!
 

bsbeamer

macrumors 68030
Sep 19, 2012
2,660
1,299
Download the FULL INSTALLER with the "installinstallmacos.py" script and post screenshots that it is downloaded correctly. You want 10.14.4 18E226 for authentic MP5,1 which is #3 in the screenshot below.

Screen Shot 2019-03-27 at 9.11.39 AM.png


Script is available at:
https://github.com/munki/macadmin-scripts/blob/master/installinstallmacos.py

Search this forum for "installinstallmacos.py" for additional walk throughs.

As you've been given previous advice in another thread, if you have changed your monitor in the past 3-6 months DP1.2 is likely the culprit. Don't change stuff and say "now it doesn't work". Swap monitor back and figure out what the issue really is.
 

zozomester

macrumors 6502
Original poster
Apr 26, 2017
268
63
Hungary
Download the FULL INSTALLER with the "installinstallmacos.py" script and post screenshots that it is downloaded correctly. You want 10.14.4 18E226 for authentic MP5,1 which is #3 in the screenshot below.

View attachment 828784

Script is available at:
https://github.com/munki/macadmin-scripts/blob/master/installinstallmacos.py

Search this forum for "installinstallmacos.py" for additional walk throughs.

As you've been given previous advice in another thread, if you have changed your monitor in the past 3-6 months DP1.2 is likely the culprit. Don't change stuff and say "now it doesn't work". Swap monitor back and figure out what the issue really is.
Thanks this answer!
Well, I downloaded the Mojave installer from the app store. Monitor has long been there (One years). The Video Card has been around for 4 months. I changed my processor tray about two months ago.
 

startergo

macrumors 65816
Sep 20, 2018
1,278
468
Where does Firmware load when restarting?
When asked to install the firmware shut down the Mac .then power back up and don't let go the finger from the power button untill you see it blinking .3-4 seconds later you may release . Wait until it boots to the operating system .log on and check the revision .
 

w1z

macrumors 6502
Aug 20, 2013
429
257
If your system meets all the requirements listed by @tsialex to upgrade the firmware yet the process fails, one area I have looked at that could possibly impact the process is corrupt efi bootrom device data in the NVRAM that is placed in there by the firmware updater program.

Please try clearing your NVRAM by carrying out a PRAM reset and running the full installer from the App Store again.
 

startergo

macrumors 65816
Sep 20, 2018
1,278
468
I've made a video. I made SMC and NVRAM reset. You still can't upgrade. What's the problem?
After you get the button blinking you should wait more leave it alone like 10 minutes and see if it boots again to the operating system and don't press any buttons . Remember you will not see any progress indication on the screen. It may reboot by itself .Just give it more time .
 

zozomester

macrumors 6502
Original poster
Apr 26, 2017
268
63
Hungary
After you get the button blinking you should wait more leave it alone like 10 minutes and see if it boots again to the operating system and don't press any buttons . Remember you will not see any progress indication on the screen. It may reboot by itself .Just give it more time .
Sorry, it doesn't start again. Inside're stuck. I touch the button and switch off immediately.

Do you think you have to wait 10 minutes? It was only a few seconds before .......
 

startergo

macrumors 65816
Sep 20, 2018
1,278
468
Sorry, it doesn't start again. Inside're stuck. I touch the button and switch off immediately.

Do you think you have to wait 10 minutes? It was only a few seconds before .......
Did you do NVRAM reset 3 or more times?