Mac Pro 5.1 GTX680 Bootcamp Suttering

Discussion in 'Mac Pro' started by DSevenPL, Mar 23, 2015.

  1. DSevenPL macrumors newbie

    Joined:
    Feb 22, 2015
    #1
    Hey. I have a stuttering while gaming no Mather of Game Settings. Fraps showing a solid 60FPS but I noticed a lags.

    I'm running via Bootcamp Windows 8.1 all drivers are up to date. Graphic card is a GeForce GTX680 Mac Edition.

    When I switch this GPU to normal PC I'm getting no stutter on the same game and settings ...

    MacPro 5.1
    2x Intel Xeon 6 Cores 3.46Ghz
    EVGA GTX680 MacEdition
    32 GB Ram 1333Mhz
    2x SSDs on 2x Apricorn Velocity Solo's
    Bootcamp on SSD in Drive Bay 1
     
  2. IowaLynn macrumors 6502a

    IowaLynn

    Joined:
    Feb 22, 2015
    #2
    EVGA Nvidia driver or Windows driver forGTX 680?
     
  3. DSevenPL thread starter macrumors newbie

    Joined:
    Feb 22, 2015
  4. JronMasteR, Mar 24, 2015
    Last edited: Mar 24, 2015

    JronMasteR macrumors 6502

    JronMasteR

    Joined:
    May 4, 2011
    Location:
    Switzerland
    #4
    I have noticed similar things in certain games. With the 680 which I had before and also with the 780 I have now.
    I was mostly suffering from frame drops, stuttering and hitching.
    After trying all kinds of things, I discovered that if I disable 1 Cpu via msconfig the issue was gone. It seems that if the game uses cores from both cpu's, there is a latency issue. You could also use task assign to make sure that a game only uses one of the cpu's.
     
  5. Surrat macrumors 6502

    Surrat

    Joined:
    Jun 20, 2014
    Location:
    United States
    #5
    Thats VERY interesting, thanks for posting it. I never even thought of a problem like that cropping up.
     
  6. JronMasteR macrumors 6502

    JronMasteR

    Joined:
    May 4, 2011
    Location:
    Switzerland
    #6
    You're welcome. I hope it will help some other people with dual Cpu systems.
    I was surprised as well, but also very relieved at that time.
    First I thought it was because of the hyperthreading, since that is known to cause issues in some games. Sadly, you cannot turn off HT in Windows on a mac.

    I'm always using task assign now for every game. It is also better if you let games use only CPU B since that one runs cooler because its right at the intake.
    I've noticed some other nice things. Far Cry 4 was always bottlenecked by one maxed out cpu core. But when I set it to use only 4 or 6 cores, the load is spread very evenly across the cores and I get higher fps.
     
  7. Surrat macrumors 6502

    Surrat

    Joined:
    Jun 20, 2014
    Location:
    United States
    #7
    How do I tell what core is what on the processor affinity list? Are the real cores listed first, then the virtual ones? or maybe alternating?

    I also noticed that cpu 1 is always running hotter than 2, then in cpu-z in win81, I noticed that my cpu 1 is always on turbo mode, running at 3.33ghz. The second cpu is holding 3.06ghz, so that explains the higher temp. Seems strange to me though, I thought turbo only activated under high load.
     
  8. JronMasteR, Mar 26, 2015
    Last edited: Mar 26, 2015

    JronMasteR macrumors 6502

    JronMasteR

    Joined:
    May 4, 2011
    Location:
    Switzerland
    #8
    Can't really tell you which one is which. I think it's not one physical and one logical. The physical core just appears as 2 logical ones.

    Well, turbo will depend on how many cores are under load. If only one is under load, it will turbo to the max, if all are under load, it will stay at base or close to base clocks

    Edit: So I did some testing with geekbench 3 in W8. With CPU0 sore was 2300, with CPU0 and CPU1 ist was 2900. Multicore scores by the way.
    Seems that if a game is limited by a single core, it can help to assign CPU0, CPU2, CPU4 etc.
    By doing that you improve performance in games that don't like HT.
     

Share This Page