Mac Pro 5,1: HDMI delivers no sound

Discussion in 'Mac Pro' started by Jardins de Vin, Jan 2, 2015.

  1. Jardins de Vin macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #1
    Tried to connect my Mac Pro to a TV screen with HDMI, but the TV does not appear in the sound preferences.

    It's a Mac Pro 5,1 (mid 2010) and the card is a Sapphire 7950 with HDMI. The TV a Panasonic Viera.

    I read that some MacBooks from that era don't support audio through HMDI, I couldn't find anything about the MP but could it be that the same applies to this computer?
     
  2. OneAnswer macrumors member

    Joined:
    Sep 20, 2014
    #2
    The HDMI interface does not show up in the Sound Output preference pane?
     
  3. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
  4. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    It's normal, you have to install extra driver to activate "audio via HDMI"

    You may check you system info, there should an item under PCI card with no driver yet.
     
  5. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #5
    Yes, the 7950 appears twice and for one of them, there is no Driver installed. I guess that's what you mean? Or should it only appear once?
    And also - where do I get this Driver, is it a specific one for the 7950?
    I thought Mavericks already come with all the drivers for this card. :)
     
  6. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #6
    The one that with driver installed is the GPU. The one that with no driver yet is the audio part.

    Mavericks only contain the 7950 GPU driver, but no HDMI (display port) audio driver. You may check this post to get the 3rd party driver.

    http://forums.macrumors.com/showthread.php?t=1499797&highlight=hdmi+audio
     
  7. Jardins de Vin, Jan 2, 2015
    Last edited: Jan 2, 2015

    Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #7
    Thanks, I was not aware of this at all! :) Perhaps this is even the reason for my AHT error and it will be fully recognized after that! (yes it's me Bobcat, I changed my username and have an avatar now :D)

    Edit: it worked but the error is still there. Hehe.
     
  8. MadMarkC macrumors newbie

    MadMarkC

    Joined:
    Apr 1, 2017
    #8
    --- Post Merged, Apr 1, 2017 ---
    I had the same issue. I spent some time with an Audio Engineer at Apple and he came up with a solution that will deliver audio and video to HDMI. Amazon and others sell an adapter that will grab video from the MDP and audio from the USB port. I just ordered the adapter to see if it works... I am confident that it will do the trick. This will allow me to use wireless HDMI connections as I want to rip and burn on my Mac across the room to store on my 4 stack drive tower and be able to send movies to the TV in the living room. This will allow me to proceed with that plan. Here is the description you can type in or copy and paste to pull up the adapter.

    Mini Displayport 1.1 Male and USB Male Audio to HDMI Female Converting Adapter
     
  9. kwikdeth macrumors 6502a

    Joined:
    Feb 25, 2003
    Location:
    Tempe, AZ
    #9

Share This Page