MP 1,1-5,1 Mac Pro 5,1 High Sierra firmware issue

Discussion in 'Mac Pro' started by pierre1610, Jul 17, 2019.

  1. pierre1610 macrumors regular

    Joined:
    Feb 3, 2009
    #1
    Hi

    I have a 5,1 Mac Pro with a 2.5" Angelbird SSD on a PCIe card which has my OS on it.

    I previously had High Sierra installed on this exact setup.

    I did a clean install from a Sierra usb boot, I tried High Sierra usb boot stick first but it failed with the same error I'm getting when I try to upgrade.

    The drive is greyed out and the error says
    "You may not install to this volume because the computer is missing a firmware partition"
    The OS see's the drive as an external drive as its on a PCIe card.
    The drive is set to GUID Partition Map and Mac OS Extended (Journaled) format.

    What I don't understand is I previously had this exact setup running High Sierra.

    Thanks
     
  2. cdf macrumors 6502

    Joined:
    Jul 27, 2012
    #2
    I've ran into this issue before. If you make macOS see the disk as internal (you can use Innie), the error goes away. (Caveat: you need to do this from an existing installation, not a USB boot drive.)
     
  3. Soba macrumors regular

    Soba

    Joined:
    May 28, 2003
    Location:
    Rochester, NY
    #3
    What version is your system's Boot ROM? (You can find this in System Information.)

    And what version of High Sierra are you trying to install?
     
  4. pierre1610, Jul 18, 2019
    Last edited: Jul 18, 2019

    pierre1610 thread starter macrumors regular

    Joined:
    Feb 3, 2009
    #4
    Boot Rom = MP51.0089.B00
    (Weird thing is I have another machine, a 12 core, not 6 core that I've just done a clean install on too, High Sierra works on that one and its got the same Boot Rom)
    The only difference is the machine that upgraded to High Sierra with no problem doesn't have the boot drive on a PCIe card.

    High Sierra = whatever the version on the App Store is, not sure I can find out
     
  5. cdf, Jul 18, 2019
    Last edited: Jul 18, 2019

    cdf macrumors 6502

    Joined:
    Jul 27, 2012
    #5
    The Boot Rom is not the issue (although it couldn't hurt to upgrade it to the latest 144 version). The issue is that macOS is seeing your drive as external. You said you already have an installation on your 12 core. Use it (or any other full macOS installation) to install to your drive after making that system see the drive as internal.
     
  6. pierre1610 thread starter macrumors regular

    Joined:
    Feb 3, 2009
    #6
    You were right, i moved the drive into a SATA slot and managed to upgrade it. Strange i didn't have to with this machine last time.

    I looked at your thread, do i download from the link or the attachment on post 9 to get the drives to appear as internal?
    I'm a bit confussed, you refer to innie which is the kext in the attchment of the post. However your instructions say download lulu.kext
    Which is it?
     
  7. cdf macrumors 6502

    Joined:
    Jul 27, 2012
    #7
    It's both. Innie is a plugin for Lilu. You get Innie from the attachment in the thread and Lilu from the link. Follow the instructions and you should be good to go.

    That "missing firmware partition" error is really something of a mystery. Sometimes a PCI drive will just proceed with the installation no problem, other times you get the error, and even reformatting the drive doesn't help. Making macOS see the drive as internal always gets the installation going.
     

Share This Page

6 July 17, 2019