Mac Pro 5,1 with flashed GTX 970 experiencing graphics artifacts

Discussion in 'Mac Pro' started by high5ths, Mar 21, 2018.

  1. high5ths macrumors newbie

    high5ths

    Joined:
    Mar 10, 2011
    Location:
    NYC
    #1
    Hi, I've got a Mac Pro 5,1 with an NVIDIA GTX 970 4 GB from MacVidCards I bought in May 2015. It's been a fantastic card but I'm now getting some strange multi-colored graphics artifacts on my 4K monitor (Dell P2715Q). They appear even if that is the only monitor connected, and regardless of which port I plug the monitor in. I also tried switching DisplayPort cables. Sometimes the artifacts show up on a different monitor (the others are 1920x1200) but most of the time just on the 4K monitor. They happen randomly, even when the card is not working hard, but pretty much every day.

    Any thoughts about why this is happening or what I can do? Do you think the card is failing? I had hoped this card would last longer than three years. Could this be something else failing in the Mac Pro itself?

    I'm attaching an example picture with artifacts in the Finder window. Here's also a video where you can really see the fireworks: https://www.dropbox.com/s/83wkm5lbd6rrxd4/IMG_8616.m4v?dl=0

    Thanks for any guidance you can give!


    Jeff
     

    Attached Files:

  2. Flint Ironstag macrumors 6502a

    Flint Ironstag

    Joined:
    Dec 1, 2013
    Location:
    Houston, TX USA
    #2
    Usually due to overheating or dying VRAM. Have you thoroughly dusted the card?
     
  3. crazyhorse90210 macrumors newbie

    Joined:
    Mar 1, 2018
    #3
  4. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #4
    I've been having the same problems with the last several Nvidia driver versions with the 970 as well. I suspect it's not a hardware problem.
     
  5. Slash-2CPU macrumors regular

    Joined:
    Dec 14, 2016
    Location:
    New Orleans, USA
    #5
    Seeing the same thing. Odd colored patches in semi-transparent window headers.
     
  6. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #6
    May I know which GPU you are using? And if enable Reduce Transparency help?
     
  7. Slash-2CPU macrumors regular

    Joined:
    Dec 14, 2016
    Location:
    New Orleans, USA
    #7
    Flashed GTX 970(it’s in my sig). And yes, reduce transparency fixes it.

    The oddly colored areas aren’t constant. Once a day to every other day. Doesn’t affect stability or usability.
     
  8. PowerMike G5 macrumors 6502

    Joined:
    Oct 22, 2005
    Location:
    New York, NY
    #8
    I'm currently having this same issue with my GTX Titan X. It seems to definitely be a current web driver issue a multiple folks are having this issue. Of note, I never had these issues till this latest driver.

    Guess its the waiting game to be fixed in the next web driver or so.
     
  9. high5ths thread starter macrumors newbie

    high5ths

    Joined:
    Mar 10, 2011
    Location:
    NYC
    #9
    Thanks for your replies! I dusted the card but still was getting the glitches, but I'll try "Reduce Transparency" and the fact that others are seeing the glitches gives me hope that it will be fixed sometime. Thanks!
     

Share This Page