mac pro airport wireless problem

Discussion in 'macOS' started by nick_harambee, Jul 12, 2009.

  1. nick_harambee macrumors regular

    Joined:
    May 20, 2005
    #1
    Hi

    Up until now I have been using an ethernet cable to connect my Mac Pro to the local network/internet, but I have now moved house and need to use a wireless connection with Airport which worked fine in the last house, when i needed to use it, e.g. to connect to remote speakers.

    In the new house I have a Netgear Router for ADSL internet, connected to a Time Capsule which handles the wireless network. I also have an airport extreme to extend the network around the house. The Wireless signal to my Macbook Air and someone else's iMac are fine, but the wireless signal to the Mac Pro is weak (even with the Time Capsule about 8 metres away in the next room, and the Airport Extreme even closer). Sometimes I can't get any signal at all, sometimes it shows all three bars in Airport, but I get a self-assigned IP, other times I get a proper IP address and I can connect to the internet briefly, and then it cuts out again. I can connect fine using Ethernet still, but don't want to run a cable round the house.

    Using Airport Utility on the Mac Pro sometimes the Time Capsule and Airport Express show up, sometimes not. They always show up on the Macbook Air. I am using the latest firmware versions for the Airport Express and the Time Capsule, and the latest version of Airport Utility. The radio mode is n (b/g compatible) and the channel is 11. The country is the UK, multicast rate 11 Mbps, the transmit power is 100% and use interference robustness is checked.

    I wonder if someone would be able to help me troubleshoot this problem.

    thanks

    nick
     
  2. Aldaris macrumors 65816

    Aldaris

    Joined:
    Sep 7, 2004
    Location:
    Salt Lake
    #2
    Sounds like your airport card has gone bad... I had the same problem with my PowerBook G4, I'd take it to get it serviced or inspected.:confused:
     
  3. nick_harambee thread starter macrumors regular

    Joined:
    May 20, 2005
    #3
    it may be that the airport card has gone bad, but i want to eliminate other possibilities before buying a new card.

    i have checked the connections to the card in the mac pro, wire 2 going to the first terminal, wire 3 to the second terminal and nothing to the third terminal. all connections seem secure.

    once curious thing. when i run network diagnostics i get the following screen: The AirPort network "XXXXX" requires a password. but i haven't set a password for the network. even when i reset the Time Capsule, created a new network with a different name, I still got the same message asking for a password. perhaps this is connected to the problems i am experiencing
     

Share This Page